Question about Crown XS500 2-Channel Amplifier

Open Question

Crown xs500 power amp was turning on fault led when turned on. replaced r33,r35,r37 were open and replaced ic6. now when i turn on everthing turns on well and suddenly goes into protect. relays actuates power led turns on then goes into protect fault mode.canu help please.

Posted by on

  • JUAN HEUREAUX Apr 27, 2013

    OLA AMIGO YO CAMBIE IC6 CHEQUIE LA R33 R35 R37 ESTAN BUENA QUE MAS PUEDE SER SALE FULT

×

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: Crown ce 4000 amp wont work

Crown CE amps have a very decent service manual that give test points to check for faults. In these amps protect mode is a good sign that major components are not burnt out ie, (Transformer).
With a good Digital volt/ohm meter most common circuits can be checked against the service manual specifications. Usually in these amps the Zener Diode or Capacitors are the first to burn out along with cooling fans. That would be a good place to start.
Respectfully, Muzick

Posted on May 03, 2008

quang123
  • 107 Answers

SOURCE: i have a crown ce4000

I believed you got 1 or 2 electrolytic capacitors were dry out so it missed 17V + or -- regulators in the preamp sections that why both side light are on If you go to 1 of the service center Crown in your town it would cost you between $100 to $200 I use Australian dollars

Posted on Dec 01, 2008

  • 6 Answers

SOURCE: crown amp xs900 will not reset


naz, get a hold of crown, tell them whats up. check all fuses and connections first. the unit is worth $900.00. they should be a little understanding.

Features
 

  • 2-ohm dual (per channel) : 1200W
  • 4-ohm dual (per channel) : 900W
  • 8-ohm dual (per channel) : 600W
  • 4-ohm Bridge : 2500W
  • 8-ohm Bridge 2100W

  • Indicators for : Signal, Clip, Power, AC Mains, Fault, Bridge, Temp.
  • Housed in a rugged, all-steel 2U chassis
  • Microprocessor-controlled protection system.
  • Flow-through ventilation from front to back.
  • Internal heat sinks with forced-air cooling for rapid, uniform heat dissipation.
  • EIA Standard 19-inch rack mount width
  • Safe with all types of loads.(2 to 8 ohms in Stereo, 4 to 8 ohms in Bridge Mono.)

Inputs 

  • XLR-¼" combo connectors: One per channel
  • 3-pin female XLR connector and TRS ¼" phone jack accept balanced or unbalanced signals.
  • 3-pin Phoenix-style connectors (2-channel models only),One per channel, accepts balanced or unbalanced signals.

Output 

  • Balanced XLR connectors (2-channel models only)
  • One per channel, 3-pin male XLR connector in parallel with XLR-¼" combo and Phoenix-style input connectors for daisy-chain operation.
  • 5-Way binding post output connectors: One pair per channel; accept banana plugs, spade lugs or bare wire.
  • 4-Pole Speakon output connector (2-channel models only)
  • Accepts a 4-pole Speakon connector.

Posted on Jan 01, 2009

dunnbiker
  • 8546 Answers

SOURCE: i have a crown ce 2000 watt amp. channel 2 keeps turning off

Do you get any Fault indications?

Have you swapped the speakers around to eliminate them as external causes?

When the channel dies is the unit very hot and is the fan turning very fast (it should be if hot)? The fan could be defective, slow or airflow may be restricted.

Turn the amp off and examine the fan guard on the rear to make sure it is clear of dust and debris. Vacuum it out if necessary. With a small thin non-metalic object reach in and test the fan for free movement by trying to rotate it. It should coast.

Posted on Apr 28, 2009

Ganx
  • 113 Answers

SOURCE: The fault light immediately comes on my Crown XLS

Hi try disconnecting the speaker outs and turn off bridge (if its on) If it doesnt work still, then suggest direct to a crown agent. The amp has a 3 year no fault warranty. Hopefully its still in!

All the best

Posted on Aug 04, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My pioneer sx-950 blows 6 amp main power fuse, can't find problem. Replaced six of the power amp o/p transistors, two resistors r35 and r37. no change. help, thanks for being there, geo


Hi George,

I think I'd be looking more closely at the AC / DC section of power supply end of things. Six amps at 120V is about 700 watts and is more than any single channel of the amp. Look at the rectifier for burnt diodes, filter caps for bulging / leaking / etc. Something trying to draw 700W is likely to be a larger component - so I'd look there.

Good luck!

Feb 05, 2015 | Pioneer Audio Players & Recorders

1 Answer

I have a crown xs500 amplifier. The right side stopped working. I got the "clip" light and the green light for about a minute as I was testing it, then both lights are out all together. This...


With a crown amp it can be any number of things. I would recommend having a service center test it and send it back to you. Working with the interior of a commercial amp can be hazardous because of the size of the capacitors inside of it. For the future I would recommend always having the amp turned of for any connection or disconnection of equipment.

Mar 22, 2011 | Crown XS500 2-Channel Amplifier

1 Answer

I have a Braemar LCB450-G evaporative cooler. There are two Diagnostic LED,s on the electrinics module,one red & one green. When the power is turned on at the module the red LED remains on & the...


There are several possibilities, the drain valve is opening and closing, this causes water to fill the base, the float valve will not achieve the desired level so the fan will not start. This could be the drain valve actuator is U/S or the PC board. Have you tried to turn the main power off at the switch board for 1/2 hour?
Most occasions the service person will swap out all the units as they purchase it as a package. It is not cheap to replace these units.

Nov 22, 2010 | Heating & Cooling

3 Answers

Fan don't work when power is turn on crown xti 4000


the fans on these amps are heat sensitive, only when the amp heats up, then they come on

Mar 27, 2010 | Crown XTi 4000 Amplifier

1 Answer

Rockford t20001 bd amplifier no sound.


Disconnect your subs. Chk the impedance with an ohm meter. They should read apx 4 ohms or 8 depending on woofer. If they chk ok chk the remote turn on for voltage when system is on.

Jul 29, 2017 | Rockford Fosgate T20001 bd Car Audio...

1 Answer

The fault light immediately comes on my Crown XLS 602 power amp immediately upon turning it on. It will not go out?


Hi try disconnecting the speaker outs and turn off bridge (if its on) If it doesnt work still, then suggest direct to a crown agent. The amp has a 3 year no fault warranty. Hopefully its still in!

All the best

Aug 04, 2009 | Crown XLS 602 2-Channel Amplifier

1 Answer

I have a crown ce 2000 watt amp. channel 2 keeps turning off


Do you get any Fault indications?

Have you swapped the speakers around to eliminate them as external causes?

When the channel dies is the unit very hot and is the fan turning very fast (it should be if hot)? The fan could be defective, slow or airflow may be restricted.

Turn the amp off and examine the fan guard on the rear to make sure it is clear of dust and debris. Vacuum it out if necessary. With a small thin non-metalic object reach in and test the fan for free movement by trying to rotate it. It should coast.

Apr 27, 2009 | Crown CE2000 2-Channel Amplifier

4 Answers

Yamaha YST-MSW10 subwoofer quits after about 10 minutes


This problem can be solved by either of the following:
1/ Modify the PCBA to prevent the auto shut off feature from working. This is done by adding a 20k ohm resistor across pins 1 & 2 on the timer IC6. This resistor will prevent the timer from turning off the amp. To do this, unplug the amp. Remove the 8 screws on the perimeter of the rear of the amp. Carefully remove the rear plate. Disconnect the speaker wires at the speaker and the front panel connection on the main board. Locate IC6 on the bottom of the main board. Solder a 20k ohm resistor (1/4W) across pins 1 & 2. Pin 1 and Pin 8 are noted on the board. Be sure to insulate the leads of the resistor to prevent contact with the board. See picture. Re-assemble in reverse order.
2/ Some 5.1 channel amps allow independent control of the volume for the subwoofer in their setup. Check your amp to see if you can raise the signal level going to the subwoofer to prevent the amp from shutting off. You can then dial back the volume of the subwoofer using the volume control on the front._436.jpg

Aug 07, 2007 | Yamaha YST-MSW10 Computer Speakers

Not finding what you are looking for?
Crown XS500 2-Channel Amplifier Logo

Related Topics:

335 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crown Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5056 Answers

The Knight
The Knight

Level 3 Expert

74136 Answers

Paul Bade

Level 3 Expert

1536 Answers

Are you a Crown Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...