Question about Waterway Spa Pump Executive 56 Frame 4hp Dual Speed 2" Intake 2" Discharge

1 Answer

My 4.0 hp waterway excutive pump works, the shaft spins, but no water movement, i checked for airlocks, could it be the grey propeller inside the wetend thats not working? is it worth a look inside the wetend?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Waterway Master
  • 1,378 Answers

Thank you for posting your question here on Fixya.com.


Yes...you'll likely find the impeller body has broken away from the motor shaft so even though the motor turns the impeller is not. Replacing the impeller and the seal are not to hard but you may want a shop to do it if you are not familiar with seal replacement. While they have it they can make sure the motor bearings are still OK since the most common reason the impeller breaks is a seal leak that leads to motor shaft and possibly motor bearing damage.


If this answer does not fix your problem, please comment with additional details prior to rating the answer. You may also contact me thru our website at www.arrowpools.net. Positive feedback is appreciated once your problem is solved!

Posted on Mar 17, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1973 evinrude 25 hp motor that does not circulate water through. I took out the water pump and the rubber propeller is in good shape.Any other ideas?


look at the prop part closely

see if the water flushes fully through the block without the pump fitted
seals
blocked gauze/water pick up fouled

i know these corrode even with the best of flushing
make sure the pump drive shaft is spinning with the base of the motor sometimes the shaft spline will splinter or break



26251917-axvwupmg4kugekg2jlvo4qzx-4-1.jpg

Aug 04, 2016 | Boating

1 Answer

I have a Waterway 48-Frame 2HP 115v pool pump for my above ground pool. I just purchased it about 2 weeks ago from Rec Warehouse. It was working good no problem for about a week and half then all of of...


Check to see that the pool pumps mounting is secure. Loose mounting could cause the motor to run loudly. It could be bearings rubbing or a bent shaft. If it is new, this should not have happened. If you check the mounting and feel that it is secure, I would return the pump to an authorized Waterway service agent and let them look to see if the bearings or shaft are damaged. I would do this quickly while you can still return the pump if its defective.

Jul 04, 2010 | Waterway Spa Pump (Side Discharge) 1 HP...

1 Answer

Installing seal kit on hot tub waterway pump and can not get impeller off it broke I got shaft locked down so it will not spin even bought a strap wrench damm thing will not budge it is part number 310...


I can't say for sure if it is on your model and I don't rember where it is located. But some of these had impellors that had a allen screw that locked it to the shaft. I know this is not much help but I hope it helps.

May 10, 2010 | Waterway 5 Hp 230 Volt 2 Speed Side...

2 Answers

The pump is not pushing water through. Wat is the


ure the propeller and shaft turn, but I woulsd dare to say that they are actually turning independant of each other. Sort of like a stripped nut on a bolt. They both look like they are in place and working, but when you add any sort of pressure they just don work the way that they are supposed to. I bet the shaft is actually spinning inside of the propeller, as soon as the water pressure is built up, it fails. Spinning it with your fingers will not imitate the real life pressures exerted on the propeller and shaft, that the water pressure exerts under load (in operation). I would either rebuild it with new parts (new shaft and Propeller) or just go out and buy a new one with a warranty. There is no other reason why this pump will jnot throw water through your system... NO REASON, unless you have the thing hooked up wrong, but I think that would be impossible, wouldn't it?

Apr 24, 2010 | Intex 2500 Gal Easy Set Swimming Pool...

2 Answers

Our hot tub uses a Waterway Pump. We emptied the water and refilled it with clean water. The pump now just hums... and doesn't pump. Did we do something wrong? Is there a solution. It is 220V. The...


Was the pump working prior to the cleaning or had it been sitting dormant? The motor relies on a starting circuit within it to operate. One of the components can be bad or the pump can be siezed up.

Turn off the power and remove the back cover from the motor. Try to turn the shaft by hand. Is it free to turn? If so, the problem is inside the motor. If not, look for the obstrction.

A local electric motor repair shop can help you if you find damage in the motor and/or pump.

Dec 27, 2009 | Waterway Spa Pump Executive 56 Frame 4hp...

1 Answer

How do I get to the pump seal on my hi-flo water


The impeller threads off the shaft and most likely is right hand threads. You will have to lock or hold the motor to remove the impeller. If you remove the motor cover you might find that the motor has a slot in the end of the shaft or two flat sides so you can hold it with a flat wrench.

The impeller is probably plastic and could break. Get a strap wrench to remove the impellor.

Sep 20, 2009 | Waterway 1.5hp Hi Flo Above Ground Pool...

1 Answer

Whirlpool model gsl9365ez2 / doesn't agitate or spin


Check your drive coupler, its located between the motor and transmission

Mar 19, 2009 | Whirlpool Washing Machines

1 Answer

Sounds like it the pump needs to be oiled...how?


sometimes debris makes it way into the propeller shaft housing making an extremely bad noise pull it apart clean it out and see if the noise stops remember always wash aquarium filters and parts with the water from the tank or pond it came out of or bacterial quality will be disrupted causing the inhabited to suffer

Sep 27, 2008 | Waterway Supreme Hi Flo Pump Dual Speed 2...

Not finding what you are looking for?
Waterway Spa Pump Executive 56 Frame 4hp Dual Speed 2" Intake 2" Discharge  Logo

134 people viewed this question

Ask a Question

Usually answered in minutes!

Top Waterway Garden Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Mike Raino

Level 1 Expert

16 Answers

john h

Level 3 Expert

12650 Answers

Are you a Waterway Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...