Question about QSC GX3 Amplifier

1 Answer

One channel's red led is always on and no sound

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 8,546 Answers

Register and download the manual for free at retrevo.com

http://www.retrevo.com/support/QSC-GX3-Amps-manual/id/23107ag606/t/2/

See page 7.

"CLIP: red, to the left of each Gain control.

Normal indication: illuminates whenever the amplifier is driven beyond full power. The LED's brightness indicates the amount of distortion. Distortion that causes only brief flashing may not be audible.

During muting, the indicator fully illuminates. This occurs during normal "On-Off

Posted on Mar 17, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What's six red blinks at sony tv?


Hi, [Error code 6. LED flashes 6 times]. Malfunction of inverter or overcurrent protection....regards Sean

Jan 15, 2016 | Sony BRAVIA KDL-32BX330 32" 720p HDTV with...

1 Answer

How do I fix channels with no sound


Mute Switch/Mute-Clip LED :
  • This switch mutes all Aux, Group and L/R sends from the corresponding channel.
  • This switch is equipped with a red LED that will illuminate when the channel is muted.
  • When the MUTE button is out,the LED functions as a Clip indicator that will illuminate at 2 dB below clipping.
  • Muting the channel does not prevent the PFL signal from being sent to the PFL/AFL mix when the PFL Switch (12) is in.
  • This switch mutes its respective Group send from the Group channel.
Go to page 11 in this link :
Peavey FX Mixer Series Operating Manual

You can also try, Restoring Factory Settings, in the Utility Menu Options.
Go to page 16 in ths link :
Peavey FX Mixer Series Operating Manual

CAUTION:
Restoring the factory settings option resets your mixer's presets, reformatting factory presets and erasing all other user presets. (This option is handy when your venue has permanently changed and all-new presets are required.)
Once confirmed, the presets are not retrievable and will be permanently lost.
Should you select this option in error, a warning screen allows you to cancel the procedure.

Sep 05, 2015 | Peavey 32fx USB 32 Channel Mixer

1 Answer

Royce 642 CB led display always shows one channel higher than what the radio is operating at? If I want to operate for eg. on CH19 I have to select CH20 on led display!


you may have to go thru all the channels and reset them to their correct frequencies . reset the radio to channel one and the top channel always going back to channel one to get a balance between all channels . If that is to much work and you don't mind the problem and can deal with it then leave it as it is .

Sep 09, 2013 | Cobra 29 LTD CB Radio

1 Answer

Sharp LC37D44U Power LED was flashing green. TV would turn on, channel indicator shows in upper right corner, sound good, but screen would be black. Channel indicator disappears but screen is still...


I had the same problem. all the service reset would only make the display come on for a few second with no "k" on the screen - only the channel would show up. I purchased a complete set of board for the lcd on ebay, and started swapping them one by one. The inverter boards were the culpret. Tele working 100% since that board swap.

Nov 16, 2010 | Sharp Aquos LC37D44U 37 in. LCD HDTV

1 Answer

No sound/picture and red power light always on (Hitachi 43FDX15B)


When u turn the tv on,u hear alot of clicking?That mean the Ballast that help the projection bulb to work is dead.Change the Ballast,might as well change the bulb too.U don't know what is the condition of the projection bulb in.

May 29, 2010 | Hitachi 43FDX15B 43" Rear Projection...

2 Answers

Retuning Philips DTR 1500 digibox


Had same problem. Remedy is to put digibox back to factory reset. Dis-connect from mains. Keep pressing + button on front panel as you re-connect to mains. Red LED will be on, when orange LED blinks release + button. briefly press + button. You have solid red LED and blinking red LED. Enter code 9 9 0 0, by remote blinking LED will show green. Wait a few minutes and the instalation page will appear on screen. Go to update and start as you did before and C5 should be installed. Hope that helps.
Dave

Sep 30, 2009 | Philips Televison & Video

1 Answer

Sound problem on Sony TA-343 amplifier


If you're not experienced with troubleshooting and repairing electronics, I strongly suggest professional service. There are internal problems and most likely several components will need replacement.

Oct 08, 2007 | Audio Players & Recorders

1 Answer

Stop putting out sound to subs


Ok This is a two channel High Current amp. It is stable to one ohm. If the Subs are single voice coil at two ohms the they have to be wired in Parallel that means (Red +) (Black -) are connected to the + and - of another sub and then the (RED +) (Black -) from both go to one output channel of the amp. You pair the other two in the same fashion on the other output channel. If you are getting no output (sound) at all first check if the amplifier is going into protect. (Usually indicated by a red led on the unit. If it is connect only one Sub to each output and see if the protect LED goes out. If it does then you should have sound at the subs. If not check that you have the sub output enabled on the HU some head units do not come with the sub output enabled on the HU. If every thig is enabled, with only one sub connected to each output and the protect LED is not on then your amp is probably blown and needs repair. Nice thing is that MA has a great warrenty policy. Check and make sure the protect LED is off. If it is on you probably have the SUBS wired wrong

Jun 23, 2007 | MA Audio HK802SX Car Audio Amplifier

Not finding what you are looking for?
QSC GX3 Amplifier Logo

431 people viewed this question

Ask a Question

Usually answered in minutes!

Top QSC Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

Brad Brown

Level 3 Expert

15478 Answers

Gil Shultz

Level 3 Expert

3368 Answers

Are you a QSC Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...