Question about Hoover Vacuums

Open Question

I have Hoover WindTunnel Air Upright Vacuum - UH70400 just used couple of times. While vacuuming the carpet carpet fringes were rolled up in to brushroll and brushrol stopped working. It means vacuum is not working effectively now. Brushroll indicator is flickering.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
reddevil6
  • 1673 Answers

SOURCE: Broken piece

You will have to replace the brush roll, part #60844-5, belt # 61120B. You should be able to get them from a repair shop, get the right one or it won't work right. You maybe able to go eureka.com and order direct.

Posted on Mar 02, 2008

Ad
reddevil6
  • 1673 Answers

SOURCE: Brushroll engagement at carpet mode doesn't always work eureka 4870

Is the brushroll ends turning freely? if not then replace it, There could be a problem with the belt, or with the idler clamp asm. Sometimes they get clogged up with debris and won't work properly, try cleaning it. This is what lets the brush turn or not turn, depending on the position of the switch.

Posted on Mar 11, 2008

Pnutgllry
  • 57 Answers

SOURCE: Had a problem with the brushroll now its burning up the flat belt

When you put the flat belt on, is the print on the outside of the belt? Is the brush correctly positioned?

Posted on Jan 06, 2009

  • 1 Answer

SOURCE: Eureka 4870 vacuum brushroll control doesn't work

Use two hands to presscontroll button upward until it snaps in place.

Posted on Jan 06, 2009

advacak
  • 125 Answers

SOURCE: brushroll wont roll

likely the belt is crooked, and jammed in the floor plate. try reseating it.

Posted on Mar 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Changed belt , it broke again not sure why


gotta make sure both ends of brush bar are clean and turn freely

Apr 22, 2015 | Hoover U5753-900 WindTunnel Bagless...

3 Answers

Brush won't spin on hoover wind tunnel bag less upright when on carpet, belts are fine


The belts may look fine but may be stretched and worn. Replace them. Make sure brush spins free. Idler pulley should tighten belt tension when handle is released

Jul 25, 2014 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Why does The beater bar on my hoover continue to run in the upright position?


Hi there! Some vacuums do not come with the feature that automatically shuts the brushes off when in the upright position.. If your unit is like this, be sure to put the vacuum on the highest setting when using the hose. Also, because the brush-roll continues to spin, avoid tipping cleaner or setting it on furniture, fringed area rugs, or carpeted stairs during tool use. Hope this was helpful!

Jul 21, 2014 | Hoover Vacuums

1 Answer

Hoover model U6425-900 brushes do not roll


-- Make sure slide switch is in carpet position
-- The idler arn which tensions the brush belt may be broken
-- The idler arm override which is attached to the carpet slide switch may be broken

The second one is common.

Oct 30, 2011 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

I've had the Hoover Windtunnel for a couple years now. Its starting to smell when you vacuum. Why and how do I fix it???


I was experiencing the same problem right after changing the belt for the first time, as my Hoover is just a few months old. I am assuming what you are smelling is burnt rubber, like your belt, right? Well, if you have changed your belt recently, make sure you are using the right one. If you're not using Hoover's authentic belts and you're buying it from Wal-Mart, make sure it's the correct one, otherwise it won't work right and/or it will give off a burnt rubber smell. One other thing you could try doing first, is raising the carpet height adjustment up a notch or two. If you have it too low and your beater-bar/brush roll has to work too hard, it will start to smell also.Good luck!

Aug 07, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Dark marks on carpet after using hoover


these dark marks are burn marks from the beater bar itself. most walmart, kmart, and target shelf vacuums from hoover, dyson, and any cheeper vacuum has a hard bristle system. I've noticed even on the high end hoovers as well that they do the same thing. the best way to save your carpets is to see if there is a replacement beater bar that can be substituted for your vacuum. i dont know what style of beater bar that particular one is but check with your local vacuum repair center to see if they have something with softer brushes you can use insted otherwise i would recommend a new vacuum with softer bristles. usually something that is half as stiff as what is already on yur unit. you culd also try lifting the hight setting as a temporary solution.

Sep 06, 2008 | Hoover U5450-900 Windtunnel Supreme Bagged...

1 Answer

Dog hair from vacuum is being laid back onto carpet


my plush carpet and dog hair do not go together! I realized with this particular model and in my environment, the bag fills in one vacuuming! I literally dug out all the dirt I could by taking it apart and then changing the bag. Voila!

Mar 31, 2008 | Hoover WindTunnel Widepath U5397 Vacuum

1 Answer

Hoover Windtunnel


Sounds like you have a bad brush roll(48414115), take it out and see the the ends turn freely or not, if not, then replace it. Also check the the slots that the brush roll sits in to make sure they haven't melted. I am assuming that the motor is running, if not, then it may have froze up.


e6c90bc.jpg

Feb 28, 2008 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover u8147-900 upright vacuum


Either the brush rolls are bad, at the ends, or the gear/motor asm. is bad.

b095bb5.jpg

Dec 29, 2007 | Hoover U8147-900 WindTunnel V2 Bagless...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

122 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18408 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1467 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...