Question about Car Audio & Video

1 Answer

My amplifier stop working - Car Audio & Video

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 72 Answers

Check for power to the amplifier and check for shorts. as well as the remote turn on wire. (blue)

Posted on Mar 16, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

HOW CAN I REPAIR CHANNEL ONE ON CROWN CE2000 IT IS NOT WORKING TWO WIRES BECAME IN CONTACT WITH EACH OTHER


The power amplifier section should be troubleshoot for shorted output IC or transistor. If you wish to get some details; visit the site linked here. Pull up older posts. Surf the site with patience. http://electronicshelponline.blogspot.com/

Jun 21, 2015 | Crown CE2000 2-Channel Amplifier

1 Answer

Russound x75 stopped working wont power on


Check the fuse! Is it plugged in? Is it turned on. Have you read the manual?

Jun 27, 2014 | Russound X75 Amplifier

1 Answer

One of the channels is'nt working it just stop playing


I have the same problem, did you ever get a solution?

Apr 30, 2012 | Technical Pro LZ-1100 Amplifier

1 Answer

Car amplifier stopped working.


what gauge wire are you using

Apr 24, 2012 | Car Audio & Video

1 Answer

Subwoofers stop working after few seconds


Check the subs wiring... follow the manual....

Jul 16, 2009 | Car Audio & Video

1 Answer

Apx stopped working, MTX 702x


maybe the audio amplifiers Ic´s damaged or the power fet

Mar 06, 2009 | MTX X Thunder 702X Car Audio Amplifier

1 Answer

Kenwood 9102d wont power on


YOu might have burned out the inner fuse. Better yet the source connect...

Nov 06, 2008 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Just died out..


Have you determined if the problem is with the amplifier or the subwoofer?

 

Have you checked the wiring to make sure that there are no loose connections?

Oct 18, 2007 | Alpine MRP-M450 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

The Knight
The Knight

Level 3 Expert

74136 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...