Question about Eureka Vacuums

3 Answers

Burning smell, loud, no suction - Eureka Vacuums

Posted by on

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 77 Answers

Check brush roll, replace belt.
Jim

Posted on Aug 02, 2008

The vacuum tube could br plugged right at the bottom. Take off the bottom cover (screws in indentations in the cover, Then clear out the gunk at the bend in the vacuum tube. I used another vacuum to get it out.

Posted on Sep 28, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Throw it away and buy a kirby

Posted on May 30, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hoover Dimension has no suction and it smells of something burning


pets in house? check all hose passages for "hairball" clog...and check the drivebelt that spins the brush...(some have an electric motor to spin the brush, thus no belt)

Nov 02, 2012 | Hoover Bag Paper Microfilter Dimension...

1 Answer

No suction on my Hoover Dimension


If you smell something burning unplug until problem is found and fixed, suspect if no suction hose is blocked and if brush wheel it or the belt may be causing the smell, a bad or failing motor is less likely but possible.

Nov 02, 2012 | Vacuums

1 Answer

Electrolux cylinder vacuum No suction and loud noise and smell of buring rubber


rollers are probably stuck the belt is burning check for restrictions in you hoses as well as in the vacuum as well if nothing else works a repairman

Jul 13, 2012 | Vacuums

1 Answer

DC17 very loud and has a electrical burning like smell


Hi there,

I'm sorry to hear you're having difficulties with your DC17. If the machine is making an unusual noise, and you can smell burning, I'd advise you not to run it again, and to contact us directly so we can provide further assistance. You can call our Helpline free on 1-866-693-9766 - or if you email your contact details to askdysonUS@dyson.com, someone will be in touch as soon as possible to help.

We'll look forward to hearing from you.

Best wishes,

Jack
Dyson Online Customer Support
http://www.dyson.com

Feb 01, 2012 | Dyson DC17 Animal Bagless Upright Cyclonic...

1 Answer

Hoover H3030-006 240 V Motor making a loud sound and burning smell


If you have little to no suction, that sound is happening because you most likely have a clog some were in the vacuum.

smell is probably your motor over working itself do to the clog.

also double check your belts on your brushes that they are moving with the motor. smell and sound could come from the brushes being jammed which would cause the belt to freeze and heat up and could burn the belt and or your motor.

if it is still running though your not in the red yetm so triple check that the machine is cleared off all clogs and jams in the belts and brushes.

Jul 02, 2011 | Hoover H3030 FloorMate SpinScrub 500...

1 Answer

Not suctioning/


i would change the belt and filter.( belts need to be changed on average every 6 months). now if you smell a burn like an electrical smell the motor is gone.

Jul 19, 2009 | Dirt Devil Featherlite Bagless Vacuum...

1 Answer

No suction, burning smell, expells dust


If by "suction" you mean it's not picking up dirt and debris on carpet, odds are your belt needs replacement, and the belt has burned, causing the burning smell. Ensure that your brushroll spins free, and replace the belt. (Belts should be replaced in any vacuum with a rubber belt every 3-6 months, regardless of use.)

If you mean that you are not having any airflow at the end of the hose, you most likely have a clog in the main hose and the burning smell is caused by your motor overheating. Ensure that there is nothing blocking the hoses.

If you have suction in the hose, and your brushroll is turning, there may be a clog in the head area behind the brushroll. Look in the hose that your wand plugs into, and ensure that it is also clear.

-R

Aug 05, 2008 | Eureka Vacuums

2 Answers

Eureka 5197 self propelled bagless upright


Did you check the brush roll when you changed the belt? The smell of rubber would inducate a belt slipping. So if the brush roll (part #61308-2)isn't turning, the belt would get hot and would be slipping. If the motor sounds real loud, then you could have a bad motor(part #60775-4).

Feb 14, 2008 | Eureka 5197AT Upright Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

356 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Jim Parker
Jim Parker

Level 3 Expert

1040 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...