Question about Hoover Vacuums

1 Answer

The red replace bag came on so i replaced the bag when i turn it on again the red light is still on

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Welcome Back:

    Visited the website for 2 consecutive days.

  • Contributor
  • 31 Answers

Make sure you have the bag on tightly. Also...before you replace the bag, check and see that there is no dust remaining in the tube going to the bag. It could be clogged and blocking the sensor to the red light; which is keeping it on.
Good Luck and I hope this hint helps you out.

Posted on Mar 14, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bag light wont turn off


Hi there! The vacuum may be still sensing dirt in the cleaner. Try wiping the area down in and around the bag port. Be sure you are replacing the bag with a genuine Hoover Type Q bag. Also, when assembling the bag remember to slide the red bag door lock to the right to lock it on. If the check bag indicator light still comes on there may be an issue with the sensor on the vacuum. We would recommend taking your vacuum in to a Hoover authorized service center for repair. Hope this helps! Service Center Locator

Sep 13, 2014 | Hoover Platinum Collection Upright Vacuum

1 Answer

Light keeps blinking


http://www.searspartsdirect.com/partsdirect/user-manuals/uh30010com-hoover-parts-vacuum-manual
WARNING: TO REDUCE RISK OF PERSONAL INJURY - UNPLUG CLEANER BEFORE SERVICING
PROBLEM POSSIBLE REASON POSSIBLE SOLUTION

2. Blown fuse or tripped breaker.
4. Thermal protector activated. (power
light is flashing)
1. Disposable bag is full. ("Check Bag"
indicator illumJnated red)
1. Disposable bag not installed correctly.
3. Brushroll is worn out.

2. Check fuse or breaker in home. Replace fuse/reset breaker.
4. Turn the cleaner off and disconnect it from the electrical
outlet. Then allow cleaner to cool for 30 minutes. If the
thermal protector continues to activate see Needs Service
solution #5.
1. Replace disposable bag - Pg. 9.
1. Review disposable bag removal and replacement - Pg. 9.
3. Replace brushroll - Pg. 10.

Turn the cleaner off and disconnect it from the electrical
outlet. Then allow cleaner to cool for 30 minutes. If the
thermal protector continues to activate see Needs Service

Mar 11, 2014 | Hoover UH30010COM Bagged Vacuum

1 Answer

HOOVER Freespace TFG 5123 - Red Light?


Check the entire flow path from intake to bag. You may find it is clogged.

Dec 12, 2013 | Vacuums

1 Answer

I have replaced the bag, and both filters and it still doesnt have good suction and the full bag light is still on, whats the problem?


You probably have a clog in either the hose, or the dirt inlet by the brush roll. That red light is telling you that either the bag is full or a clog is not allowing suction..

Nov 28, 2012 | Dirt Devil M082475 Bagged Canister Vacuum

1 Answer

While vacuuming the red light for the bag of the vacuum came on and the vacuum stopped. The bag was no where near full so I replaced it with a new bag - same problem. It vaccumes for a minute or then stops...


I'm assuming this is the Epic 6500 or similar model.
Detach the hose, turn vacuum on. If it runs, place palm of hand against inport hole. If it shuts off the problem is with either the control valve setting or the control valve assembly itself.
For cvs, turn dial on top of vacuum all the way to the largest dot, and try above test again. If that doesn't work, then it's the CVA. It needs to be cleaned or replaced, which is an in shop job. Fro repair, take it to the nearest Aerus Electrolux store. I recommend a full clean and service to remove any dust/dirt from the motor, fan assembly, and other internal parts.

Another problem, which relates to the dial setting, is that fine dust will quickly clog the pores of the bag, resulting in the machine "thinking" the bag is full. Turning the dial to the proper setting helps get the bag fuller. The middle setting is the normal setting, and is for areas without fine dust and sand.

Dec 05, 2010 | Electrolux Vacuums

1 Answer

It is switching itself off and red light is on for bag, but bag is new


Almost certainly there's a blockage somewhere. You should try the following, in the order given: remove the flexible hose from the top of the machine, check the hose and its socket for debris and clear if necessary, then switch on. the red bag light should not be illuminated. Check that the bag light is operating correctly by placing your hand over the hose socket to block the air flow - the light should come on, and go off again when you remove your hand. If all is well so far, replace the hose in its socket and then remove the rigid plastic tube at the other end of the hose from its socket in the base of the machine and go through all the tests as before. Finally, turn the machine over and check in the little trap door (again looking for blockages).
That should cover it. If this doesn't solve the problem, post a reply here and I'll see what else I can do for you. Good luck! I value feedback, so please remember to rate this solution - thank you!

Mar 03, 2010 | Sebo Automatic X1 Bagged Upright Vacuum

1 Answer

What is the symbol above the "change bag" symbol?


When the bag is full, the "full bag" light will come on and will turn itself off. Replace bag (make sure there is no clog) and try again.
Hope this helps.

Aug 17, 2009 | Electrolux Epic 6500 Vacuum

1 Answer

Wind tunnel two with bag, started with burning smell then shut off with red light on. Belt is fine but cannot get it to start again.


Sounds like your motor.Try replacing the brushes in the motor.If that does not work then the windings in the motor have burnt out.

Aug 01, 2009 | Vacuums

1 Answer

Vacuum just stopped working.


is there a filter in it if so clean the filter.try it without the bag in it.make sure the bag is in correctly.does the bag expand when you turn it on.you might have something caught up in the hose.take the hose off and blow througfh it.if you can't its clogged.also check the inlet where the dirt goes into the bag.the inlet might be clogged.please leave feedback

May 04, 2009 | Electrolux EL7020A Oxygen 3 Ultra Canister...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...