Question about Bissell Velocity Bagless Upright Cyclonic Vacuum

1 Answer

We took the vacuum apart including all hoses and there does not appear to be an obstructiobn, what is causing the vacuum to lose suction

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 694 Answers

The fan/impeller could be broken or too worn to provide suction. Check it and replace if necessary.
Did you clean/replace the filters? Instructions for doing so can be found on page 16 of the manual.
Other things to check can be found on page 17 of the manual.
The manual is found on the following site.

http://dl.owneriq.net/b/bd974215-7845-4e77-b433-52ef08093176.pdf

Posted on Mar 13, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No Suction


i about to say that's always a clog of some sort that causes that

Jan 31, 2013 | Miele S7210 Bagged Upright Vacuum

1 Answer

I have a Kenmore "Intuition"


I had a different vacuum that did this. I took all manner of things apart looking for blockages and the like .I found that by having the vacuum handle in the full upright position shuts off the suction to this area and doesn't power the brush BY DESIGN. I think this is to get more suction to the hose.

Dec 18, 2017 | Kenmore 25512/ 25513 Progressive Canister...

2 Answers

Disassemble electrolux olympia one vacuum.


Four nuts in rear housing, deep inside. Motor slides out after they are removed.

Jan 17, 2010 | Electrolux Vacuums

1 Answer

No suction to the canister


Sounds like you have a blockage somewhere. I would take the hose off the canister and test for good suction. if ok then you have an issue with the hose and wand assembly. follow this to determine where you lose suction.

I’m happy to assist further over the phone at https://www.6ya.com/expert/robert_b96ba3f038cf317c

Oct 20, 2009 | Vacuums

2 Answers

The dirt devil vision wide glide Model 086700W appears to have no suction. I have cleaned the hoses and filter and still there is nothing being picked up. Also, I have checked the belt.


there must be a blockage after the hose, check where the hose plugs into the vacuum. make sure unit is un plugged for safety

Aug 09, 2009 | Vacuums

1 Answer

Bad suction on bissell powerforce bagless vacuum


I took the bottom apart and it needed a new belt and that was the problem so it's fixed.

Jan 16, 2009 | Bissell 6594 PowerForce Bagless Upright...

Not finding what you are looking for?
Bissell Velocity Bagless Upright Cyclonic Vacuum Logo

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Brad Brown

Level 3 Expert

17326 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...