Question about Northstar Garden

Open Question

North star eletric hot 2000 psi 3.5 gal per min oil pump had blown shaft seal. replaced with new pump. put small allen plug in return port. I have oil flow to the pump but none comes out port leading to burner even with shutoff switch removed and pump turning. Installed test gage 0 pressure. Took off bypass line and ran into can. pumps small amount of fuel into can that way but with uneven flow & small bubbles. nomatter what I do I just can't get fuel outlet port to burner. pump # A2VA-7116 please help

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 68 Answers

SOURCE: I want to remove the 4gpm pump on my pressure washer.

HI, It sounds like it is just stuck on the keyway as these can be very tight. You need to force the pump of evenly on either side and should come of if patient.

Posted on Feb 08, 2010

Testimonial: "I'm sure the answer is correct. Over time my use of harsh chemicals no doubt corroded the key-way."

Ad
wmpcs
  • 100 Answers

SOURCE: I have the Troy-bilt 2550 psi pressure washer with

I would replace the internal part of the unloader valve, it is known as the unloader seat, I can order you one it would take 2-3 days, Part number is 193972 price is $45.06. If you are interested in ordering one send me a email at justin@wmpcs.com with the information that I just gave you.

Another thing that you can check is the outlet check valve, the tube that you screw your high pressure hose onto has a valve built into it, if that valve went bad or if there is something stuck in it you would also have this problem. If you take the tube off the valve will be right where you screw that pipe onto the pump, the valve is part number 190592, price on this is $8.16.

Posted on Nov 10, 2010

kel1guy2002
  • 3740 Answers

SOURCE: I have a Pressure Washer VR2500 , 6.5 horsepower /

Hi and welcome to FixYa, I am Kelly
First here is the owders manual:
http://www.excellpressurewasher.com/documents/pdf/D30494-E.pdf

There are 3 versions of the VR2500 Pressure Washer.

1 being the VR2500 Type 0 It has the comet pump that needs no oil
2 being the VR2500 Type 1 Also with the comet pump.
3 being the VR2500-C Again with the coment pump

The allen set screws that you removed hold the bearings in place.

The only pump maintence required is winterization with either a winterizer EX80 or RV anti-freeze

PUMP

The manufacturer recommends using

a pump protector/winterizer, such as

EX80, when storing the unit for more

than 30 days and/or when freezing

temperatures are expected. If a pump

protector/winterizer is not available,

*RV antifreeze needs to be run through

the pump as outlined in the steps
below.

EXCell does make units that have an AR pump that requires pump oil. The VR2500 pump does not.

Thanks for choosing FixYa.
Kelly

Posted on Dec 06, 2010

  • 1 Answer

SOURCE: My Troy Bilt power washer (using Honda GCV160

I had a similar problem. Turns out I had left the hose disconnected and some sort of wasp built a paper type nest inside the washer tube that the hose connects to. I had to take the pump off and take apart and then cleaned it out with a screw driver. Not too easy to do but finally got it clean. Same thing happened with the hose.

So, if you haven't used it for awhile, check that there is no blockage in the hose or pump tubes. You might be able to blow it out with an air compressor.

Posted on Feb 11, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 05 flhtcui ultra is having aproblem with the oil light coming on and pressure on gauge reading 0 but has good oil pressure ,i have put a new sending unit on it and a new gauge


Oil pressure must be checked with an external gauge that you connect to the same point as the oil pressure sending unit. With the engine at normal operating temperature (hot after 30 min spin), at 2500 rpm or above, oil pressure should be above 20 PSI up to around 30 PSI. It may go as low as 5 PSI on idle with a hot engine but should increase as soon as motor comes off idle. Oil viscosity and ambient temperature will affect oil pressure. If your experiencing this problem only with a hot engine, you may have a big problem in the timing chest. Inner cam bearings are known to collapse (these are smaller than 2007 MY) and the rollers enter the oil pump, thrashing it and causing low oil pressure. If the external gauge (use one that goes to 60 PSI or there abouts) shows correct pressures, then your sender unit, wiring or gauge is faulty. Check this as soon as possible as I have seen engines completely thrashed over this. Ruined engine cases (cam bearing completely disintegrates and cam shaft starts running on parent metal), big ends gone, pistons and barrels, oil pump and cam plate, tappet followers, the list goes on and on. On one engine I have done, I was only able to use the cylinder heads, push rods and covers. Everything else I had to replace. If you find this bearing damaged, make sure that the oil pan is removed and washed out as rollers are picked up by the scavenge side of oil pump and 'pumped' to oil pan, ruining oil pump in the process, sucked back to oil pump and screwing the pressure side, damaging the cam plate, and on and on.

Feb 01, 2015 | 2005 Harley Davidson FLHTCUI Electra Glide...

1 Answer

How do you change a water pump on a 2000 Cadillac Eldorado


if you have the north star motor it on drivers side tward front grill, you will find a belt cover you need to remove an you'll need a special tool most auto parts stores will rent it to you for a small fee ,it likes a large socket ,if you have the new one you'll see how it fits in socket, using a rachet with socket place over water pump and turn a 1/2 turn to left and it's out ,replace in reverse ,take care not to disturb new o ring seal ,and don't use silicone to seal it , BUT general motors strongly suggest you do use some type of motor sealant , now for the bad news =these motors are very bad with over heating issues that have plaged the north star for years , if you drain antifreeze make sure you use air purge valves to remove any air from motor (purge valve looks like a brake bleeder screw ) or it will continue to over heat, im guessing that's why your doing this , if over heating is a problem take the time to go over all aspects of the cooling system =belts, flushing motor, cooling fans working correctly ,coolant filled, well I REALLhope this helps you ,good luck with it .
Woody

Aug 26, 2014 | 2000 Cadillac Eldorado

1 Answer

Compressor pulley has come off, is it simply a press fit?


Hi,
The pulley will fit over the shaft. There should be a key that will fit in the keyways of the pulley and the shaft when you line them up...
Then there will be two allen set screws to tighten down...one will be on the key and the other 90 degress around the shaft.
Line up the pulley so the belts align with the other pulley and then tighten everything down....you are now good to go again...

heatman101

Mar 24, 2010 | Porter Cable Cable 135 PSI, 60 Gal. Oil...

1 Answer

Pump problems


Are you only using gravity to feed the machines. The law of gravity is that, for every foot of elevation you will get 2 PSI ( pounds per square inch) of pressure. You can figure out the minimum volume that the manufacture requires and make sure that amount is being furnished to the machines. You will probable need to install a pump prior to the machines with a regulated return line to keep the proper amount of water running for optimum performance. Its very hard on the machine not to have the proper volume of water. So to answer your question, i don't believe you'll be able to get 9.5 GPM that the three machine need by simple using gravity. I hope this helps

Dec 11, 2009 | Comet GXD2527G Pressure Washer Pump

2 Answers

Oil leak at top of pump


The oil in the pump is probably leaking because a seal is blown and water is getting into the piston housing. Take a look inside at the oil. It should be brown and translucent. If it is gray, white or milky, you have a blown oil seal. This reservoir should only be 1/3 full of non-detergent oil to begin with. Hope this helps

Sep 07, 2009 | Northstar Garden

1 Answer

Triumph Bonneville T120 oil pressure issue


The oil pressure on a new engine is:

Idle is:  20 - 25 psi
Full pressure is 68 - 80 psi.

Pressure switch operates at 7-11 psi.
The pressure switch could be faulty.

Pressure when hot may be very low
and  if it is returning oil to the tank
that is a good sign it is still pumping.

Aug 19, 2009 | 2004 Yamaha V Star Classic

1 Answer

Proline Pump 8D-10-1n11CB. This is for a pool and is leaking from the shaft to the motor


The pump seal is bad on the unit. This requires disassemble of the pump unit. Remove power to the unit, dissasemble pump housing, remove the impeller from the shaft of the motor by removing the allen screw with an allen wrench. Seperate pump housing from motor remove the old seal replace seal. Lube motor shaft with a little clean oil or wd40 to facilitate easy install thru new seal,reassemble in reverse.

Jun 03, 2009 | Hayward 1.5 Hp Northstar High Performance...

1 Answer

Oil leak under the engine


If it is a vertical shaft engine then it is most likely the crankshaft seal. That requires removing the engine from the frame and removing the pump from the motor to replace the seal. If it is a horizontal shaft engine then it could be either the shaft seal or the side cover gasket. Both require removal of the pump.

Apr 29, 2009 | Garden

2 Answers

Pressure setting of series 90 pumps


Yes 90 series pumps will run pretty close to 6000 psi. there are cross port reliefs built into the endcap of the pump and usually a POR valve as well. so the POR should be set at 3000, the cross ports in the pump should be set higher than this. There may also be a "transmission block" which is a seperate block with hot oil shuttle and cross port reliefs. Make sure these reliefs are also set higher than the POR valve in the pump. There may also be cross port reliefs in the motor. These too must be set higher than the POR valve in the pump. If you system overheats after increasing the pressure setting of the POR valve, you are probably loosing oil across one of the cross port relief valves.
Please visit http://hansonhydraulics.blogspot.com for more information. I** If am electric motor is being used to drive this pump, be sure you have sufficient horse power for this increased load. **

Jan 29, 2009 | Danfoss Sundstrand-sauer-danfoss...

Not finding what you are looking for?
Garden Logo

Related Topics:

24 people viewed this question

Ask a Question

Usually answered in minutes!

Top Northstar Garden Experts

John Trevino

Level 3 Expert

1388 Answers

Brad Brown

Level 3 Expert

16195 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Are you a Northstar Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...