Question about Jl Audio 1000/1V2 Car Amp

1 Answer

I have a jl audio 1000/1v2 my probem is the low volt ligth blinking and dosen t work wath shut I do

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 147 Answers

The low voltage light would indicate that there is not enough power reaching the amplifier through the power wire. Are you using 4awg or bigger wire? Is the amp grounded well? Does this happen all the time or just at high volume?

Try checking your power and ground connections and ensure that you are using the correct size of wire.

Posted on Mar 12, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The thermal light on my JL AUDIO 250/1 car audio amplifier is blinking, even after I have shut the veichle off for hours. HOw can I resolve this?


try to pull the fuse....may reset the amp...but more than likley there has been some kind of internal damage ....ie... water damage or bad speaker connected etc....

Aug 24, 2010 | Jl Audio 250/1 Car Audio Amplifier

1 Answer

Jl audio amp blink low voltage then power over and over.


Had the same problem once from a very poor ground connection.

showed 12V across multimeter, but could not deliver any real power across the connection due to poor grounding.

check it.

Aug 19, 2010 | Jl Audio 300/4 Car Audio Amplifier

1 Answer

Low voltage light on


is not gettin enough power
low volt light on

Jun 01, 2010 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

The power light comes on then it give out


jl audio 12w7 with jl audio 1000.1
get a high volt capacitor 8 or more fared a breaker fuse 100amp .Best bet is to have an another battery hook up in back of truck for this kinda set up cause this amp really pulls alot of juice

May 20, 2010 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

Jl audio 300/4 low ohms light wont go off


If the low ohms light is on then you have your speakers wired to low. I need to know some more info like what type of speakers you have running on this amp and how many. Also was it working before and then it started doing this? Check the ohms with a volt meter if you know how, if not just get a volt/ohm meter and set it to the ohms setting and then take the positive(red probe) and touch it to the positive terminal on the speaker and then the negative(black probe) to the negative terminal and see what it reads. Make sure you check how low in ohms your amp is capable of handling. If you don't know just google the model of your amp and you will find a site that has a manual or just go to JL audios web site and you should find out there with no problem. Let me know what you find so I can assist you more if need be cause I also repair amplifires for a living and have many years experienc and I'm the cheapest amp repair business you will find any where. Good luck

Aug 15, 2009 | Jl Audio 300/4 Car Audio Amplifier

1 Answer

Jl audio 1000/1 low voltage -keeps shutting off at high volume


You should definitely upgrade the power wire to the sub amp to 4 gauge -absolutely your choking your amp its starving for current-poor thing is starving !!!!!!!

Apr 16, 2009 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

Green light blinks slowly on my JL Audio 300/4 amp


Check your fuse at the battery. While AGU glass fuses "look" good, when you read the voltage AFTER the fuse, you can only be getting 5 volts or so. I can't tell you how many times I have seen this.

Larry T
Winona Lake, IN
http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html

Jan 27, 2009 | Jl Audio 300/4 Car Audio Amplifier

2 Answers

Jl 1000/1 amp not working


If I'm not mistaken, the blue light is the low voltage indicator. You need to confirm that the voltage ON THE POWER SUPPLY TERMINALS of the amp never drops below 11 volts. If it does, the amp will shut off. It's possible that you have a bad connection or even a defective fuse that's causing the problem.

JL recommends a 100 amp fuse for the amp. If you use a fuse that's too large and something goes wrong, the amp may be very severely damaged (possibly beyond repair).

May 08, 2008 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

2000 watt jl audio amp & car battery...


Make sure that you don't have any strands that would connect the remote lead to the constant +12 volts. Also make sure that your remote lead fromt the radio switches off when you shut the car off. If you don't have an aftermarket radio with a remote turn-on lead, tap into the ignition wire to the radio. Let me know what kind of car you have and I can point you in the right direction to get the right wire. Good luck.
-Andrew Hawkins

Apr 08, 2008 | Jl Audio 1000/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 1000/1V2 Car Amp Logo

Related Topics:

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

matthew walsh

Level 1 Expert

69 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...