Question about Kenwood KDC-X792 Car CD/ MP3 Player

1 Answer

The head unit functions properly except for the screen not coming on. The illuminated lights come up, but nothing on the screen.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Kenwood Master
  • 2,226 Answers

There are probably some bad solder connections on some surface mount resistors inside of the deck itself. there are about six resistors that need to be resoldered.

Posted on Mar 11, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Harley troubleshooting


First if the radio/stereo head (main unit) doesn't turn on (back lights illuminating, display showing, etc.) there might be a fuse in the back of the unit.

If the head works, and nothing to the speakers, a wire might be broken/disconnected.

May 29, 2014 | 2005 Harley Davidson FXDLI Dyna Glide Low...

1 Answer

Powers off after green light comes on


-ALL lcd tvs, except for latest units with LED backlighting ,use from
two to six or more CCFL lamps-any of which can fail-causing darker bands on sceen since failed CCFL CANNOT illuminate screen area
-IF none of CCFLs illuminate OR if reddish tinge on startup,one or
more ccfls are failing-OR INVERTOR section failing-where INVERTOR board gets juice from power supply and ups voltage to >1500 v AC
-just like flourescent tube-but ccfls "might" be integrated into lcd panel itself-to make "slimmer"
-either problem is EXPENSIVE FIX-so newer LED backlit units better since leds are more reliable,last longer AND reduce power consumed

Jan 05, 2013 | Hannspree XV37 HDTV 37 in. LCD TV

1 Answer

2001 Civic dimmer not working


It's not high and low beam, it's the dash lights that are dim. I've hooked up many aftermarket radios but never knew it was a no no to hook up the dimmer/illumination orange wires in a '01 civic. I googled it and seen many others with similar issues like mine but nothing exactly like the issue I have.

All the dash lights work, they are dim though. The radio lights work but they are even more dim than the rest of the dash lights. I have check every single fuse under the dash and in the engine bay. The dim controller does not work at all now. I'm guessing that's the issue and from what I read, the dimmers circuit board is in the instrument cluster. Some can fix it, others can't.


I will probably end up buying a used instrument cluster off of ebay, they are not expensive. Hopefully that fixes it since everything else works.


Oh, yes, the brake lights work.


Ted, I think you answered the wrong question...I mentioned nothing about the battery or the low/hi beams

Aug 13, 2012 | 2001 Honda Civic

1 Answer

Cyclone ca-594 amplifier


The protection system will come on if for example the speaker wires are touching, or there is an overload in the system. If you can't get it to clear, then suspect a power transitor has failed, causing a short circuit.

Jun 27, 2012 | Audio Players & Recorders

1 Answer

I have a Sony Cdx-gt300. When the head unit receives power it turns on, the clock shows, and then the Radio functions scroll continuously. The radio has been reset a dozen times at least. I have also...


you might have a button stuck, try gently pulling the function button out a little bit. i used a sheet rock knife razor blade and was able to release it but after pressing the function button again it started all over again. good luck.

Mar 26, 2017 | Sony CDX-GT300 CD Player

1 Answer

Head lamps not turning on except when brights are on.


check for voltage going to the sockets, if none, go to the dimmer switch

May 20, 2010 | 1983 Ford Econoline

1 Answer

Fresh Air will not work after cleaning


How well did you clean it, there are 2 connections to the lcd screen up front maybe one of those became unpugged. You have to be careful cleaning around the circuit boards because body static can ruin a circuit board. Its possible that happened . I had a problem with a lcd screen going bad and the unit would not come on and just stay lit like your describing. I replaced the screen and it was fine.

Apr 28, 2010 | Ecoquest Fresh Air Air Purifier

1 Answer

KDC MP242 faceplate will not light. I have the unit run directly through the car vehicle battery for power. The CD player will accept and eject a disk, so I know the unit is getting power. However, I...


Im not sure if this is gonna fix your problem because im not exactly sure what you mean when you say you ran the player directly to the battery....but if the faceplate is not lighting up then it is possible that you may have not connected some of the wires properly. Some head units come with illumination wires which I believe are usually orange and that could fix the problem of the faceplate not lighting up....I hope that you are not actually running it straight to your battery..like under your hood, straight to your battery. I would imagine that you have purchased the proper wire harness and have matched the wires properly in the dash to the radio harness. If you do not have all of the wires hooked up and the harness plugged in to the radio and ready to go like your gonna put it in the dash to bolt it in then do that. Hook everything up properly with the wires and the harness so its like its ready to be bolted in and then test it...if the faceplate is still not lighting up then you may need to bring it somewhere to have it done professionally or if you are confident you are doing everything properly then it could be a faulty screen. I can add that I have installed many radios and had have lots that I have not needed a use of that orange illumination wire for.....its pretty straight forward just matching the colors and connecting them...but if you have never done it then you should probably take it somewhere, just not sure if you have ever done it before. Hope this was helpful to you.. :) Good Luck!

Dec 15, 2009 | Kenwood Car Audio & Video

1 Answer

Lens won't open/flashes E18 on screen


i got my camera a couple of mounths, but i have not used it alot. When i turn it on, the start up screen wold come on but e18 would come up on the screen and nothing would happen after. i desperately need your help to fix my camera. thank you.

Sep 24, 2006 | Canon PowerShot A70 Digital Camera

Not finding what you are looking for?
Kenwood KDC-X792 Car CD/ MP3 Player Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4869 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76673 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...