Question about Broan-NuTone CV450 Central Bagged Central System Vacuum

2 Answers

Unit will not turn on

The unit has power at the source but will not come on either at the vac outlet or the manual on/off rocker switch on the side of the unit. I am not sure if the relay is bad or the circuit breaker is bad. Is there a way to reset the circuit breaker? Does it use fuses? Help.......

Posted by on

  • titanmd Jan 26, 2009

    I have the same problem. The solutions listed address the problem as if the unit will not shut off. The unit will not turn on all of the sudden.

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,035 Answers

There should be a auto/manual switch, at least most have them, is it in the manual setting? If it is in the auto setting, then pull out the the 2 low voltage wires, if it shuts off, then there has to wires touching in one of the outlets or a staple thru the wire shorting the 2 together. If it stays on, then there is a problem in the cannister. Check that switch, maybe it is stuck in the manual position.

Posted on Jul 30, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,847 Answers

Unplug the vacuum unit from the wall. If it is hard wired turn off the circuit breaker

Posted on Jul 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

The Vaccum is not turning on when i plug the hose into the wall. The hoover system will turn on when i turn the switch on at the base and wont go off till i turn the switch off. But it will not come on...


you can test this out by taking a small metal spoon and with the bottom side of the spoon insert it into the vac outlet on the wall. you want to touch the two metal pins inside the vac outlet to test if the unit is the problem or the hose is the problem.

If the unit starts, the hose should have a 3 year warranty on it. I recommend you have your nearest beam dealer check it out.

If the unit does not start, it has a 7 or 10 year warranty, the circuitry should be replaced. Again have your nearest beam dealer check it out.

good luck

Nov 06, 2010 | Beam Industries Vacuums

1 Answer

Our Easy-Flo built in vacuum system will not turn off, even when the hose is disconnected. We have to turn it off manually. Could it be a short in one of the wall outlets causing this?


Some models have an on/off switch on the power unit itself. This switch is used to turn your power unit on when you are right at the machine.
If there is no switch on the power unit, unplug your power unit from the wall socket, look for two low voltage wires coming out of the power unit. These two low voltage wires are usually either attached with terminals or are tied to two wires coming out with plastic screw on wire caps. Disconnect the 2 low voltage wires. Plug your power unit back in. If the power unit does not come back on then yes, the problem is most likely a short in the outlet wiring. If the power unit still comes on with the 2 low voltage wires unattached, then the problem is in the internal circuitry of the power unit, usually a relay or some units have a circuit board with relay, circuit breaker and other components on it. The relay or circuit board will have to be replaced.
It's a little difficult to check for a short if you have multiple outlets, but if you've recently done some renovations you might start checking in that area.

May 19, 2010 | Easy Flo EF1400 Central System Vacuum

1 Answer

On my kenmore central vac no power unplug unit plug it back green light comes on but try turning vac on green light goes off again .


Please clarify that we are talking about the central vac LED/switch panel panel and plugging it into a 110 V wall receptacle.
If I understand when you unplug from the power source ,then plug back in the green LED comes on, looking normal ? But when you manually activate the switch on the motor housing of the vac itself the vac does not start and the LED goes out, so no green or red LED at that point?
If this is the case , Kenmore CV's built approx 5 years ago (MADE by EUREKA) and prior had a circuit board with attached cord (as opposed to detachable) which was prone to relay failure. There were several symptoms, most common was that the relay on that switch panel /circuit board would fuse on and the vac would continue to run when the hose was detached from the wall.However some I worked on from that era had exactly the same symptom you describe. If your unit is between 5 and 10 years old and this sounds accurate, you can unscrew this curved side panel relay with one philips screw. Inside on the PCB will be an L shaped black or white 24volt relay, generally rated at 10 amps. The replacement board or relay will be rated at least 24V/ 15 amps or more. If you can isolate your motor and test it separtely with a power cord or meter , the realy/board will be the only control componnet left.
If you have a small tipped soldering IRON, not a gun, you can generally find a replacement relay to rebuild the board for about $6 at an electronics parts store. Otherwise you will need to replace the control board itself, anywhere form $45 to $70 plus service call if you have a tech come out to the house, and the tech will just unscrew , detach wires and replace the board, no repair , approx 15 minutes work. This will likely cost over $100.
Please post back with your results

Oct 24, 2009 | Easy Flo EF1400 Central System Vacuum

1 Answer

Replace switch on electrolux 2100


The 2100 is an older model which is prone to rocker switch failure. What you see outside is only a switch button. Underneath is a plastic rocker which sits in a grove and pivots back and forth to activate the on off switch.
If you push the switch down and there is no audible "click" you Likely need the rocker itself, especially if you tip the vac upside down and shake it and hear a piece rattling inside or find a broken narrow plastic finger about 1/2" inch long when opened.
However if it clicks and works every 3-5 times,the rocker is fine and you will need the spring mechanism and switch button which you can see form outside.
To remove either the process is the same.
Separate the body by opening the bag cage and pulling the two bumpers forward with a set of pliers. They are locking keys. Once removed, the rear housing will drop off allowing the vac to hinge open back to front. Do this with the vac laying upside down and observe the hinge section of the front bag door .DO NOT REMOVE THE MOTOR. You will need to clip all these componnets back together to reassemble and slide the bag chamber back to seat against the motor with the motor housing engage in the ribbing of the vac side walls.
With the vac open you will only need to remove the spring loaded bag lockout switch and the bag housing it sits on, not the motor or rewind..
Once removed there will be 6 chrome philips screws visible. These hold the top trim on the front of the vac and the front ones hold the on off switch into its housing. At the very front will be two screws going through a black or whitish switch housing. That housing will lift out with wires attached to reveal the switch rocker, etc,. This portion will lift back and out at about 45 degrees of the inner housing, as a unit. The switch button sits atop the rocker via two end tabs and will pop off the housing to reveal if the rocker itself has a broken "finger" or if the button has a weak spring.
The suspect spring is not the coil rocker spring but the thin U shaped spring on the underside of the switch button. Remove the rocker spring with a pair of needle nose pliers.and examine the rocker comparing to your new one.Use more vaseline on the new rocker and if you have it reinsert the clear flex plastic into the coil spring. If not disregard.
Re-installation is the reverse order, tuck switch back in at 45 degrees from back to front.
Pay special attention the the rubber seal at the back of the bag cage.
If anything is misaligned in this body you will fight to reassemble. Don't fight it , back up and look at your work. When and ONLY when it is perfect it will realign and click together like a lego set and the keys will slide in perfectly
You can and should test the vac before reassembling the whole body, simpley slide your hand under neath and activate the switch, with a bag inside the vac.
See now, wasn't that EASY???????
Please post back to advise how you make out. Its a 7 minute process worth $25 for a good tech. A bad tech will spend half a day trying to figure this one out but just go slow and follow the instructions and you will do fine.

Oct 17, 2009 | Electrolux UltraLux 2000 Bagged Canister...

1 Answer

No power to my vac.


This sounds more to be a switch or motor failure if the outlet is OK, and the unit will not work.

Sep 25, 2009 | Hoover SteamVac F5914-900 SpinScrub...

4 Answers

Shop vac 90L400 stopped working won't start


I had the same problem with the same model. Turned out to be the thermal fuse on the motor housing, between the switch and the windings. Took it apart and replaced the melted solder with 14 guage copper wire. Works fine! No thermal protection but I don't use it for long at a time anyway. Check the switch for continuity, if good then check the thermal fuse for continuity. If good, it's the motor.

Oct 19, 2008 | Shop Vac 925-13 Canister Wet/Dry Vacuum

5 Answers

Shop vac QPL625 on off switch stays on.


Contact Digi-Key 1-800-344-4539 or 218-681-6674 ask for part number EG1505-ND.

Cost is about $2.00 plus shipping.

See http://search.digikey.com/scripts/DkSearch/dksus.dll?Detail&name=EG1505-ND for part details.

You want a D.P.S.T (On/Off) mini-rocker switch.

Apr 16, 2008 | Vacuums

2 Answers

Central vac (Hoover) always on!


There should be a manual/auto switch. If it is in the manual mode, then it will run all the time. Other then that you probably have a stuck relay. But this will have a years warranty on it, so you should be able to have it serviced under warranty.

Oct 08, 2007 | Hoover L2310 GUV Central System Vacuum

Not finding what you are looking for?
Broan-NuTone CV450 Central Bagged Central System Vacuum Logo

307 people viewed this question

Ask a Question

Usually answered in minutes!

Top Broan-NuTone Vacuums Experts

Roger Potts

Level 3 Expert

694 Answers

Custom Exchange
Custom Exchange

Level 3 Expert

397 Answers

Steve

Level 3 Expert

3287 Answers

Are you a Broan-NuTone Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...