Question about EliteGroup BKi810 Motherboard

2 Answers

Bki810 motherboard Hi There I have a Bki810 and I think my motherboard has gone. The PSU is ok as I checked it on another pc. There is a small light on the motherboard but when I press the power button nothing happens. I have removed all parts and replaced them again but still nothing happens. I seem to have difficulty finding one of these motherboards on the internet. Thanking you Regards Helena

Posted by on

  • saisspys Jul 30, 2008

    Hi Styme



    Thanks for your help.



    Do you know where I can purchase one of these motherboards?



×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hello,

I had got the same problem on an old motherboard.

Perhaps you can try :

- take out the battery button for CMOS storage (on the mother board)
- clear C-MOS with the jumper (few seconds and replace it the jumper in the right position)
- try to launch again

If it's ok replace your battery button (CR2032).

Bye

Posted on Aug 13, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 84 Answers

LED light on motherboard is indication your getting electric , Fan spins also is good indicator but it also does not mean the motherboard works though . If you tested CPU on second motherboard that should have told you the first motherboard has died . ( As long as the CPU can run on both motherboards that is )

Posted on Jul 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I think my motherboard is bad. My computer won't turn on. Have tested the power supply and I believe it is good. When power cord is plugged in the green light is on but very dim. When I disconnected the...


Replace your PSU then test all leads that are attached to your hard drive sounds like a faulty lead of some sorts then
try replacing all the leads that attach to your hard drive including electrical extensions + IDE,SATA and the ones that attach from your motherboard to hard drive
make sure all leads that are attached to your drives dvd\cd 3 1/2 inch floppy have secure connections and are not faulty or just replace them they are probably old and faulty because a computer has to have an end to the circuit any fulty leads will lead to no boot up
good luck

Sep 07, 2010 | HP Motherboards

1 Answer

I have a K7VT2 m/b set up with a Antec SL300S 300w PSU, 40gb hdd, 80gb secdondary hdd, a floppy dd, cd dd, Logitec speekers, USB conected key board & mouse, D-Link DWA-140 wireless n USB adapter. All...


i dnt think so as for your pc 300 is ok but if u add more hardware to your pc it might not support that.
As far as the router is concerned i think its windows prob not the psu.

Mar 04, 2010 | Asrock K7VT2 Motherboard

1 Answer

Bki810 update my bios and still does not recognize large disks .. as 160GB.


"Some days a diamond, some days a stone." If you must keep the old mobo, you might have to trade off for smaller partitions of that big 160.

Jan 28, 2010 | EliteGroup BKi810 Motherboard

2 Answers

Audio driver


you can use the drivers from here

Jan 11, 2010 | EliteGroup BKi810 Motherboard

2 Answers

I need drivers for a amptron bki810 mobo. could you please direct me to where i can find them. Thanks


go to the AMPTRON support site to download drivers, thanks for using fixya/

Oct 05, 2009 | Motherboards

2 Answers

Need drivers for bki810


Hi,

You can download the drivers from :-

http://www.updrivers.com/drivers/Motherboard/Amptron/BKi810-Linux_Windows_2000_NT4_ME_98_95/12963.html

http://pcchipsusa.com/support-driver.asp

Hope i helped you.

Thanks for using ' Fixya ' and have a nice day!!

Sep 08, 2009 | EliteGroup BKi810 Motherboard

1 Answer

CMOS checksum error


rahul23petit

"CMOS" checksum error default loaded" means ur mother board cmos battery fail (which is locate at mother board), to solve this problem replace it by new one (u can buy it form any computer accessories shop). all oher problem happen for it.

Jul 06, 2008 | EliteGroup BKi810 Motherboard

2 Answers

Usb


check to see that if ur USB has infected with virus or scan your pc. let me know

Apr 18, 2008 | EliteGroup BKi810 Motherboard

Not finding what you are looking for?
EliteGroup BKi810 Motherboard Logo

Related Topics:

311 people viewed this question

Ask a Question

Usually answered in minutes!

Top EliteGroup Motherboards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Mark Taylor
Mark Taylor

Level 3 Expert

728 Answers

Michael Thomas
Michael Thomas

Level 3 Expert

3051 Answers

Are you an EliteGroup Motherboard Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...