Question about Alpine PDX-1.1000 1000W x 1 Car Amplifier Car Audio Amplifier

1 Answer

Car amp wont turn on

My alpine amp just cut out one day and never turned back on, i found that the positive wire goin from the battery to the amp was split because of my hood hing. i bought a new wireing kit but the amp still wont turn on. i checked all the wires and everythign appears to be hooked up right. i also just to make sure my alpine amp wasnt blown i hooked up my 800w kenwood amp and that wouldnt turn on either. if you could help me witht hsi i would really appreciate it

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

I'll assume that you've checked the amplifier's on-board fuses.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Posted on Jul 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I dont know how to connect it .it is an mrp-m850 i tryed to connect it but it wont turn on


well u run a power wire atleast 4 guage from the positive terminal on the battery, then 4 guage to a chasis ground source, then a remote wire to the rear of your cd player that will kick the amp on when the cd player turns on... then for subwoofer wiring go to www.the12volt.com for sub wiring options... you need either single voice coil 4 ohm subs or 2 ohm dual voice coil subs to get the 2 ohm load to the amp so u can get the rated power out of it...

Dec 06, 2009 | Alpine MRP-M850 Car Audio Amplifier

1 Answer

JBL amp won't turn on


unfortunately it probably burnt up. If all the wiring's good like you said it is it's probably just fried... My advice is send it back if it's still under warranty, they'll either repair it or get you a new one. If its not under warranty you can pay to have it fixed or just buy a new amp. I you buy a new one go Kenwood, or Alpine, i've had problems with jbl in the past...

Aug 30, 2009 | JBL PX600.2 Car Audio Amplifier

1 Answer

Alpine PDX1.600 amp cuts off


Make sure there's no missmatched impedance. If your sub running 2 ohms then your amp has to be 2 ohms stable. Does the amp blow fuses or get really hot? If it does it can be a fire hazard and I would recommend taking it out of your car. It could be that you don't have sufficient grounding. The grounding needs to be very close to the amp and the paint needs to be thoroughly scratched off. Otherwise could be a blown transistor within the amplifier, you can check this by opening up the amp, running a multimeter and testing the transistors for resistance.

Aug 04, 2009 | Alpine PDX-1.600 Car Audio Amplifier

1 Answer

Alpine amp wont turn on..


your power wire is sufficating yor amp probably

Jul 29, 2009 | Kenwood KAC-8152D Car Audio Amplifier

1 Answer

Alpine pdx 1.000 keeps cutting out


You are going to want to make sure all your power wires and grounds are 4 gauge as well as the wire leads to and from the capacitor-4 gauge also. make sure you have a very good ground - the power wire from the battery should hit a distribution block-from the dist. block a 4 gauge should go to the capacitor another 4 gauge to the mono amp and another to the 4 channel amp -every component should have a good solid ground even if you have to bust out a grinder and a drill and some self tapping sheet metal screws and go nuts on it- see if that helps you

May 26, 2009 | Alpine PDX-1.600 Car Audio Amplifier

1 Answer

Amp problems


The main thing that comes to mind is whether you've checked the in-line fuse on the positive wire. Most amp installations are supposed to have a fuse within 1ft of the battery terminal for just such a reason. Next, if you have a voltmeter of some kind (or know someone who does), check to see if you still have 11VDC-14VDC at the power terminals of the amp. If you do, then check the remote turn-on lead (which is supposed to connect to either your head unit or the ignition). If my memory serves, the remote wire should be high (about 12V) when the amp is being told to turn on and low (less than 2V) when it's being told to turn off.

Jul 29, 2008 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

Amp doesnt work


If you've only had it for 3 weeks and it's under warranty, you need to send it to a warranty station.
If there is no warranty and you want to try to find/repair the problem yourself, let me know.

Oct 23, 2007 | Alpine PDX-4.100 Car Audio Amplifier

2 Answers

Alpine mrp-m450 Amp won't stay on


im having the same problem with my amp, I took it to best buy and they said the amp was recieving power and recieving signals from the deck and i had everything hooked up right but that in the circuit board all the connections were blown, meaning i have a blown amp, i hope this isnt your problem but it definetly sounds like it. GOODLUCK

Nov 12, 2006 | Alpine MRP-M450 Car Audio Amplifier

Not finding what you are looking for?
Alpine PDX-1.1000 1000W x 1 Car Amplifier Car Audio Amplifier Logo

Related Topics:

149 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...