Question about Vacuums

1 Answer

Smelt rubber burning and vaccum cut out. Will not switch on

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Teacher:

    An expert who has written 2 tips or uploaded 1 video tip.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 100 Answers

What do you mean pls?

Posted on Jul 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The vaccum continues to shut down and Shark troubleshoot suggest the thermastat. Instructions followed but problem persists.


the burning odour will be from an over heating motor ( overload switch is cutting in )
have it checked out by an accredited service agent for the machine

Jun 25, 2015 | Shark Rotator Professional Lift-Away...

1 Answer

My rainbow 1650- was working fine then all of a sudden it powered down and had a burning smelt a little electrical, but also like something else. Then I hit power switch andi unplugged The unit. I took...


It might have been the wad passing through but with a burning electrical smell it should be checked out by qualified technician. Burning electrical smell means it may catch on fire

Sep 23, 2013 | Vacuums

2 Answers

Is it worth trying to fix my kirby vaccum?The motor smells like its burning when we run it


Generally the smell is the rubber belt that attaches from the motor to the brush.
Make sur the brush rollers are clean and spin freely, check the belt at the same time.
Please let me know if this helps.

Jan 09, 2011 | Kirby Ultimate G Bagged Upright Vacuum

1 Answer

Was vaccuming and vaccum quit. Tried unplugging and turning back on. Getting absolutely no power. unscrewed screw under handle and tried to make sure connection was being made. Don't really know what to...


ok..If you have a multimeter you can check plug fuse then switch and motor, if you put leads across the plug you will get some reading if its working.could be thermal cut out on the motor.

Apr 18, 2010 | Kenmore Magic Blue 24195 Bagged Canister...

1 Answer

Miele Vacuum Cleaner - burning smell / motor won't stay on


check brush the belt may have popped off and is binding or brush is binding clean brush of any debris thread/hair wrapped binding brush and check and or replace belt

Mar 24, 2010 | Miele S318 Bagged Canister Vacuum

1 Answer

I bought this second hand, so have no manual for parts, etc. I smelled something really bad, am assuming it was the belt. How do i release the head of the vaccume to get to the roller. It needs cleaned...


rotate the front belt lifter from green to red then rotate the locking knob above the nozzle. and the head will lift off. it helps if you put the height adjustment in the highest setting. did it smell like rubber burning?

Jan 01, 2010 | Kirby G5 Bagged Upright Vacuum

1 Answer

While starting my vaccum cleaner big noise and stream is coming . it is dead?


No Brand? I think you mean big noise and smoke? Smoke can be from a burning belt or dying motor. If it smells like burning rubber you likely have something jamming the brush roll. Otherwise suspect the bang came from a motor fan. Do not attempt to run. disassemble and inspect

Aug 19, 2009 | Vacuums

2 Answers

Vacuum smells like burning rubber when on, no suction, leaving black marks on carpet


Usually when my vacuum smells like burning rubber, the belt needs to be changed and that is very easy to do. You just need to remove the the screws that hold in the rotator and put in a new belt. When the belt needs to be changed the vacuum will not pick up anything and this could make it seem like there is no suction. I hope this helps!

Nov 25, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Kirby just turned off while vacuuming, will not go back on. On/Off Switch doesn't feel right either...smelt rubber burning also while vacuuming.


Could have a bad cord or switch asm. A rubber smell usually means the belt is slipping on the brush roll and is in need for a new one.

Apr 14, 2008 | Vacuums

1 Answer

Will not start at all


most likely if it dont turn on at all period.1 of 2 things on/off switch went out or 2 motor burned up but most time u can tell if it is bad motor cause if it smelt like burnt plastic ever bad news its dead but hopefully u can just change switch

Dec 15, 2007 | Kenmore 31913 Progressive Direct Drive...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...