Question about MTX Car Speakers & Subwoofers

1 Answer

I have a blown thunder 6500d amp. It wont power up or light up and all cables are correct. I took it all apart and was wondering how to trouble shoot some common electronic issues that may have happpend to the amp. Any suggestions?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

There are several things you can check. Do you have a multi-meter?

Posted on Aug 26, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My sub wont play music but it will pop when i cut the truck on and the amp lights up


it's blown or the amp is. that pop you are hearing is the speaker clipping, meaning its getting power but no sound which means the amp or sub is blown.

Aug 17, 2010 | Car Speakers & Subwoofers

1 Answer

2 MTX Thunder Problem.. Bridging?


Is there a option on the chanels that say ''Bridged''? If so, you can hook the subs up in parellel or series to get different ohm loads. Usually the lower ohms, the more power amp puts out. Those subs can handle 225 watts RMS whitch means the power it can handle constantly. If the amp gives more than 225 watts RMs, you could be at risk of blowing the sub. If you could give me the model # of the amp, I can be of more help.

Feb 11, 2010 | MTX Thunder 4500 T4510-04 Car Subwoofer

1 Answer

Infinity Basslink not producing any sound. Green light on.


check that fusse under the hood if its blown pull it out and replace it wont hurt anything if u pull it out an put it back in if the cars off.but if ur getting power lights on the amps then more then likely ur fuse isnt blown.id start by checking the audio cables are produceing sound.if u need more help let me know bertman285@hotmail.com

Sep 29, 2009 | Infinity BASSLINK Car Subwoofer

1 Answer

My car's sub is ''sub-par'' my expectations


Hello css42103,

You did not specify the impedance or the model of your Audiopipe replacement woofer but if it is the TS-V6 DVC 6.5", then the impedance of each voice coil is 4ohms. If you wired the coils in parallel, you now have a 2ohm load to the amp. At 2 ohms, the amp tries to produce more power, and even at moderate volume, can be driven into clipping causing distortion. Not good for the amp. Definitely not good for the woofer.

I'd try wiring the woofer coils in series and see if it stops cutting out.

Hope this helps.

Jun 01, 2009 | Car Speakers & Subwoofers

1 Answer

Subwoofers won't work and they are brand new


Hello,

I've got a pair of these MTX's subs powered from a Fusion 450 watt 2-channel amp. For the price, they are great. By the way, they are 4-ohm.

My first suspicion would be that something in the first incorrect wiring damaged either the amp or the subs. Can you explain specifically what the "installing the subs incorrectly" means? Was the amp output shorted out at any time or was it operated without a load? Either of these conditions will fry an amp and sometimes, the protection circuitry doesn't work either.

First make sure that your amp is still working. Check both the primary power fuse, usually located near the vehicle battery, and the fuses on both sides of the amp. Make sure that when you turn the system on, the power light comes on steady (blinking is protection mode). Test your subs one at a time on a speaker output.

Mar 29, 2009 | MTX Thunder 4500 T4510-04 Car Subwoofer

4 Answers

No sound


Can you physically move the cone or is it siezed? hook up a wire to its + and - and then do a pop test using a 9volt battery + to + and - to - on the battery if it doesn't make a sound then the woofer is blown, if it does pop then the problem lies within your amp.

Nov 07, 2007 | MTX Thunder 8000 T8154A Car Subwoofer

8 Answers

SUBWOOFER NOT WORKING?


if you have real old wires from the amp to the sub try getting new wires on it. check the little wires that go to the cone itself on the sub. sometimes they can manage to get pulled out of their terminals and make sure that thier touching the terminals on the correct spot

Sep 29, 2006 | JBL GT150 Car Subwoofer

Not finding what you are looking for?
Car Speakers & Subwoofers Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Speakers & Subwoofers Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Are you a MTX Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...