Question about Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Fusion car amp problem

Hi. iv just bought a 2nd hand amp that worked realy well for a few days till it stopped working took it back and he temperary fixed it for me great. now the fuse went on it, and replaced it twice in a row with them blowing so put a larger one in and its ok but the amp light powers up then powers down with the popping sound of the sub going at the same time over and over. my earth power etc is all good something crazy inside the amp i suspect any help would be great :) fusion model: FE-402

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

The amplifier likely has shorted output transistors. Going to a higher rated could easily have caused more significant damage.


Let me know if you have any other questions.

Posted on Jul 27, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Red light on fusion amp?


Hello,

This is a rather common problem. The red light indicates it is not correctly getting power.

So trace your power wire from the battery--> check the fuse on the wire if there is one---> to your amp. If that is all in working order next move onto the ground wire.

Make sure it is sparking on the surface that you have it grounded at. If it does not spark when you touch the ground wire against that surface then you are not correctly grounded. It should be bare metal, something connected to the cars frame.

Try this and post back if you still need additional help. Thank you for choosing Fixya!

Oct 01, 2009 | Fusion Digital designs EN-AM6004 Car Amp

2 Answers

Ok I just bought a used fosgate amp belive its a T10001b could be wrong its big has fan 3 led lights and some pioneer premier 10 flat subs think there 4ohm. I bought a brand new amp install kit 6gauge...


eyp, most of the time speaker connections blow and fuses wont stop that from happening. They are there to stop the mainboard from frying and not working at all. try running rca splitters to the operational side of the amp. run the sub on 1 channel. you will start hearing a difference but both sides will work. if not, run the splitters from the head unit and bridging it. these are the cheapest solution i could provide

Jul 27, 2009 | Rockford Fosgate Punch P5002 Car Audio...

1 Answer

Subwoofers stop working after few seconds


Check the subs wiring... follow the manual....

Jul 16, 2009 | Car Audio & Video

1 Answer

Infinity 336rms amp worked for over a year then one day stopped?


check your fuses. Also check the power wire connection to the amp and then the ground source maybe move that if there is paint under it. check fuses on the amp. Check ohm load to the amp from the speakers.

May 27, 2009 | Infinity Reference 611a Car Audio...

1 Answer

Amp doesn't come on


Hello rheabarb,

You did not say whether or not you checked the wiring going to your subs. Many times, a shorted or grounded speaker wire will cause an amp to fail. And if the amp powers up OK with the subs disconnected, I'd suspect one or more of the wires.

Hope this helps.

May 19, 2009 | Clarion APX1300 Subwoofer Mono Amp - 300W...

1 Answer

Fusion car amp turns on then gos in protect mode


look behind ur headunit could b a wire touching or a piece of metel

Apr 08, 2009 | Car Audio & Video

2 Answers

Amp staying on but cutting out?


Hello Willb2396,

Actually you answered your own question in your paragraph. I draw your attention to your statement of:
"It will work for as long as I'm driving I will park my car, and when I turn it back on every thing will be working just fine and, then a couple minutes later, amp cuts out and won't hit for a couple hours or a couple days.... I have checked the sub multiple times and I don't see it being the sub or the amp"

You are correct it is neither the Sub nor the Amp. The problem is either your voltage regulator or your alternator. one and or the other is going bad.

Here is some advice check your ground wires, the buy a dual alternator kit, it contains the parts you will need to add an additional alternator to your car. This will provide the power you need.

I hope this helps,

Thank you,

Shuttle83

Nov 10, 2008 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

Kenwood 9102d wont power on


YOu might have burned out the inner fuse. Better yet the source connect...

Nov 06, 2008 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Problem with my amp


then use it as a paperweight...seriously, you prolly blew the jensen speaker, you prolly damaged the amp

May 15, 2008 | Hifonics Titan TXi 6006 Car Audio...

Not finding what you are looking for?
Sony Xplod XM-554ZR Car Audio Amplifier Logo

Related Topics:

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

xxxxxx xxx

Level 3 Expert

4724 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

286 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...