Question about Nitro BMW-481 Car Audio Amplifier

1 Answer

1200w Nitro amp

When I plug in my red and white connectors in the amp, the subs start to pulse and the connectors are sensitive whenever I touch them. One guy said that the shield ground could be broken

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 45 Answers

Yes it could be your ground..check your negative from the amp is going to the car body and not the battery. also try a new set of rca leads from the stereo to the amp..also check that your stereo audio out voltage is the correct voltage for the amp inputs.

Posted on Jul 27, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My red light wont cut off


are they subs or door speakers? if they are subs, then speakers ohm load is too low for the amp. If they are speakers then again the ohm load is too low or one the speakers are blown are shorting out against the door. sometimes when mouting speakers in the door, the terminals are accidentally touching some metal inside the door.

Oct 27, 2014 | Sony Xplod 1200W Car Amplifiers

1 Answer

Power light flashing


This means it is blown. Whenever the power light flashes on any amp it is blown or something else is wrong with it. Most likely its blown. You can blow am amp by hooking it up to a powerful sub and blaring it, or just overheating it. Hope this helps. This can usually be fixed as well

May 07, 2013 | Pioneer Gm-d8400m 1200w Max, Class D Mono...

1 Answer

Red light


You have not got your subs wired up poperly, End it fried the ouputs on the amp, Live end learn (Dude)

Nov 10, 2012 | Nitro BMW-482 Car Audio Amplifier

2 Answers

My nitro bmw 486 cuts out when i turn the volume up alittle bit,subs start crackling and distorting turn volume back down sounds just fine amp doesn't go to protect mode still works 4 guage wire a


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty D.A thumbs up would be greatly appreciated if this answer is helpful to you. nitro-bmw-486-cuts-out-when-turn-volume-lv2kkrmxrai4iihdvw4m3np2-1-0.jpg

Jul 20, 2012 | Nitro BMW-486 Car Audio Amplifier

1 Answer

How do i check if my amp is still good?


first make sure that you have power check the red thick wire, and the remote wire with a voltmeter if its ok then disconect the rca plugs now get a pair of rca wires plug one end to the amp and touch the other end if it makes noise your amp is good ( please be very carefull as it will make a loud noise on the speakers when you touch the other end if the amp is good) good luck

Dec 16, 2009 | Car Audio & Video

1 Answer

What size amp should i get for performance teknique sub-woofers


the amp you have will do the job depending on how may ohm you sub is and can you amp stable to handle low ohm's. you should also check your cabling to make sure its for about a 1500w amp so you dont lose any power

Sep 17, 2009 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Nitro BMW 484 1200 watt amp.


check fuses and remote wire at the head unit. must have a good ground at amp.

Dec 03, 2008 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Nitro 1200w amp


It sounds like the shield ground in the amplifier is broken. If that's the case, the connections would have to be repaired.

Let me know if you have any other questions.

Jul 26, 2008 | Nitro BMW-481 Car Audio Amplifier

2 Answers

Was a green light during the day the next red and stays red


look for wires that are touching each other like speaker wires or you may have a blown sub

Mar 14, 2008 | Nitro BMW-486 Car Audio Amplifier

2 Answers

Car Audio (amp over heating)


The problem would be if you had it switched around. The 1200W subwoofer only means that it can handle 1200w of power the 1000w amp means that it can deliver 1000w of power. What you may have is an impedance mismatch. My question is what is the resistance rating on the sub woofer and what is the minimum resistance rating of the amplifier. These are actully the important issues at hand. the rating of the subwoofer resistance in Ohms should never be lower then the minimum resistance rating on the amplifier. in fact the resistance rating on the amp should match the resistance rating on the subwoofer.

Sep 09, 2007 | American Pro VS-2043 Car Audio Amplifier

Not finding what you are looking for?
Nitro BMW-481 Car Audio Amplifier Logo

Related Topics:

141 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nitro Car Audio & Video Experts

kcunningham2

Level 1 Expert

31 Answers

Larry Spears
Larry Spears

Level 3 Expert

625 Answers

matthew walsh

Level 1 Expert

69 Answers

Are you a Nitro Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...