Question about Toshiba TP55H60 55" Rear Projection Television

1 Answer

Good sound ,No picture

At the moment, I accidentally shorted the heatsink of Q801 with the metal part of my lamp which I assume is ground which burnt a run on the neg side of C810 (168VDC input power to Q801)so it is on order.
The old problem is still there however. I can probably use some help from some one using the the same service manual that I am using. I have access to the service manual as I mentioned,DVM and 100MHZ oscilloscope. Thanks if you can help.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,071 Answers

Click this site for free downloading ,and register first there;
http://www.eserviceinfo.com

Try to check Q801 if not leak ,this problem like this good sound no picture this is convergence trouble,try to check this also...

Posted on Jul 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I turn the tv on and red light comes on solid for a sec then starts to flash with no picture or volume what is wrong any clue


That would be a burnt out lamp, or better yet the lamp blew up as in broken, when that happens you will not get sound. If it just gave up as in burnt out you will get sound but no picture. Both are the same the lamp needs to be replaced.

May 03, 2010 | Toshiba 51H84 51" Rear Projection...

1 Answer

When plugged in and turned on no picture and makes a chirping noise when unplugged the noise slows and quits like a fan rubbing against something but no picture and no sound


This is usually the flyback transformer (IHVT-integrated high voltage transformer) and the HOT( horizontal output transistor) The transistor will read shorted, with a multimeter, if it is bad. It is mounted to a heatsink straight back from the flyback. It may have a metal clip that holds it tight to the heatsink.
It is a pretty easy fix if you can solder.
While you have the board out, check for any discolored resistors or blown capacitors and replace those as they will likely fail before long and cause more problems. Also check with a bright light and a magnifier for cracked solder joints and resolder any that you find.

Nov 27, 2009 | RCA P60920BL 60" Rear Projection...

1 Answer

Sony grand wega lamp problem


Hello!

The lamp is burnt . It got burnt when used on the other TV either your friend circute board had a short or the lamp was placed wrongly on the board and it got burnt.
Get a new lamp make sure it u put it correctly and it should work now .

Good luck

Nov 24, 2009 | Sony Grand WEGA KF60WE610 60" Rear...

1 Answer

Blinking red power light. No picture or sound.


Sound to like the lamp is burnt out. I would start by replacing lamp.
Good Luck.

Nov 21, 2009 | Toshiba 57H81 57" Rear Projection...

1 Answer

Mitsubishi WD-65733 no picture, electrical buzzes in series


What it sound's like is that the lamp ballast is the problem. Buzzing sounds like when the power is first brought to the ballast it has to ramp up the voltage to get the lamp to light, then the voltage drops back down when the lamp is lit. Sounds like the lamp ballast isn't ramping up the voltage the way it should. May have to replace it. A good service shop would be able to do this for you.
Blessings,
A/V Media Guy

Nov 20, 2009 | Mitsubishi WD-65733 65" HDTV

2 Answers

Power light blinks also lamp program blinks no picture no sound


you either have several burnt diodes or the cpapciters in each corner are burned out

Dec 28, 2008 | JVC HD-52G786 52" Rear Projection HDTV

1 Answer

No Picture/Sound


can you go to the error menu?
im assuming it's the lamp however the error menu will tell me more
If the standby light blinks five times repeatedly, that's indication of a "Lamp driver error". The probable cause listed is, "lamp driver faulty". Its also possible that the internal antenna used to detect the presence of high voltage has become mis-positioned. The lamp driver provides the high voltage. If no high voltage is detected, it is assumed that the lamp driver is faulty.
Otherwise, it is assumed that the lamp is bad and the LAMP LED lights
the part number for the lamp is XL2000U. Its available for $200 at http://servicesales.sel.sony.com/ecom/accessories/web/productSearch.do. Use the Part or Accessory Number to locate the part.

Jan 17, 2008 | Projection Televisions

2 Answers

No picture or sound - Power Save light blinks red 5 times - nothing on the screen


i also have the same problem with the flashing green light for a while then a different red light starts blinking on and off around 5 times....and i replaced my burnt bulb with a new one...still no picture.

Oct 24, 2007 | Sony Grand WEGA KF50WE610 50" Rear...

1 Answer

Weird Rapid Metallic Popping Sound


I think i have the same problem, but i can get audio still. did the poping plinking sound come from the inside back panel of your TV? it sounded almost like a arc wielding noise?

Sep 29, 2007 | Sony Grand WEGA KDF-50WE655 50" Rear...

Not finding what you are looking for?
Toshiba TP55H60 55" Rear Projection Television Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toshiba Projection Televisions Experts

Jaime Hernandez

Level 3 Expert

2267 Answers

Dave Naylor
Dave Naylor

Level 3 Expert

834 Answers

The Knight
The Knight

Level 3 Expert

68223 Answers

Are you a Toshiba Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...