Question about Sony SA-WM500 Subwoofer

3 Answers

Light on front isnt on at all..

Doesnt seem to power up at all.. Is there a fuse somewhere ?

Posted by on

  • Anonymous May 05, 2009

    How would you go about doing that.

×

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Actually, there is a fuse. You need to take out all the screws and remove the two dials so you can take off the panel. Look to where the power cord connects to the board, and you will see the fuse. It is a 125V 4 amp fuse.

Posted on Nov 22, 2009

  • ishjessica95
    ishjessica95 Oct 03, 2012

    Where can you Buy 125v 2.5amp at?

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 40 Answers

No, its probally the power supply, i would try putting a new power supply in

Posted on Jul 25, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same problem with my klipsch kw-100 I am thinking the fuse is blown on my sub its prolly the same with your sub

Posted on Sep 21, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi i have a 2007 chevrolet spark. The ligther doesnt work. Does someone perhaps know where does the fuse of the ligther is i can't seem to find it.


is everything else working
somewhere inside the car under the dash or kick panel areas
should be a fuse panel cover to pull down or off

will have a legend to point out the lighter fuse

26227943-baaqz4pc4guywvkqfm2wgc1t-4-0.jpg

Jun 29, 2016 | Chevrolet Cars & Trucks

1 Answer

Why did i lose power to my windows,stereo,interior light,cruise control etc,, all at the same time with fuses seeming to be all fine


These are often on the same power circuit, have you tried checking for a voltage at the fuse? It sounds like a break somewhere, if the powers ok at the fuse, it can be difficult to find where the break is. You might need to get an auto electrician in.

Oct 26, 2015 | Cars & Trucks

1 Answer

My printer isnt feeding paper and it has plenty in the shoot


You may have a piece of paper jammed somewhere, open inspection hatches and check

Jul 23, 2014 | Canon Pixma MP600 Printer

1 Answer

Hey i have a scosche in-line fuse block i purchased. I haven't had any problems until recently. My fuse fried. So i bought more and went to replace it and every fuse i try instantly fries. i cant seem


Most likely the amplifier you have hooked up to that fuse position is defective and causing the fuse to blow. Or you have a short in the powerline somewhere. Disconnect the power wire from the amplifier, tape up the end so it won't short out to anything. Replace the fuse, if it doesn't blow then you will need to get the amp checked, if it does blow, then you have a short somewhere along your power wire.

Jan 30, 2014 | Scosche Industries Car Audio & Video

1 Answer

I have a Ricoh Aficio 2500sp copier, a paper got jammed which was released and i closed the door at the side (as normal) the copier stop working as though a fuse went...... Ive checked the plug, socket and...


check at the back of the machine, somewhere around the power cable, there should be a small black trip switch, if that doesnt work then check the fuse on the power supply board after you unplugged the power cable

Nov 03, 2013 | Ricoh Aficio Office Equipment & Supplies

1 Answer

Wire diagram vw caddy van for stereo


As you have power to the eject and cd, it would seem to be a problem with the Power switch on the head unit.

Jul 14, 2013 | Vehicle Parts & Accessories

1 Answer

I have no power ? But, battery and fuses seem ok.


WHEN DID THIS FIRST START, DID YOU DO ANY THING THAT MIGHT HAVE CAUSED THIS. CHASE THE POWER FROM BATTERY TO FUSE PANEL THERE MAY BE A MASTER FUSE SOMEWHERE TAHT YOU HAVE MISSED.

Jun 05, 2013 | 2000 Harley Davidson FLSTC Heritage...

1 Answer

1999 chev astro van


Sounds Like You Have An Exposed Hot Wire Somewhere. I Would Try And Change Cig Lighter Wiring Harness. Be Sure And Check Your Aux Outlets So That There Are No Exposed Wires. They All Run On The Same Fuse Hope This Helps!!

Feb 12, 2013 | 1999 Chevrolet Astro

1 Answer

1995 Chevy Caprice Wagon, right side signals and brake lights dont work


change the bulb if still out then check and test socket/ground wiring/wire harness for damage

Apr 28, 2017 | Cars & Trucks

Not finding what you are looking for?
Sony SA-WM500 Subwoofer Logo

879 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...