Question about Sony TA-N1 2-Channel Amplifier

2 Answers

The Sony TA-FB930R amp I have is giving a intermitten clicking, any idea what causes this

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

TA-FB930R. Unplug the power chord; all other wires can remain attached. Remove the top cover. Get some compressed air (aerosol, pump or compressor). Pull off the volume button and remove the little circuit board behind it (Beware of short circuit, even with power off!). This gives you enough room to blow compressed air behind the front circuit board to clean the selector (the culprit). While at it, clean the entire amp with compressed air.
First of: All electrical circuits collect dust > dust collects moisture > moisture vaporizes, making the problem go away temporarily after 10 minutes.... The second biggest culprits in general are: Oxidized connectors (use special spray and move them a little.). Loose components (circular crack around component leads, caused by heating and cooling of the circuit boards; solder them again). Worn or dirty potentiometers (tone/volume controls etc.). Clean, spray or replace. And third; check for burn spots and moist pointing at fried or leaky components. 9/10 you won't need a manual to fix electronics.

Posted on Nov 27, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

In addition to my previous comment:Shortly, my amp started clicking again. Being more thorough this time, I carefully pried the selector switch a bit to add some contact spray.
However, this time the culprit wasn't the selector switch, but the switch inside the headphone socket. Spray with dedicated contact spray (not WD40) and plug in/out your 6.3 millimeter headphone plug a few times.
(An intermitting fault is a pain in itself; when having different causes it can drive you up the wall. Glad I've got it fixed :-)

Posted on Oct 27, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony ta av431 Stereo Amp Front speaker do not


Have you check your sound configuration at front panel?

Oct 09, 2013 | Amplifiers & Preamps

1 Answer

I have a Sony power amp TA-N9000es there is no sound do you need a remote or is there a volume control inside the case. Have tried every input every speaker connect there is just no sound. what can i do...


It's just a big amp with no controls you would change during normal operation. There's no remote. You don't name any source or if you even HAVE one attached. THAT would be a good place to look for missing sound.

Register and download the manual for free audio.manualsonline.com

http://audio.manualsonline.com/manuals/mfg/sony/sony_ta_tan9000es.html

http://dl.owneriq.net/f/fede44fb-b9ba-4e03-87bb-d0f3e29e22ef.pdf

Set the BTL/Normal switch on the back to Normal. In fact, any switch or knob with BTL, set it to whatever choice is NOT BTL.

Mar 24, 2011 | Sony TA-N9000ES 5-Channel Amplifier

1 Answer

Sony TA-E9000es. No Display, No Sound. Software Ver 1.18. Has Bulletin HIFI1-99-028R1 performed. (Add capacitor, replace resistor)


also replace Q108 @ Q109 on power board. If that does not fix it then also replace PH101 & PH102. Also on Power board.

Jan 14, 2010 | Sony TA-E9000ES Amplifier

1 Answer

I have 2 questions will my SONY TA-E9000ES preamp work with my SONY STR-DG720 7.1 RECIVER and what SONY ES Amplifer was spefically made to work with the TA-E9000ES WHEN IT WAS ORIGANLY PRODUCED


Here's a page for the 1st one

http://home.online.no/~espen-b/ta-e9000es/

It will work with your 7.1 receiver. Just use one of the inputs on the 7.1 to connect to the Pre-amp

PLease rate my help if this helps

Thanks

Nov 04, 2009 | Sony TA-E9000ES Amplifier

2 Answers

HOW TO WIRE AN EQUALIZER TO A SONY TA-FE370 AMP


You can't wire an equalizer to this amp unless you only want to equalize one source, because it doesn't have a tape monitor function.

Jan 22, 2009 | Sony TA-FE370 2-Channel Amplifier

1 Answer

Find a user manual for a Sony TA-VE150 Amp


Just click below for electronics site download;


http://servicemanuals.vstore.ca/


http://www.eserviceinfo.com


Hope it may help you;

Regards,
VOTIT

Jan 07, 2009 | Amplifiers & Preamps

1 Answer

Sony TA-AV421 Amp


im needing help connecting my audissey aps 5+2 energy floor speakers . im confused on the 2 channels

Jul 30, 2008 | Sony TA-N9000ES 5-Channel Amplifier

1 Answer

Sony TA-N9000ES Flash light when turn on.


an amp of this size generates alot of heat internally when in use as these use mosfet ICs and can get very hot.
your problem is most definately dry solder joints and possibly quite a few at that.
i've repaired quite a few sony surround receivers with similar problems and have all been down to dry solder joints.

hope this helps.

Jul 26, 2008 | Sony TA-N9000ES 5-Channel Amplifier

2 Answers

TA-N9000ES Amp - Standby light constantly blinks - no sound


The flashing light is indicating that a fault has been detected, and it is staying in "protect mode". First disconnect all cables from the processor (except the power cord) and then power up the processor. This will eliminate the possibility of a shorted cable or a problem with any connected components. f the light still flashes, there is an internal problem and the processor will require profesional service.  

Oct 09, 2007 | Sony TA-E9000ES Amplifier

Not finding what you are looking for?
Sony TA-N1 2-Channel Amplifier Logo

625 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4593 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68368 Answers

Are you a Sony Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...