Question about Infinity BASSLINK Car Subwoofer

1 Answer

Red light comes on and then slowly goes out. No output

My basslink is hooked up and everything and when i turn my car on, the red light initially glows really bright and then in a matter of seconds goes away. Also, there is no sound coming out of the system. Both the amp's fuse and the fuse on the power cable are good. PLEASE HELP!!!!!

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 109 Answers

For some reason you are not getting constant power to the system. What gauge power/ground are you running? Describe your system to me and we'll see what I can do to help.

Posted on Jul 17, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Everything is hooked up and the ps3 turns on but it doesn't show up on the T.V


  1. Make sure the HDMI cable is connected to the HDMI OUT port on the back of the PLAYSTATION 3 system. Connect the other end of the HDMI cable into the HDMI Input port of the TV or display monitor.
  2. While the PLAYSTATION 3 system is in standby mode (red light on the front of the system), hold down the touch-sensitive power button on the front of the system until the system goes into standby mode again . (So the light cycle would go from: red light --> green light --> then back to red light). This will ensure that you have held down the power button long enough to reset the Video Output Settings.
  3. Turn on the PLAYSTATION 3 system and once the system finishes powering up, the Video Output Settings will automatically reset to the standard resolution (or detect the current display output settings of your TV/monitor).

Jun 27, 2010 | Sony Playstation 3 (PS3) Console

1 Answer

Basslink has no output, but Power LED and Servo LED always on.


Hi,

One or more of the DC to DC outputs might be bad. Check the
/- 54v on the main PCB and the /-15v on the switching controller PCB.
Losing one side of the 15v will cause the limit comparator to rail and force the servo protection, even with no input signal.

Apr 02, 2010 | Infinity BASSLINK Car Subwoofer

1 Answer

Is the light on the infinity basslink suppose to be red or green


Hello jmw3031,

The Basslink should have both a red power LED and a green servo LED. The red LED should be on when power is applied. The green servo LED should only come on during high-level bass transients. Turn the gain down slightly if it stays on for extended periods.

Hope this helps.

Jul 15, 2009 | Infinity BASSLINK Car Subwoofer

1 Answer

Basslink Powerlight comes on then fades quickly


check to make sure your remote wire is hooked up to your amp turn on that runs straight out of the stereo not your power antenna also make sur you have a clean ground(no paint or rust) and also check your connections make sure you have a strong connection to all wire hook ups.......you should check to see that your remote wire has no tears in it or small rips or cuts because that can interrupt your current to and from the amp and radio

Jun 25, 2009 | Infinity BASSLINK Car Subwoofer

1 Answer

No picture but have green light


  1. While the PLAYSTATION 3 system is in standby mode (red light on the front of the system), hold down the touch-sensitive On/Off button on the front of the system until the system goes into standby mode again . (So the light cycle would go from: red light to --> green light --> then back to red light) This will ensure that you have held down the On/Off button long enough to reset the Video Output Settings.
  2. Turn ON the PLAYSTATION 3 and once the system finishes powering up, the Video Output Settings will automatically be reset to the standard resolution (or detect the current display output settings of your TV/monitor).

May 24, 2009 | Video Game Consoles & Games

1 Answer

Basslink red light on but no sound


check the all power lines and regulator .is any of them overheating?
then check the power amp ic or transistors.

nuwan.

Jan 12, 2009 | Infinity BASSLINK Car Subwoofer

1 Answer

2nd Basslink, still no power-on. Please help


this is in response to the post below:

I just bot a basslink t and i wired it up and nothing it just keeps blowing the fues in the unit i got mine on ebay2.gif so i dont know if i can use the warranty dose anybody have an ida for me- britter623

I got a used basslink about a month ago and had the exact same prob kept blowing fuses...found out that the voice coil had blown on the infinity...so I had a brand new dvc polk 10 sittin in the closet, I swapped them out, put the polk in the place of the infinity sub, however, the magnet is much larger, hence, dual voice coil, it would rattle sooo much from the passive radiator against the magnet, also could not turn the gain up at all due to the rattle. I got the bright idea to build a "custom fiberglas enclosure for the polk and incorporate the infinity's parts(amp/control) I finished the box finally last night and hooked it up this morning, no power, no lights, no nothing! s@#%, F&@%! ANyone had a prob w/the amp not having the lights turn on, no power??? Hope that helps about your fuse blowing issue.










Jul 15, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

Basslink Stoped working after a month ** sound ** red LED


check all your power fuses and insure you havec power where it is supose to be. maybe you have blown a fuse.

Mar 09, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

Red light


It sounds like the output transistors have failed. Disconnect everything from the amp except for the B+, ground and remote and turn the amp on. If it goes into protect, the amp is in need of repair. If you want to repair it yourself, email power acoustic for the schematic.

Oct 02, 2007 | Power Acoustik LT-980/2 Car Audio...

1 Answer

Basslink servo light constant on


defect age,short worn its time through had the same thing happen to mine,A SUGGESTION PUT A 25 AMP FUSE,AND PULL IN AND OUT THE GAIN TUG IT,IT SOMETIMES STICKS AND SHORTS YOUR UNIT OUT,GOOD LUCK

Feb 23, 2007 | Infinity BASSLINK Car Subwoofer

Not finding what you are looking for?

Open Questions:

See all Infinity BASSLINK Car Subwoofer Questions

Infinity BASSLINK Car Subwoofer Logo

Related Topics:

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Infinity Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22059 Answers

Are you an Infinity Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...