Question about Vacuums

Open Question

Dirt devil envision wide path

I can't figure it out. This vacuum has no suction at all. I've taken it apart and it's not the belt, the hose isn't clogged, the filter is freshly cleaned. I took the roller out and put my hand over the suction hole and there is no suction at all.

Any clue what to check next?

Thanks,
Thea

Posted by on

  • ell2scott Sep 23, 2008

    I have the same problem, but I do have suction in the hose - just not the main part of the vac! It's pretty tedious trying to vacuum the whole house with the hose!

×

6 Suggested Answers

  • 298 Answers

SOURCE: Attachment hose has no suction

Sometimes when you take them apart and
reassemble the vac (the plastic slide doesn't
make full contact with the lever,or it isn;t on
the lever at all) that switches
from the floor to the attachment. IF Tthere
are no clogs in the duct then that the
most likely problem

Posted on Nov 18, 2007

  • 126 Answers

SOURCE: Vacuum Problem

The Bissell can have several filters in it, depending on the model. Some have a round hepa filter that is covered with a foam sleeve. This filter is located at the bottom of the dirt cup. Others have a foam filter that is located under the dirt cup in a pull out drawer. Also, they can have a cylindrical separator above the dirt cup which can be removed and washed. They are usually a blue plastic and you reach in and turn it a 1/4 turn counter-clockwise to remove. If your machine has the hepa filter, when you remove the dirt cup, the filter is at the bottom and you turn the bottom 1/4 turn and the clear housing will come off to access the filter. You should also check the small filter on the machine just below where the cup sits. This will only be there if your machine has the hepa filter on it.

Posted on Mar 21, 2008

ukvacfan
  • 328 Answers

SOURCE: Dirt Devil Vibe No Suction

Sounds like there is a clog somwhere. Check the hose - you can undo the hose with a screwdriver but because of that bend use a pipe cleaner or a long wire to see if there is anything blocking the tube. Next check the dirt channels from the bottom of the hose on the Dirt Devil Vibe once the hose has been taken off. Check that the bottom part is clear and then tip the machine over, remove the bottom sole plate (4 screws, 2 at the front and 2 at the back near the rear wheels) to check the roller brush - sometimes if there is an obstruction in the dirt channel from the roller brush suction will not get through.

Dont forget however that there are two filters on the Dirt Devil Vibe. The top filter has to be unscrewed and then unlocked. Tap it a couple of times to dislodge any dirt and then lift out the second part filter at the top of the bin.

Dont forget to rate if this advice works. Thanks.

Posted on Jul 30, 2008

  • 1 Answer

SOURCE: dirt devil vibe 088915v

Are you talking about the beater bar? If so, you probably have a broken belt

Posted on Jan 16, 2009

  • 1 Answer

SOURCE: dirt devil purpose for pets vacuum quit working

The motor overheats from the filter being clogged underneath the canister or the canister or both are clogged-without the air flow the motor overheats and shuts off as a precautionary measure.By letting the motor cool off it will start again but will turn off shortly if the filters are not properly cleaned.Hope this helps everyone.
Rob

Posted on May 14, 2009

bozcro
  • 867 Answers

SOURCE: The dirt devil vision wide glide Model 086700W

there must be a blockage after the hose, check where the hose plugs into the vacuum. make sure unit is un plugged for safety

Posted on Aug 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Nothing going into dirt canister


Is there suction at the hose? If not it is either blocked or the suction fan is broken. If there is, then there is a blockage in the pickup section, something is lodged across the channel after the brushes and before the place where the hose plugs in.

I think there is a safety switch to prevent it from running with the canister out so hard to check for suction at the top of the motor/suction fan. Make sure nothing is over that part under the canister too! If you can figure out how to bypass the safety switch (if there is one), you should have good suction where the canister sets on top of the motor base.

Oct 06, 2012 | Dirt Devil UD40270RM Quick Power Compact...

1 Answer

No suction


the hose can clog up insid where you cant see it my husband takes it off and runs water thru it to flush stuff out lets it dry then reconnects it

Sep 18, 2012 | Dirt Devil Featherlite Bagless Vacuum...

1 Answer

I have a Eureka Contour model 2900 type A upright vacuum, the roller works fine nothing clogged, took it apart motor blade is free of debris, no suction from tube and blasts OUT air from the front HEPA...


Even with your explanation,it seems the hose is clogged.Try taking the hose off,then blow through it or pour water through it.If this doesn't do it,make sure the suction canals are going to the proper areas.

Apr 04, 2012 | Eureka 2900A / 2901A Contour Bagged...

1 Answer

Burning smell from vacuum, but not from the belt


Possibly motor is going bad like that stator wearing out.

Aug 26, 2009 | Vacuums

2 Answers

No suction


Check the main filter cone - if it has a rip in it, then there won't be any suction in it, also clean it gently with a paint brush to get all of the dust out and check the back of the upright after the bin is taken out as sometimes there is dirt clogged at the back. Check the front of the sole plate i.e. where the roller brush is and check the dust channel behind this as it can get clogged. Due to the nature of this vacuum with the hose being located at the front of the floor head dirt can be trapped but most of all its the paper pleated cone filter that needs a good brushing. Hope that helps.

Feb 25, 2009 | Dirt Devil Featherlight Bagless Upright...

1 Answer

Suction


hello tnwalkergal the hose may have a clog inside the hose at the bend you can take the hose loose and run a broomstick or a yardstick thorgh the hose this is how I find the clog

Jan 24, 2009 | Dirt Devil M086700 Vision Bagless Upright...

1 Answer

No suction


If you have low suction at the end of the hose, then you either have a clog in the hose or a clogged filter. Take the hose off and drop something in it to see if it comes out the other end. If you have suction at the end of the hose, then the dirt inlet by the brush roll is clogged.

Apr 07, 2008 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover Windtunnel


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is a filter at the bottom where the dirt cup (and bag) is, check it also.

Dec 28, 2007 | Vacuums

2 Answers

Attachment hose has no suction


Sometimes when you take them apart and
reassemble the vac (the plastic slide doesn't
make full contact with the lever,or it isn;t on
the lever at all) that switches
from the floor to the attachment. IF Tthere
are no clogs in the duct then that the
most likely problem

Nov 18, 2007 | Dirt Devil 12 Amp HEPA Filter Vacuum...

6 Answers

Vaccum has no suction


Need a new belt -- you might have suction but you need the brush to spin (hard to help without make or model, upright or canister)

Oct 17, 2007 | Kenmore 25614 / 25615 Progressive Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

44 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18304 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...