Question about Dirt Devil Vacuums

2 Answers

The unit does not start when thbe switch is turned on

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 327 Answers

Could be a bad switch or one of the wires came off or the motor went in it the way i would check it first is the see if there is a connection get a volt meter and put on oms and place it on the plug turn on and off the switch there should be voltage going through it it not the the switch or the wires are messed up ..take out switch and try same thing with the volt meter and try the wires to if no voltage in one of the systems then there is a problem ...70% sure it is the switch

Posted on Jul 14, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,847 Answers

Do a power cycle by unpluging and holding the power bottom for 30 sec and re plugging back.

Posted on Jul 14, 2008

  • Legin Varghese
    Legin Varghese Jul 14, 2008

    if still not open the unit and chk for any loose contact between wires any burned wires. if not it is the motor.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Will not start: no power at all when power switch turned on.


Could be cord reel unit, power cord or switch....lastly the motor, check all with a voltage meter or if need further assistance let us know

Feb 23, 2014 | Hoover SH40060: Multi-Cyclonic Canister

1 Answer

Hoover Model SH80520 starts and won't quit


that's how it's supposed to operate, switch on turns the unit on. switch off turns the unit off. thier is a wire that is connected to the leads on each outlet that turns the unit on when the hose is inserted and the switch is in the off position.

Mar 30, 2012 | Vacuums

2 Answers

The Vaccum is not turning on when i plug the hose into the wall. The hoover system will turn on when i turn the switch on at the base and wont go off till i turn the switch off. But it will not come on...


you can test this out by taking a small metal spoon and with the bottom side of the spoon insert it into the vac outlet on the wall. you want to touch the two metal pins inside the vac outlet to test if the unit is the problem or the hose is the problem.

If the unit starts, the hose should have a 3 year warranty on it. I recommend you have your nearest beam dealer check it out.

If the unit does not start, it has a 7 or 10 year warranty, the circuitry should be replaced. Again have your nearest beam dealer check it out.

good luck

Nov 06, 2010 | Beam Industries Vacuums

1 Answer

ARE THE BRUSHES SUPPOSED TO TURN ?


the unit has a safety switch in it that only starts the brushes turning when you have the unit in the reclined position for using it on the carpet.

Nov 04, 2010 | Hoover WindTunnel V2 U8148-900 Upright...

1 Answer

Our Easy-Flo built in vacuum system will not turn off, even when the hose is disconnected. We have to turn it off manually. Could it be a short in one of the wall outlets causing this?


Some models have an on/off switch on the power unit itself. This switch is used to turn your power unit on when you are right at the machine.
If there is no switch on the power unit, unplug your power unit from the wall socket, look for two low voltage wires coming out of the power unit. These two low voltage wires are usually either attached with terminals or are tied to two wires coming out with plastic screw on wire caps. Disconnect the 2 low voltage wires. Plug your power unit back in. If the power unit does not come back on then yes, the problem is most likely a short in the outlet wiring. If the power unit still comes on with the 2 low voltage wires unattached, then the problem is in the internal circuitry of the power unit, usually a relay or some units have a circuit board with relay, circuit breaker and other components on it. The relay or circuit board will have to be replaced.
It's a little difficult to check for a short if you have multiple outlets, but if you've recently done some renovations you might start checking in that area.

May 19, 2010 | Easy Flo EF1400 Central System Vacuum

1 Answer

Nutone Scovill 350 will only turn off if unplugged


Some units have an on/off switch on the power unit itself. Check to make sure that is not turned on. Unplug your power unit and remove the 2 low voltage wires (not the power cord itself) . The low voltage wires start at the unit and run throught your home and attach to each hose inlet. They are usually attached to the unit by simple wire terminals or wire capped to small wires coming out. Just unlug the terminals or unscrew the wire caps and pull the connections apart. Plug your machine back in. If it still comes on the problem is the relay or circuit board/switch/ relay assembly inside the unit. If it doesn't come on with the low voltage wires unattached then you may have two wires touching somewhere in the low voltage wiring.

May 14, 2010 | Broan-NuTone CV353 Central Vacuum

1 Answer

Will not turn off when hose is pulled out of wall


Some units have an on/off switch on the power unit itself. Check to make sure that is not turned on. Unplug your power unit and remove the 2 low voltage wires (not the power cord itself) . The low voltage wires start at the unit and run throught your home and attach to each hose inlet. They are usually attached to the unit by simple wire terminals or wire capped to small wires coming out. Just unlug the terminals or unscrew the wire caps and pull the connections apart. Plug your machine back in. If it still comes on the problem is the relay or circuit board/switch/ relay assembly inside the unit. If it doesn't come on with the low voltage wires unattached then you may have two wires touching somewhere in the low voltage wiring.

Jan 26, 2010 | Broan-NuTone CV450 Central Bagged Central...

1 Answer

Central vac won't turn off unless we unplug


Some units have an on/off switch on the power unit itself. Check to make sure that is not turned on. Unplug your power unit and remove the 2 low voltage wires (not the power cord itself) . The low voltage wires start at the unit and run throught your home and attach to each hose inlet. They are usually attached to the unit by simple wire terminals or wire capped to small wires coming out. Just unlug the terminals or unscrew the wire caps and pull the connections apart. Plug your machine back in. If it still comes on the problem is the relay or circuit board/switch/ relay assembly inside the unit. If it doesn't come on with the low voltage wires unattached then you may have two wires touching somewhere in the low voltage wiring.

Jul 18, 2009 | Broan-NuTone CV350 Central Vacuum

2 Answers

Central vac (Hoover) always on!


There should be a manual/auto switch. If it is in the manual mode, then it will run all the time. Other then that you probably have a stuck relay. But this will have a years warranty on it, so you should be able to have it serviced under warranty.

Oct 08, 2007 | Hoover L2310 GUV Central System Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dirt Devil Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Dirt Devil Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...