Question about Hoover F6212-900 / F6215-900 SteamVac Agility Upright Vacuum

1 Answer

Suction When putting down the salution, my hoover doesn't want to pick it all back up. Very little suction. Any tips to what I can do myself?

Posted by on

  • todv Aug 24, 2008

    Not taking up any dirty liquid. None.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Take the recovery tank out, there is a filter on the handle part where the tank sits in, make sure it is clean. Check for any other filters to make sure they are all clean.

Posted on Sep 01, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Hoover f8100900 will not suction


Here is a site which will guide you through possible causes that are causing the problem with your vacuum and help you pin point the correct one. Hope this helps. https://www.repairclinic.com/RepairHelp/How-To-Fix-A-Vacuum-Cleaner/113-203--/Hoover-Vacuum-cleaner-won-t-pick-up-no-suction

Jan 12, 2018 | Hoover F8100900 Upright WetDry Vacuum

1 Answer

Hoover windtinnel suction problem


the intake hos at the bottom might be clogged.first take all the filters out and disconnect the hos completely from the vacuum,then check and see if you have suction.the intake hose is the clear looking one at the bottom that wrapps itself up from the base to the backside of the upright.you can use a coat hanger to push out the clog if there is one just bend the tip till its rounded.work it down into the intake hose from the back.after removing the hose and the filters you should have suction.just make sure all the filters get cleaned .you can blow out the hose with a garden hose

Apr 02, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

No suction in carpet cleaning mode with Empower


Check the nozzle . Turn it over on it's belly and remove the 4 screws that hold the base plate on. Take off the plate and remove the brushroll. I bet you will see a clog in the intake. If not take it to your local vac shop and let them fix it.

May 28, 2017 | Hoover U5262-900 / U5260-900 / U5266-900 /...

1 Answer

No suction


Check again for obstructions in the hose. Also underneath where the debri goes when it is being sucked up. Also make sure all your hoses are connected as this could effect the suction.

Nov 29, 2008 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

No suction


have u checked all of the filters. I know that when not all the filters r clean the machine will turn on but then it will sound louder and still have no suction. Most times there is a filter under dirt container thats sits above motor and if this filter is not clean the motor cannot breath. Thus no suction

Sep 29, 2008 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

It has been cleaned , yet there is no suction the hoover wont pick hardly anything up & it gets hot very quickly


Then there most be a clog either in the hose or the dirt inlet by the brush roll. If you pull the hose off like you are going to use an attachment, is there suction there. If not, then the problem is in the hose. If there is suction, then the problem is down below,

Jun 14, 2008 | Hoover Vacuums

6 Answers

No suction


I finally got my steamvac F5914-900 suction to work after I read someone review about it on amazon. Here is what that person suggested for suction problem and to my surprise it worked.

1. Any time you aren't getting suction, the first thing to do is check the dirty water bin. I re-seated the thing about ten times this morning, trying to figure out why suction on the unit had ceased. (The dirty water tank was bone dry.) I was frustrated because I was absolutely sure everything was seated properly, but was still getting no suction.

Finally, I pushed on the lid from the _sides_ rather than the back or front while attaching it to the tank, and it seated a little bit differently. Suction was restored!

2. To clean out the suction area, pour some hot water on a tile floor (NOT wood) and **** it up. Repeat until everything is flowing smoothly. Sometimes, reduced or minimal suction is due to gnarly clogs. Again, though, if you're getting NO suction, the culprit is probably the dirty water bin's lid.
I hope this helps.

Mar 23, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

No Suction in Hoover U6450-900


If there is no suction, check the filters, if they are clean then there has to be a clog either in the hose or in the inlet down by the brush roll. See if there is suction at the hose end. If there is, then it is clogged down lower. Are you sure that the brush roll is turning when it is on the carpet? For a manual, go to www.hoover.com, put on your model number, if one is available, you can down load it.

Jan 07, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Windtunnel


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is a filter at the bottom where the dirt cup (and bag) is, check it also.

Dec 28, 2007 | Vacuums

9 Answers

Hoover Agility, No Suction!!!


I had the same problem. Lower the handle to the floor and check the black spiral suction hose at the neck of the machine. The lower hose in my Hoover split. Check and see if yours has done the same thing. If so, the lower suction hose will have to be replaced. Hope this helps.

Oct 04, 2007 | Hoover F6212-900 / F6215-900 SteamVac...

Not finding what you are looking for?
Hoover F6212-900 / F6215-900 SteamVac Agility Upright Vacuum Logo

Related Topics:

64 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...