Question about C. Crane FRS AM/FM/SW Radio

1 Answer

No Sound I have a Sangean Platinum Edition CCRadio that I've owned for 6 years+. Has always been plugged in with the original power supply. The display comes up, tunes to channels but no sound. It has never been droped or smacked. Have tried reset . . . no worky. Rufkarma

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Try plugging it the headphones in and out a few times,problem could be bad connection it that connector

Posted on Aug 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 Pontiac Vibe - 4 Cyl. 150k miles. Ignition coils keep going bad - every 4-6k miles. Coil 1 has been replaced 4 times, Coil 3 once. Coil 4 twice in the past year (20k miles). All spark plugs


Install new spark plugs, 4 new coils & replace the oxygen sensors

O2 Sensors are only good for 100,000 miles, then slow
down or quite

No idea why the coils do not last 5 or 6 years

Cylinder #1 is always at the front on a 4 cyl

Go to Rock Auto --Buy Wells Coils,NGK Double
Platinum Plugs & NTK O2 Sensor

Those parts are expensive because you have a Totota
Motor I guess

Clean MAF Sensor with CRC MAF Sensor Cleaner

Jan 08, 2013 | 2003 Pontiac Vibe

1 Answer

My Telefunken 42" Full HD


The problem might be on your power supply.

1. Check the power supply it is located on where the plug is connected on the main board.
2. Use a multimeter it must be on AC function, to check the AC supply
sometimes the problem is just on the plug
3. Then if there is an AC supply on your plug then check the power supply
4. Check for busted fuse (usually has no reading on multimeter on diode test)
replace same type of fuse.
5. If the fuse are good check for open resistor or shorted transistors.
always replace same rating of resistor and transistors (same on number and type)
IF the problem still exist just contact me.

Hope this may help you..

Aug 20, 2011 | Televison & Video

1 Answer

Vegas movie studio hd platinum 10.0


Welcome to FixYa

Professional-Level Power for Your Home Studio. Vegas Movie Studio HD Platinum software has everything needed to produce spectacular HD movies. Edit video in nearly any format including HDV and AVCHD. Powerful features for video compositing, color correction, and soundtrack creation help you get feature-film results in your home studio. Use the surround sound mixing tools to create 5.1 soundtracks. Choose from hundreds of professional 2D and 3D video effects, titles, and filters. Upload movies to YouTube, burn to Blu-ray Disc, or author DVDs using beautifully designed themes or your own custom menus and graphics. Exclusive Sony Show Me How interactive tutorials help you get started fast. Vegas Movie Studio Platinum Edition - powerful tools for video compositing, color correction, and surround sound mixing help you get feature-film results in your home studio. To share, upload movies to YouTube, burn to Blu-ray Disc, or author DVDs with custom menus and graphics.
For More Click here
Thanks for Contacting FixYa

Jun 27, 2010 | Sony Vegas Movie Studio Platinum 9 for PC

2 Answers

Numark 360 21v 750ma Power Supply


Try the following sites

http://www.powerstream.com/power2.html

http://www.platinum-records.com/Numark-21V-750MA-AC-Adapter-Power-Supply-prod7509.htm

Or even a cheap replacement laptop power supply as these usually start at 1000 mA which will give you current to spare and have a longer lifetime. most of these cover from 15V to 24V and are either auto switching or manual select for the voltage. Plus you can pick these up from most electronic / big box / supermarket shelves

Aug 10, 2009 | Numark DM1200 DJ Mixer

1 Answer

Sangean ATS-803A - no audio


If its not a micro-p glitch, sounds like the radio was subject to a spike or surge wile plugged into the AC adapter. If the "power" light stays on all the time, thats what happened. Believe me, I was Sangean America's tech from 1990-1995.
Rob
The fix is to replace a transistor, or fet in the main pwr supply. (Close to where the adaptor plugs in.)
I wish I could give more details, but its been 14 long, long years.

Jun 03, 2009 | Sangean ATS 808A AM/FM/SW Radio

1 Answer

Creative Labs Sound Blaster Audigy 2 ZS Platinum


Hello,

No, you cannot fix this. Any replacement you buy will work fine no matter where you are located. You may want to do a Froogle search from Google and shop by reseller rating and price.

It is the Power Supply for the PC that needs to be adaptible with your country's power grid. So, don't worry about that just be more careful, as I'm sure you will, when you install the power plug to your sound card.

Regards,
Worldvet

May 18, 2008 | Creative Labs Sound Blaster Audigy 2...

3 Answers

NO Sound - 865PE Neo2-PFS Platinum Edition


You need to install the correct version of the sound drivers from the MSI website under your motherboard type. Third party or from Realtek sound drivers won't make you sound chip works. If after installing sound drivers from MSI website still don't work then your on board sound chip colud be defective.

Jun 29, 2007 | Abit AS8 Motherboard

1 Answer

ATS 505 Power Supply Problem


Make sure no other buttons are held down when powering up, although you usually see a clock on the display if there is power but the unit is locked up for another reason. The fact that you've tried batteries and you've tried the PSU suggests to me that there is some other problem with the radio, it could be as simple as a dry joint, but without experiencing the same problem myself it's not possible to suggest anything further.

Sep 18, 2006 | Sangean ATS 505 AM/FM/SW Radio

1 Answer

SANGEAN ATS505


try the power switch a few times and more force than usual.

Sep 16, 2006 | Sangean ATS 505 AM/FM/SW Radio

Not finding what you are looking for?
C. Crane FRS AM/FM/SW Radio Logo

Related Topics:

254 people viewed this question

Ask a Question

Usually answered in minutes!

Top C. Crane Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

4850 Answers

The Knight
The Knight

Level 3 Expert

72601 Answers

Are you a C. Crane Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...