Question about JBL Venue SUB10 Subwoofer

1 Answer

I have a powered sub woofer, i noticed it started to make scratching sound or popping, then i noticed it wasnt on and had a red light on the back instead of a green light. I turned it off for a hr and then it came on, well that worked for a week, now i have no luck with it turning on?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 60 Answers

This item needs to be repaired - shorted or bad parts on board. See Ebay for Repair of JBL and Infinity Amps - Specific Models - Search - Be Happy:)

Posted on Nov 11, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Cadence 400 watt active sub green light on, no sound from the sub. whats wrong?




proceed according and fix it. However yi\ou must read the diode LED for diagnose. God bless you

Mar 26, 2013 | Exercise & Fitness

1 Answer

Subwoofer is not playing


It is hard to say. The sub-woofer has its own amplifier, although it is supplied the sound data from the main amplifier. It could have a problem with the battery power circuit (Sub-Woofer Amplifier Connector Pin 6, LIGHT GREEN/VIOLET) or it could have a problem with the GROUND circuit (Pin 2, BLACK/LIGHT GREEN) Or it could possibly not be receiving the signal from the main amplifier (Pin 7, BROWN/ORANGE "+"), (Pin 8, RED/BLACK "-"). Or it could be that either the sub-woofer speaker is blown, or the sub-woofer amplifier is defective.
There is also a "High Audio Mute" circuit that connects between the main amplifier and the sub-woofer amplifier.

Mar 06, 2012 | 2000 Lincoln Navigator

1 Answer

Power sub woofer is not working on my pioneer vsx-81txv everything is working all the speakers except the power sub connection at the back all i can hear is the hissing sound when i try to connect the sub...


Hissing? How loud? A sub isn't even capable of making high frequency sounds at normal volumes.

The Pioneer manual would tell you how to enable and test the subwoofer output.
Page 17 and the MACCV procedures on Page 33 (auto) or 43 (manual)

Jun 13, 2011 | Pioneer VSX-81TXV Receiver

1 Answer

Why isnt my woofer working?


Ok, that was some important information there. If you were tightening the 12V power line, small sparks are normal. You should also have a thin wire (often blue) going into a 3rd terminal. This is normally called the remote wire. It's the wire that tells the amp to turn on when your radio turns on. Do you have a remote wire connected? When you start your radio or car, does the amp light up? There should be a power indicator light -does it light up? There may also be a fuse on the side of the amp, pull this out and see if it's blown. If not, put it back in.

May 15, 2009 | Car Audio & Video

4 Answers

No sound in sound bar and subwoofer


It could be that the unit is bad, it could also be that the device providing the input is bad. I doubt the cables are bad, but that could be also. Could it be possible that your television has a menu setting that turns the outputs off and on?

Even without the sub, you still get sound through the Bar.

Only way to test it is, different cables, alternate device to provide input for sound.

Dec 14, 2008 | Boston Acoustics TVee Model Two TV...

1 Answer

Sub woofer flashing red and green


sir,,i think there is something wrong with the connections or the cross over,,,kindly check it out or mjaybe the cone of ur speaker is damage,,,hope too help you thnkss??

Jan 27, 2008 | Kenwood SW36HT Subwoofer

2 Answers

Amplifier problems!!!


it sounds like your running your ohms to low, check to see what the amp can power and then read up online about ohms and your subs and how they should be wired

Oct 12, 2007 | Car Audio & Video

6 Answers

Speakers cut off when bass goes up...


it might be that your wires from your amp to your subs are too thin. since they were relatively new the first three months, they were probably undamaged, but after pushing them too much, they probably have broken wires, and can't get enough power to the subs when turned up, i suggest getting thicker wires before investing in a capacitor, it could save you money.

Mar 21, 2007 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

Not finding what you are looking for?
JBL Venue SUB10 Subwoofer Logo

337 people viewed this question

Ask a Question

Usually answered in minutes!

Top JBL Audio Players & Recorders Experts

Michael Edwards
Michael Edwards

Level 1 Expert

60 Answers

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a JBL Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...