Question about NexxTech Portable Hi-Speed USB 2.0 Kit Hard Drive

1 Answer

My Nexxtech nhde35 ext. hard drive is suddenly not working. Now when I plug it in, the indicator light alternately blinks red/blue. The PC does not see the drive at all. Tried swapping to another hard drive in the nhde35 enclosure, but got same results. I had used this drive on 4 other ocassions to backup my system, so it did work.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Seems most likely that the drive enclosure has failed, since swapping to a different HD made no difference. If so enclosure will have to be repaired, or replaced.

Posted on Jan 06, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an external hard drive (NExxtech). It is flashing blue and red and I cannot open.


Sorry.... Not enough information
Mac or PC. USB port for power or plugged in to AC.
Flashing usually means busy reading& writing.

Oct 18, 2014 | Computers & Internet

1 Answer

Just bought the G-Speed Q 8TB. Hooked it up and the red warning light on the bottom is flashing. Is there something wrong with the drives?


The flashing red light is indicating that it is building the RAID5 parity information. If there is an alternating amber/blue lights on one of the drives blinking back and forth with the red light it is indicating that it is building/rebuilding the RAID5.

May 15, 2011 | G-Technology 0G01792 G-SPEED Q 4TB USB 2.0...

1 Answer

Red and blue light alternately blinking. What can i do.


Remove the drive from the enclosure and either install it in your machine as a slave or you will need to buy a new enclosure and put the drive in it.

Sep 17, 2009 | Acomdata (HD160UE5-72) (HD160UE572) 160 GB...

1 Answer

No install CD for NexxTech NHDE35


Apple MacOS 9, Apple MacOS X, Microsoft Windows 98SE/2000/ME/XP will support these If your using Vista It wont work, and no upload is available.

Apr 21, 2009 | Computers & Internet

1 Answer

NHDE35 Enclosure


Posted by Decoder1 on Feb 25, 2009 I also had a problem with XP not recognizing the hard drive. The USB Mass Storage Device was reporting a Code 10 (Device cannot start). Ryockey provided the solution in that the drive pins can be offset by one set when connected to the interface. Be careful to get the pins aligned correctly, it worked for me. I also have my drive jumper set for Master. Thanks Robert!
Randy P.S. I am using a Seagate 250 GB HD 7200.7 Ultra ATA

Feb 12, 2009 | NexxTech Portable Hi-Speed USB 2.0 Kit...

1 Answer

Red Light/Blue Light I/O Error


My nx2 is working again after having the "red light/blue light/I/O Error" problem. I just:

1. turned off my computer
2.unplugged the HD,
3. took out the HD from the enclosure and plugged it back into the enclosure,
4.started up my computer without the HD being plugged in
5. after my computer had been on for a minute, I plugged the HD in and my computer recognized it and had the proper mixture of red and blue light coming from the HD, indicating it's working properly.

Good luck!

Aug 26, 2008 | NexxTech Portable Hi-Speed USB 2.0 Kit...

3 Answers

HARD DRIVE ENCLOSURE RECOGNITION BY MY PC PROBLEM


Had the same problem today. I finally noticed that the pin bay on the enclosure was large enough to allow the pins to be offset by one pin set. The open pins were hidden by wires. Once I carefully aligned the pins, everything worked fine.

Robert

Jun 01, 2008 | NexxTech Portable Hi-Speed USB 2.0 Kit...

2 Answers

Problem setting up Enclosure


Please check if your jamper of the hardrive must be set to primary settings. Or possible your usb connector having lost contact problem.

Hope this will be helpful to you.

Oct 26, 2007 | NexxTech Portable Hi-Speed USB 2.0 Kit...

10 Answers

Nexxtech 3.5" Hard Drive Enclosure (NHDE35)


I'm not saying this will solve all problems, but it solved it for me. I am running Vista and got this to work following someone's instructions from another forum.

The slot in the enclosure that you plug the hard drive into has one set of holes fewer than the hard drive has pins. This means you can plug the hard drive in two ways "left" and "right" if you will. I had to plug my hard drive in so that the unused pins were farthest from the power cable that plugs into the hard drive.

Incidentally this made the screw holes line up better, too.

Oct 01, 2007 | NexxTech Portable Hi-Speed USB 2.0 Kit...

Not finding what you are looking for?
NexxTech Portable Hi-Speed USB 2.0 Kit Hard Drive Logo

Related Topics:

267 people viewed this question

Ask a Question

Usually answered in minutes!

Top NexxTech Computers & Internet Experts

Steven Wander
Steven Wander

Level 3 Expert

579 Answers

Joe Goldman
Joe Goldman

Level 2 Expert

335 Answers

Prashant M
Prashant M

Level 3 Expert

2260 Answers

Are you a NexxTech Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...