Question about Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

4 Answers

When using my hoover wind tunnel the last few times it has emitted a burnt rubber smell so my husband checked the belt and is wasn't broken or off but now when I use the vacuum the beater bar doesn't seem to be going around as well as it should be can you help

Posted by on

Ad

4 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,557 Answers

I take it the belt was put back on !! i would say hubbi forgot the tension arm a little black striker that can go in two ways but put in back wards it will not tension the arm

Posted on Jan 03, 2011

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 520 Answers

Belt has stretched or the bearings in the beater bar have failed. could also just be that there is hair abound the ends of the beater bar.

Posted on Jan 03, 2011

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 784 Answers

One thing to check is -- on both ends of the ' beater bar ' / roller brush assembly, check to make sure that there is no carpet strings or hair that have wound up against the roller bearings. if there does seem to be string and hair there, you will need to remove it and at the same time ( after it is clean and clear ) squirt some silicone or Teflon based lubrication on and in each end -- all this will restore the unit to a new condition.

c...

Posted on Jan 03, 2011

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,088 Answers

The problem is usually the beater bar end bearings are bound up with string, thread, and hair. Remove the bar, and clean the bar ends as well as the bearing blocks they run in. Lubricate the bearings lightly with 3-1 oil or similar, then reinstall the bar. Test the running on your carpet--if it seems to stall the bar, replace the belt as well. Hope this helps!

Posted on Jan 03, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I replaced my belts on my premium hoover wind tunnel and the roller barely moves. Also, I keep getting a rubber burning smell. I'm confused weather if it's worth to have fixed or buy new.


More then likely whats going on with your roller is on each side of the roller is bearings and hair or other things build up and makes it really hard to rotate.Take the roller off the vacuum and check you may be able to clean and oil them.

Jun 22, 2011 | Hoover Premium U45900 WindTunnel Bagged...

1 Answer

I have a windtunnel vacum cleaner. When I


It might be a slipping rubber belt, is the brush roller moving when you look underneath? If it's a self propelled machine there might be another slipping belt. Friction from fast rubbing rubber can smell like it is burning.

Jan 16, 2010 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

HI, my motorized brush barely turns.It makes a hot rubber smell. I took apart and noticed the spindle the belt turns on discolored from heat. Cleaned it, but still no turning of the brush.The vac is a...


That means that the belt is stretched and it is slipping on the motor shaft, that is why it is hot and smells like burning rubber. You need to replace the belt. Here is the correct belt you need:

Hoover Windtunnel Canister Belt

Dec 24, 2009 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

How do you change the Hoover wind tunnel belts?


If you turn the vacuum over there will be (4) screws that hold on the base cover for the roller brush. Remove the screws and the cover and you can get to the belt(s). You can get replacement belts here:

Hoover Windtunnel Belts

Nov 18, 2009 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

I've had the Hoover Windtunnel for a couple years now. Its starting to smell when you vacuum. Why and how do I fix it???


I was experiencing the same problem right after changing the belt for the first time, as my Hoover is just a few months old. I am assuming what you are smelling is burnt rubber, like your belt, right? Well, if you have changed your belt recently, make sure you are using the right one. If you're not using Hoover's authentic belts and you're buying it from Wal-Mart, make sure it's the correct one, otherwise it won't work right and/or it will give off a burnt rubber smell. One other thing you could try doing first, is raising the carpet height adjustment up a notch or two. If you have it too low and your beater-bar/brush roll has to work too hard, it will start to smell also.Good luck!

Aug 07, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Vacuum shuts off and has a burnt smell


Hi,
Try removing the drivebelt, and try running it to test like this. The brush bar will not turn, but it should function normally without smell at this point. If it doesn't, you may need a new motor as I think the brushes may have worn down - producing an electrical type burning smell.

If it runs fine without the belt attatched, then there is probably a build-up of hair or threads at each end of the roller stopping it turning freely. With the hoover off, check it turns freely and easily. A small metal nail file or similar is usually a good tool to clear it.

If the roller is stiff, the belt will not turn easily, and overheat on the motor spindle - causing the burning smell.

Jan 08, 2009 | Hoover Vacuums

2 Answers

Rubber smell, Hoover


Well it sound like you do need a new belt because of how the smell is you might want to stop using it because the smell comes from the burning and over heated belt my solution would be to get a new belt and that should fix it if you need anything else you know whre to find me.

Jun 30, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Belt slipping


on the roller/brush where the belt sits if that is scarred up or grooved out that will cause the belt to slip if you can fix roller try but i suggest new roller

Dec 02, 2007 | Hoover Company Wind Tunnel U53019 Upright...

Not finding what you are looking for?
Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum Logo

Related Topics:

522 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...