Question about Balboa Instruments Duplex Digital Panel 2 Pump

1 Answer

My Balboa 500Z-Series Hot tub has been working fine for 6 months. Then today, without warning the lights started flashing and I could not turn them off from the light button. Additionally a code "Pr" appeared on the screen. I switched off the power for several minutes then switched back on and "--" appeared on the screen and the lights continued to flash. I pressed a number of different combinations and the message 5r appeared. This message does not appear on my owners manual. The water level is at the appropriate level and cannot think of a reason why this would take place other than a mechnical failure. Any ideas? With thanks, Craig Vogel

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hello!
I have a question about my Balboy 500Z. When the water is heated the motor pump is still running that means the pump runs all the time without interrupt even the water has it's temperature. Now my question: is it possible to turn of the pump? thank you for your quick answer! Greetings Beat from Switzerland

Posted on Oct 23, 2015

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 40 Answers

SOURCE: Hot tub ran fine till we moved it the balboa

pr will remain on for 3 minutes if still not starting
check fuse on circuit board

Posted on Mar 29, 2011

rockmeister
  • 2047 Answers

SOURCE: I have a Balboa Instrument

Hello there, what i think is the problem with your unit is the control board. The control board is usually responsible for the general functions of the unit. If the control board has a minor problem it would affect the entire units functionality. Although the problem should be minute and repairable so you wont need to replace the entire board which could be very expensive. this is evident from the unit still coming on and starting the pump. Simply get the entire board taken and and checked for the irregularities on the board.
hope this solution has been helpful?
Thank you for visiting FixYa.

Posted on Aug 07, 2011

SOURCE: I have just refilled by

Priming can be done many different ways depending on thetubs design. Some tub manufactures provide bleed valves located on the plumbingjust beyond the pump and heater unions. Some pumps have a bleed valve locatedon the pump. If there are no bleed valves then you will have to release theunion nuts to allow the air to escape.
You can find answers to common spa or bath problems online at http://www.balboadirect.com/support.aspx
Hope that helps.

Posted on Sep 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Great lakes hot tub


Hi, I am not a hot tub expert and I don't know what PR status is or what PL on the display means . However I did a quick search for you and have a web address that might help you find a solution.
http://www.spacare.com/troubleshootingguideforspaandhottubs.aspx
Hope it helps you
Regards
Steve

Mar 27, 2014 | Garden

1 Answer

No temperature display cant set temperature


Located behind the access panel there is a grey box that is the spa pack. Open that up with the 2 screws on the top of the pack. There is a small glass fuse on the circuit board. One of those fuses is most likely blown. If that is not the culprit you need a new topside control. More than likely it's the fuse.

Mar 04, 2013 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

I have just refilled by hot tub with a balboa 500z pump. After refilling it the pump is working fine but the jets are not. The dr light has come up. Please can someone help me bleed the pump to get it...


Priming can be done many different ways depending on thetubs design. Some tub manufactures provide bleed valves located on the plumbingjust beyond the pump and heater unions. Some pumps have a bleed valve locatedon the pump. If there are no bleed valves then you will have to release theunion nuts to allow the air to escape.
You can find answers to common spa or bath problems online at http://www.balboadirect.com/support.aspx
Hope that helps.

Jun 12, 2011 | Balboa Instruments Duplex Digital Panel 2...

3 Answers

Balboa vs500/501/502 gs500/501/502 I just refilled spa yesterday and now I'm getting error codes HL and dr both indicate low flow issues, The water level was re-filled to where it's always been. Any help...


A lot of times you can get an air lock as the spa fills. All you need to do to fix this is open the drain valve for a few seconds till it runs just water and no air. Or start the pump wile the drain is open. This should fix your problem. Good luck.

Sep 04, 2010 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

I have a 2004 great lakes hot tub with a balboa controler. My hot tub heats up fine when the pump runs on high but the temp light never comes on when the pump runs in low.


check to see that the flow switch is working properly, it may not have enough flow on low speed to allow the heater to turn on. Make sure your filter/s is/are clean. If you have a pressure switch instead of a flow switch, it may need to be adjusted or replaced.

Feb 04, 2010 | Qca Spas Jewel Series Topaz Plus Hot Tub

1 Answer

I have the Balboa 500Z pump heater kit. Its hooked direct to a mighty iron ( 120v) recirclulating pump. Ever since it was new, I keep getting lack of water vflow errors ( dr, then dy ) I have plenty of...


I have a 6 month old Balboa 500Z. I have noticed that the filter system tis running all the time 24/7. I have reset the filter cycle to run for 2 hours { F2 }. It still is running all the time. It dose not seem to make a difference what I set the cycle for it just keeps running

Dec 06, 2009 | Balboa Instruments Duplex Digital Panel 2...

Not finding what you are looking for?
Balboa Instruments Duplex Digital Panel 2 Pump Logo

1,913 people viewed this question

Ask a Question

Usually answered in minutes!

Top Balboa Instruments Garden Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Paul Stonecypher
Paul Stonecypher

Level 1 Expert

28 Answers

Mister Danger

Level 3 Expert

5631 Answers

Are you a Balboa Instruments Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...