Question about Canton Plus C Speaker

Open Question

I cant seem to figure out if i need to run speakers through the sub to get it to work or not

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My sub wont come on. but all the outher speakers work fine . cant figure it out?


I assume this is connected to a AV Receiver? There is generally a low level sub out, with an RCA jack. That should go to your sub input. The old subs had the speaker outputs on the back of the receiver connected to the sub input, and all the other speakers were connected to the sub, but that system hasn't been used in decades.

Jan 24, 2015 | Audio Players & Recorders

1 Answer

My zx850.4 keeps jumping to protect i have cvr10" 2 ohm wired as vc series/ to pallel subs and it keeps jumping to protect its 2 ohm stable i can hook subs to my 300.4 that alreadyruns 4 speakers and it...


Be aware your amp can deliver more power to a 2 Ohm speaker, but will not work if the 2 Ohm speaker somewhere in the audio spectrum comes beneath the 2 Ohm. Because you want the sub, to go as low as possible, it could be the speaker will have a very low impedance under 20 Hz, causing your amp to go in protection.
The power you give to the amp, will not be the cause it going in protection. It is sensing the output current, so it will stay in the borders the end stage can deliver. Try two speakers in series and give the same power. If the amp is not driven into the protection, I think you are closing in to what is causing the problem.

Jul 06, 2014 | Car Audio & Video

1 Answer

2006 Mountaineer Amplifier Wiring


u put to much amps to the fuel pump and burn it up u will need to get a new one

Dec 01, 2013 | Mercury Mountaineer Cars & Trucks

1 Answer

Mtx mxa 6001 amp cant get it to produce good bass using mtx 5500 subs running a 2ohm load


You seem to have everything in spec. check your crossover points and your speaker wiring. subs may be playing out of phase.
A huge factor is subwoofer enclosure ...if the enclosure is not in spec with sub requirements the subs will not peform great.

Sep 23, 2013 | Car Audio & Video

1 Answer

Rear speaker rattles in 02 Montero Limited


That cover doesn't come off - It's screwed (4) from behind. You have to take the upper trim piece off (and handle) to remove the bottom trim piece and access the subwoofer. If your sub is like mine, the foam all the way around the sub has torn away, making it rattle. There are only 4 screws holding the sub in place, and it's sticky taped to the wall, so you may have to pry it off. Hope this helps!

S

ffbaf2a.jpg

Aug 29, 2009 | 2002 Mitsubishi Montero

1 Answer

Subwoofer trouble


does your deck have a sub control on it sub on or sub off are your rca jacks plug in to the right one are your rca cables in good shape speaker wires hooked up properlly amp is set on low pass filter

Jul 06, 2009 | Car Audio & Video

1 Answer

Is amp big enough for speakers


Hello,

To run 2 subs, the amp would be a little small. The subs will run OK, they just won't be very loud.

It's usually better to compare and match up the RMS power rather than the peak power. The Sony XS-L10P5B sub has a peak power handling figure of 1200 watts, but the RMS is 300 watts. The Sony XM-ZZR3301 monoblock amp puts out 1100 watts peak, but only 330 watts RMS. They would work great together, 1 sub, 1 amp. But if you add another sub, each one would only be getting about 165 watts. They'd work OK, just not as loud as they could be.

Hope this helps!

Mar 28, 2009 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

1 Answer

Aux and sub settings


you have to turn the headunit off using the headunit (there is a button that says off or power just cant remember which one) once its off and is displaying only the time you hold the function button and all the other options will come up.

Jun 29, 2008 | Pioneer DEH-P6400 CD Player

2 Answers

Sound problems through subwoofer


check all speakers wires andcheck test mode. every thing ok, may be input wiring problem ,check every thing after that internalcircuit may be problem..

Oct 08, 2007 | Audio Players & Recorders

Not finding what you are looking for?
Canton Plus C Speaker Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canton Audio Players & Recorders Experts

Josh Whitehead
Josh Whitehead

Level 3 Expert

1148 Answers

Owen Barnes

Level 3 Expert

867 Answers

Tom Chichester

Level 3 Expert

33282 Answers

Are you a Canton Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...