Question about Hoshizaki Freezer Commercial Ice Machines - KM900MRH Commercial Ice Machine

1 Answer

Hi, I have the KM250BAF. There are seems running cycles from the board but no water going to the plate. And I see there is water pump which too hot to touch. Is this causing the problem? Thanks, Chong

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Hoshizaki Master
  • 1,043 Answers

Most likely that's your problem. New pumps very expensive.

Posted on Jan 15, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Does not cycle properly


if water valve still allows water even after unplugged electric wires to it then water cylinoid valve is bad.. if water stopes when unplugged then relay in circuit board is sticking or board defective..

Mar 26, 2014 | Hoshizaki Freezer Commercial Ice Machines...

1 Answer

Hoshizaki water dont stop runing


float switch is stuck in the "down" position. The unit goes thru a fill cycle and after 1 minute, the board "Looks" at the float swith to "see" if the sump is full. If float is stuck down, it tells the board that the unit does not have enough water and stays in the fill cycle. The compressor will not come on as long as the machine "thinks" there is not enough water. let me know if I can help further

Aug 02, 2012 | Hoshizaki Freezer Commercial Ice Machines...

1 Answer

Hoshizaki km-900mah ice maker won't start the freeze process


cycle is, fill cycle for 1 minute first. If there is not water entering the unit when first turned on, look for that issue. Water turned off, water valve not working or some restriction, clogged water filters, etc. That is got to happen first. Don't over look the bin stat being bad. Nothing happens if teh bin stat is bad. It sends voltage to the control board that runs the unit.

Jul 28, 2012 | Hoshizaki Freezer Commercial Ice Machines...

1 Answer

I have a manitowoc commercial ice machine.It has stoped making Ice and just seems to keep running water and not freezing


Hi,

Check to see if the compressor is running... if it is running and not cooling then it may have a refrigerant leak...
If the plate is getting cold but the water is not freezing then check to make sure that the float is not stuck on and the the water just keeps running in... that will keep the water warm enough so that it does not freeze...

heatman101

Mar 10, 2011 | Freezers

1 Answer

Do you have to reset ice machine after running wash cycle? Mine is not making ice now?


If you did the wash cycle per the manufacturer instructions, you may have forgotten to turn the directional water valve back. It directs the water/cleaning solution to go inbetween the plates. It has a micro switch that will not let the compressor come on. If you did turn it back, the switch may be bad.
Check it out.

Mar 03, 2010 | Hoshizaki Freezer Commercial Ice Machines...

1 Answer

Beeping 3 times every 3 seconds


The 3 beeps indicates that the unit was in the freeze cycle for 60 minutes. Causes: 1.) Water valve leaking, allowing water to continually enter the system. 2.) Float switch stuck, sending false signal to board. This indicates ice not being produced. 3,.) Low freon level causing long freeze cycle. 4.) Hot gas valve leaking thru causing warmer than normal evap plates=low production. 5.) Expansion Valve not feeding freon properly to evap plates.
Items 1 and 2 are the most common. Number 3 possible due to freon leak in the system. Number 4 and 5 are usually a very rare occurance.
Hope this helps ya.

Sep 05, 2009 | Hoshizaki Freezer Commercial Ice Machines...

1 Answer

Manitowoc SD 0852A ice maker compressor will not kick-in


Here's my thoughts, I hope it helps. I'm going on foggy memory here, so I may not be entirely correct.
I worked on something like this a few years ago. The icemold (plate) is vertical, there is a circulating pump that runs water over the mold, with the water freezing as it passes. The sealed system is a heat-pump scheme, it freezes the mold to form the cubes, and reverses to heat for release. And when it works, it makes ice fast. It runs constantly until the ice hopper is detected to be full. (there should be a bail to detect the ice level) The system will not run in the event that it thinks the hopper is full (bail up) but the pump motor runs continuous to avoid it freezing. There is probably either a false detection of "full" or there may be a leak in the sealed system and the system will therefore not run.

Jun 28, 2009 | Freezers

1 Answer

Hoshizaki ice machine KM500-MAE not sending water to harvest


I would not change the pump. If it runs for 3-5 minutes and stops, it has to be a control. The control board runs the freeze cycle for the first 5 minutes. This prevent "Short Cycling" of the freeze cycle. The board looks at the float after the first 5 minutes for the proper water level but should not effect the pump. If the pump does not run in the wash mode, check out the "Power/ Wash" switch. I would start there before I go spending hundreds on pump motor or control board. You may be able to get by on a $20 fix! Do this and get back to me. We will get it going.

Good Luck

May 06, 2009 | Hoshizaki Commercial Freezer KM-500MAH

2 Answers

Ice Cubes won't drop out


The thickness probe should be approximatly 1/4 inch off of the evaporator.Sounds like you might have loose grids on the evaporator.turn the unit off and remove the curtain.use a flash light and inspect the grids.There should not be space in between the joints,if there is the ice will freeze behind the grids and not properly release when in harvest. Also gently pull at the grids,if they pull towards you or wiggle then they are separating. I have removed one of the grids and had the unit continue to run for sometime until the evaporator could be replaced.The plating being spotty causes release issues as well.Finally check the level of the machine,front to back and side to side.Not being level will also cause release problems

Feb 18, 2009 | Freezers

2 Answers

Hoshizaki ice machine repair?


seems that its low on water or float switch is bad. try to clean float

Sep 02, 2008 | Hoshizaki Freezer Commercial Ice Machines...

Not finding what you are looking for?
Hoshizaki Freezer Commercial Ice Machines - KM900MRH Commercial Ice Machine Logo

Related Topics:

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoshizaki Freezers Experts

Dennis Boxerman

Level 3 Expert

1043 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

Are you a Hoshizaki Freezer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...