Question about Onkyo TX-SR605 Receiver

Open Question

My onkyo SRTX 606 has been giving "no signal" error for the last few weeks for the dishnetwork receiver connected through Onkyo. When I connected the dishnetwork receiver directly to tv, there was no problem but it takes 5-10 minutes before tv shows picture when connected through the onkyo receiver. what could likely be the problem and how best to get this fixed? what is the estimate I am looking at? thx

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: new home theater setup- no signal at tv using onkyo tx=sr605

This might somewhat help. Today I went back .. I went HDMI out of the Cable box and DVD player into 2 of the TVs HDMI ins. The digital audio out from each, straight to the receiver and things are working ok. All speakers are working OK. Sound isnt as loud or crisp but unfortunately I found no other solution.

Posted on Jan 06, 2009

  • 1 Answer

SOURCE: No audio sound from HDMI connection from TV to Onkyo 606 amp.

if you go to the setup menu, hardware setup, hdmi, and turn the audio out: on it should work hope this helps

Posted on Jul 29, 2009

  • 1 Answer

SOURCE: onkyo 606 doesnt show video anymore fom ps3 over hdmi

I've got exactly the same problem described by cccandme and the unplug for an hour/Master Reset Solution posted by dustywadham did not work for me. Everything was working great for about a year, and then I started having issues with the PS3 connection.
What's weird is that sometimes it will start right up, and other times it may take ten to fifteen minutes to acquire a signal. It seems as if something has gone haywire on the Onkyo, but I don't know what it is. From looking around the web, it appears as if quite a few people are starting to have problems with the TX-SR606 and their PS3 connection, and I wonder how someone could make Onkyo aware of this.

Posted on Nov 05, 2009

  • 4 Answers

SOURCE: I have an Onkyo TX-SR606 connected via hdmi to a

The problem is with the HDMI daughterboard in the AVR is bad. This is a well documented issue on this interweb! A general search in google can confirm. Here are some stuff cut and pasted frm their site and another forum. Onkyo USA Corporation (hereinafter referred to as Onkyo) hereby warrants all Onkyo products PURCHASED DIRECTLY FROM ONKYO OR AN ONKYO AUTHORIZED DEALER- WARRANTY PERIOD (from date of purchase) New Products: Receivers 2 years Parts & Labor-- You can go to the Onkyo webpage to find a n authorized service repairman.
*** I took mine to a service repair place today, the guy said that he had two that he just fixes yesterday. He said that this issue has given him a ton of work. Just make sure that you have your receipt from AN UNAUTHORIZED DEALER and that your still under warranty. Receivers 2 years Parts & Labor

Posted on Jul 31, 2010

  • 1 Answer

SOURCE: I have an Onkyo HT-S6100 home theater not sending picture to TV.

I just fixed mine with the same problem. Apparently, the HT-R667 and 606 receiver that comes with 6100 has a problem with the HDMI board. Onkyo wanted $500 dollars to fix it, costed me $16. Here's how to fix it. http://www.highdefforum.com/high-definition-receivers-recorders-players-tivos/121956-repairing-onkyo-htr667-aka-606-a.html
and the youtube vid: http://www.youtube.com/watch?v=gj0x5S9ez5U
Good Luck!

Posted on Jan 13, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When I connect the sirius radio to the docking station (sirius connect home kit) I can hear the sound for a few seconds then the docking process engages and I loose the sound. I have the tuner set to...


Hello, I am sorry about your issue. I suggest that you contact Onkyo at 800-229-1687 option #3 so that we can troubleshoot with you. Thank you, Onkyo USA

Jul 03, 2017 | Onkyo TX-DS575 Receiver

1 Answer

I have an Onkyo HT-S6100 home theater not sending picture to TV.


I just fixed mine with the same problem. Apparently, the HT-R667 and 606 receiver that comes with 6100 has a problem with the HDMI board. Onkyo wanted $500 dollars to fix it, costed me $16. Here's how to fix it. http://www.highdefforum.com/high-definition-receivers-recorders-players-tivos/121956-repairing-onkyo-htr667-aka-606-a.html
and the youtube vid: http://www.youtube.com/watch?v=gj0x5S9ez5U
Good Luck!

Apr 04, 2010 | Onkyo TX-SR605 Receiver

5 Answers

I cannot get video signal from my Samsung p1590 Blu Ray player via HDMI to pass through my Onkyo TX-SR606 AV Receiver. I get video if I connect Blu Ray player directly to TV, and have tried all HDMI ports...


I think this one is for the Onkyo wizards:

I would write them via email here:

http://www.onkyousa.com/feedback_form.cfm

1-800-229-1687
However I did find this 2 page hookup manual with nice notes at link listed below that may help you solve the mystery:

(seems you may have to assign the digital input)

http://filedepot.onkyousa.com/Files/QuickHookup/TX-SR606_QSS_En_A.pdf?CFID=918117&CFTOKEN=40624545&jsessionid=f0306ea8a0d68bb60a49102e3e5510576756


Assigning the Digital Input
If there’s no sound, you’ll need to assign the digital inputs as
necessary using the setup menus on the TX-SR606’s display.
If you connect your DVD player to the AV receiver’s COAXIAL 1
DIGITAL IN, and your cable/satellite receiver to the COAXIAL 2
DIGITAL IN, as shown, it’s not necessary to assign the digital input.
The onscreen setup menus appear only on a TV that is
connected to the HDMI OUT. If your TV is connected to the composite video or S-Video MONITOR OUT, or the
COMPONENT VIDEO OUT, use the TX-SR606’s display when changing settings.

Thanks for using FixYa!

Kelly

Feb 19, 2010 | Onkyo TX-SR606 Receiver

1 Answer

Onkyo 606 connected to tv with video only via hdmi/dvi cable. Receiver/tv must be turn on/off several times for video to get to tv. I know it is receivers fault because tv will say no video signal. After...


I am having this exact same issue with this receiver. I have to turn it off several times in order for it to pass through... Any chance you figured out how to fix this....

Oct 15, 2009 | Onkyo Audio Players & Recorders

1 Answer

Onkyo 606 Video Drop out


main board fault, its input feed on the board might be failing, it could also be a failing capacitor, you would need to open it up to have a look and see if there are any capacitors failing.

May 14, 2017 | Onkyo TX-SR606 Receiver

1 Answer

Onkyo tx-sr 606 HDMI signals not working anymore...


I am sorry about your issue,. If the reset did not resolve your issue the receiver would need to be serviced. It if was purchased from an authorized seller less than 2 years ago it would be under warranty. Thank you. Onkyo USA

Mar 09, 2017 | Onkyo TX-SR606 Receiver

19 Answers

Onkyo 606 doesnt show video anymore fom ps3 over hdmi


i hate to say it i got the same problem and the only way i sorted was a master reset which means u have to do all the set up again and asign all the hdmi again but since i done that no problems to do this un plug the lot for an hour reconnect everything then push and hold the vcr button and push stand by a message will say clear on the receiver then it is back to when u frist got it out th box hope this helps

Sep 03, 2009 | Onkyo TX-SR606 Receiver

2 Answers

Upscale from 480p Signal via HDMI


ok the problem might not be with your receiver it is with your direct tv settings. Double check to make sure you go to the format and set it up to be fixed or 1080i whichever will give you the highest resolution. Check your manual for the direct tv receiver. If this is all correct for the DTV then you must go into the setup on the receiver and at hardware icon toward bottom check on that box, now goto the hdmi settings and make sure it is set to through. this will allow the best picture with no upscaling which will degregade picture for blu ray. so your direct tv will be only 1080i but very impressive. if you still want to upscale you can then you have to change the hdmi settings from before to upscale 1080p . I just hope that your dtv can output 1080i it will give a better picture than 480p even if both are upscaled to 1080p
Oh i forgot to ask if you are connected through hdmi to the tv. Hdmi is the only option for upscaling

Feb 21, 2009 | Onkyo TX-SR606 Receiver

1 Answer

Ps3 defaults to 576p when connected through onkyo 606 receiver


You have to tell the PS3 what the Okyo can do and it probably cannot do 1080P 60Hz (but can likely do 1080P 24Hz).  Try ticking more resolutions in the PS3s setup

Jun 22, 2008 | Audio Players & Recorders

2 Answers

No HDMI Output


My configuration:
ZONE 1 (living room)
DishNetwork Dual Tuner DVR Tuner 1 [S-Video out] -> [S-Video in] ONKYO TX-SR875 [HDMI out] -> [HDMI in] Sony KDS-60A3000 rear projection TV

ZONE 2 (living room)
DishNetwork Dual Tuner DVR Tuner 2 [Composite Video out] -> [Composite Video in] ONKYO TX-SR875 [Composite Video out] -> [Composite Video in] Samsung AQUOS LCD TV

Problem:
ONKYO receiver stops sending video signal to my ZONE 1 Sony TV through the HDMI connection. ZONE 2 may still receive video. (NOTE: the issue might be related to the upconverter circuitry?)

Symptom:
I couldn't see any video, but I could hear the Tuner 1 audio through my ONKYO. An important clue is that I couldn't see ONKYO's on-screen display menu on my TV when hitting the [Setup] button on my remote. But, I could see my TV's Sony-based menus and display options.

Solution:
1. Put all ZONES in Standby mode using the remote. Hit these buttons on remote: [Receiver], then [Standby]. [Receiver], [ZONE2], then [Standby], [Receiver], [ZONE3], then [Standby]. You should NOT see any lights on the ONKYO except maybe one red led near the power button.
2. Pull the power plug out of the back of the ONKYO, and leave unplugged for 20-30 seconds. Turning off any power center it is connected to isn't enough. You MUST unplug the power from the back of the ONKYO for 20-30 seconds.
3. Reconnect the power cord to the ONKYO.
4. Using the remote, set ZONE1 to a video source known to be working. If you don't see video, try leaving the power cord off for a longer period.

I know it sounds too simple to work, but that's what brought the video back for me the few times the video stopped displaying. Hope it works for you.

Jan 06, 2008 | Onkyo TX-SR875 Receiver

Not finding what you are looking for?
Onkyo TX-SR605 Receiver Logo

Related Topics:

64 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

The Knight
The Knight

Level 3 Expert

73647 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

Are you an Onkyo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...