Question about Phoenix Gold Octane-R 15.0:1 Car Audio Amplifier

Open Question

When turning on my radio both fuses pop amp cuts out , i disconnected everything but power and grounds fuses still pop was told internal having any ideals happened after hook boat trailer but both on seprate power soureces wiring was already there didnt add

Posted by on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 8 Answers

SOURCE: i have wired everything correctly

Perhaps the PG Octane R needs a bit more power on the remote. Check if connectors are well connected to the wire. There might be some resistant present if the connection is not 100%. (oxidation?)

Posted on Aug 19, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Radio quit working


Sounds like someone shorted the wires...you need to look into the entire butcher job and see what wires were touched. Disconnect everything the butcher did and then see if your battery is still drainning power.

Dec 03, 2013 | 2006 Chevrolet Malibu

1 Answer

89 ford bronco 2 rear abs sensor light on and no power to radio fuses are good can anyone help also fuses for turn signal has been blowing Does anyone have a fuse box diagram


sounds like you have a hot ground somewhere. Check the wires for everything that doesn't work and make sure there are no bad spots where the power side is cut/damaged and grounding out.
The abs could have nothing to do with it, but either a bad connection/cut wire, or bad sensor.
Fuse and ext light diagrams below. 12_22_2012_10_05_33_pm.gif12_22_2012_10_05_50_pm.jpg

Dec 22, 2012 | Cars & Trucks

1 Answer

My CD & radio just stopped working. The screen still displays everthing and the CD track changes just no sound.


This is usually an internal failure with the head unit (the radio box in the dash) usually getting a new head unit will solve the issue, however it could be as simple as a broken or disconnected connector. Try getting to the back of your radio and inspect the connectors. Also try jiggling the wires to see if its a loose/sloppy connection. Either way, you're going to have to pull apart the dash. In some rare cases, the vehicle will have an external amplifier, if this amp popped a fuse or had some internal fault, that would cause the radio to show everything, but have no sound. Check you fuses first, especially anything related to "Audio", "Instrument", "Dash", or "Amp"

Nov 17, 2012 | 2009 Pontiac G6 GT

1 Answer

My truck keeps blowing fuses in my power wire like its grounded out. i have re-done everything and it still does the same thing


It may not be the wiring, it could be the amp itself. If you are completely confident the power wire is not grounded the following test will confirm it. If it is grounded you will be out another fuse. Disconnect the power wire from the amp. Tape or cap off so it doesn't accidentally touch metal. Replace your fuse (take a part the fuse holder if you can and use a small cheap fuse.) If it is grounded the fuse will pop. If it doesn't pop, the problem is in the amp or improper wiring at the amp.

Apr 25, 2011 | DHD US Amps Xterminator XT-4000D

2 Answers

My amp stay on when the car cuts off. the only way it turns off it i take the fuse out the power line or if i disconnect the remote wire. I have check the remote wire behind the head unit it everything is...


connect the red wire of the amp to a car battery (+). the black to a car metal and the remote cable to the blue wire in radio. when you turn on the radio the amp turn of--when you turn off the radio the amp turn off.

Apr 26, 2010 | Lanzar Vibe 1200D Car Audio Amplifier

1 Answer

Poineer III D wont turn on


If the negative ground was not disconnected, you may have popped a fuse on the radio, if it has one. Check the back of the radio and the fuses there. Always remember to disconnect the ground when working with the electrical system.

Sep 26, 2009 | Pioneer DEH-P690UB CD Player

1 Answer

I just dont know how to plug everything with it...Power button comes on if you move the amp...sparks if touches with a a screw....dont know which connections to put where


Black is ground(hook to a bolt going into metal on vehicle). Red is switched power(only on with ignition on). Yellow is power(power even if ignition is off). Blue is amp turn-on(located at radio and sends signal for amp to turn on). It is sparking because you do not have it grounded properly. You can damage your amp and or you car's electrical system....be careful. Always pull a main fuse or disconnect the battery when wiring a car audio system.

Sep 16, 2009 | Boss Car Audio & Video

3 Answers

Amp overload protection mode


it sounds like the ground is bad to begin with and check the positve cable for oxidisation on the battery terminal and at all other places that the power wire is connected to

Aug 09, 2009 | Kenwood KAC-8104D Car Audio Amplifier

1 Answer

Blowing fuses on the Vosonik VB101PK


ok, always use ground and positive from speakers to the amps +/- . Make sure the amp is not grounded. Some amps are made of metal and will ground itself. When ever any fuses pop, this means that something somewhere got grounded. If using metal srews to mount amp that has a metal casing, chances are you will pop a fuse or two. Be careful ajusting the speaker wires with a metal srewdriver, I've done that alot. "POP"

Jun 21, 2009 | Visonik V117SX Car Audio Amplifier

2 Answers

Blowing fuses under hood but nothing looks smoked in the amp


Sounds like the amp is fried, most likley in one or both of the output sections. Good luck.

Feb 21, 2007 | PPI DCX-1500.1 Car Audio Amplifier

Not finding what you are looking for?
Phoenix Gold Octane-R 15.0:1 Car Audio Amplifier Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Phoenix Gold Car Audio & Video Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

ronniebissoo

Level 1 Expert

42 Answers

Are you a Phoenix Gold Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...