Question about Kenmore 96413 Electric Kitchen Range

2 Answers

Preheat Indicator Bought a new stove and the preheated indicator doesn't seem to be working. Set it for 350 and it goes off at 225 saying its preheated. Store sent out repair guy and he saw the same thing but said "Thats how its supposed to work. All ovens are like that". He then left with out repairing anything. My last oven didn't work that way (had a digital readout of the current temp - not an indicator). The current oven's manual says the light will go off when "the desired temp has been reached". No one else I've talked to has heard of such a thing. Even the store's helpdesk guy had never heard of it either. What is going on? Is this the best kept secret in appliances, or is the repair guy pulling a "Its not a bug - its a feature!"

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 906 Answers

Good day,
hope this link below will solve your problem.

kitchen appliances

Posted on Jul 31, 2010

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 38 Answers

That is not how they work, you either have a oven sensor problem or a control board problem. One of the two are reading the temp wrong. You need to call them back and have it fixed.

Posted on Mar 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I cleaned the oven self clean, now the oven preheat feature won't turn on


I don't know what kind of range you have or if it is gas or electric. You may have to call a repairman.

May 25, 2015 | Kitchen Ranges

1 Answer

Frigidaire gallery stove


Hello Debbie - Sounds like the unit has loss some of its heat inside of the oven cavity. This means it cannot reach the proper preheat temperature in the programmed 30 minute timeframe. A technician would be required to further diagnose this concern. They would most likely assess the convection heating element, thermal cutout, thermal oven sensor and all wired connections for repairs. Lastly the oven cavity and insulation should be checked to ensure there are no gaps or damages that will leak out the heat. At t his time, I would recommend contacting a professional to assist you further.

May 24, 2013 | Frigidaire 30" Self-Cleaning Freestanding...

1 Answer

I bought a new home and there is no manuals and it is stuck on the setting sabb the stove top works perfect but the oven only heats to 260 on this particular setting??


Try this:
To
provide sabbath feature (or to cancel this setting):
1. Push the PREHEAT pad and set the oven
temperature to 500°F/260°C or more using the UP
ARROW pad.
2. Push the PREHEAT pad within the next 2 seconds
for 3-4 seconds. A beep sounds and a number
appears in red to the right of the display. For the
conversion, "3" must be displayed. If another number
is displayed, push the PREHEAT pad and select
"3".
3. Push the UP or DOWN ARROW pad to change
from 12 hour to 9999 in the display, for no 12 hour
shut-off.
4. Push the CANCEL pad to confirm your choice.
Hope it helps!

Jul 27, 2011 | KitchenAid KERC607 Electric Kitchen Range

1 Answer

When I press BAKE to preheat the oven or CLOCK to set the time the display goes blank, then the number 30 appears, and then the clock time resets itself. I can still use the oven to preheat or bake, but...


I have the same problem. I bought it new in the fall of 2007. They replaced the control panel but that didn't help. Next they replaced the whole range with a new one, same model, still the same problem. They told me it was a problem with my electric in my house. Then they said it was a strange electro-magnetic field in my neighborhood and I would have to buy a different brand?
One time with the original stove the oven quit working and I had to re-set the breaker. Everything still works but the clock is always wrong.
We bought all Maytag stuff, including fridge, stove, microwave, dishwasher, washing machine, and dryer. The kitchen stuff is 4 years old. The washer and dryer are 3 years old. We have had this issue with the stove, the washing machine broke and they had to replace the whole drum assembly, and last week my refrigerator broke. Very disappointed with Maytag stuff.
So has anyone found a solution?

May 17, 2009 | Maytag MES5752BAW / MES5752BAB Electric...

2 Answers

Preheat taking long time


If your oven has the hidden bake element then it is probably working properly. A standard oven with an exposed bake element will usually take about 12-15 minutes to preheat. The hidden element models take a little longer but they usually heat a little more evenly.
Post back if you have any more questions.

Oct 29, 2007 | Kenmore 96212 / 96214 / 96219 Electric...

1 Answer

Bake part of kenmore not working seems to take to long


Chances are the oven ignitor will need to be replaced.  Look and see if it glows.  If it does then it is weak and not opening the gas valve to lite.  Let me know what you find.
Comment by fridgetech, posted on Oct 20, 2007

Should be able to remove the bottom drawer and unplug the ignitor from below.  Or you can cut the wires on the old ignitor and splice the new one in using ceramic

Oct 20, 2007 | Hotpoint RGB745 Gas Kitchen Range

Not finding what you are looking for?
Kenmore 96413 Electric Kitchen Range Logo

159 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Kitchen Ranges Experts

Dan Webster
Dan Webster

Level 3 Expert

8147 Answers

Cindy Wells

Level 3 Expert

4755 Answers

Mike Carew

Level 3 Expert

958 Answers

Are you a Kenmore Kitchen Range Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...