Question about Vacuums

Open Question

I have a creda aquablue 8.5 kw electric shower. it's only 2 years old, it comes on ok then the light goes out & it goes cold, if you turn it towards cold it comes back on but not for long. i've cleaned the shower head as advised but it made no difference. can you tell me which part is faulty? my son in law is an electrician & could fit it

Posted by on

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
mark_beery20
  • 124 Answers

SOURCE: I have a 2 year old Electrolux ergorapido cleaner

worn batteries!
Good luck

Posted on Jan 21, 2011

Ad
bento_daniel
  • 2 Answers

SOURCE: I have a 2 year old Electrolux ergorapido cleaner

No, not worn out batteries.
For my experience, if the batteries were worn, they would charge with the blue led being on and after that, the vacuum wouldn't hold his charge. just that.
This is a different problem. Check the contacts between the charging station and the vacuum, mines got bent a bit and stopped making contact. This has happened twice and just fixed it about 30 min ago. That is why the led first lights and then goes off, there was just a brief contact between them.
Nice vacuum, very powerful and handy but maybe it is just poorly made as it is engineered in Sweden but built in China.

Posted on Sep 12, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Canister vacuum


Without the make or model... We are speaking in GROSS GENERALITIES... but

ELECTRICAL Trouble...
The light & the BRUSH not working ... when considered TOGETHER.. would indicate a NEED to check your electrical connections...

My best advise would be to:
make sure the cords & wands are fully connected
make sure the (HEAD) motor is running ...

If the motor (brush head) is running... belt looks good and brush is not seized (or jammed)...

You will need to look to the DRIVE PULLEY on the motor OUT-PUT shaft...

Hope this helps

Jul 25, 2016 | Vacuums

1 Answer

6 yr old Aqualisa shower working perfectly well. But turned itself on last night. No light showing on dial/on switch. Wouldn't turn "off" for me. Ran for 15mins and then switched off!


Good Aternoon lrmulholland,

Do you know what model Aqualisa shower you have or are you able to take a photo of it for us? That would be very useful.

Kind Regards,

The Aqualisa Team

Sep 07, 2011 | Vacuums

1 Answer

Fitting a light and the wiring is not coloour colded, so which one goes to the L and which colour goes to the N.


light bulb sockets are not colour coded as it does not matter which way round live and neutral are connected. earth will go to the outer case of the bulb holder (if applicable).

if you are not sure, i must recommend that ask a qualified electrician to actually install the light, as mains electricity can be dangerous, and incorrect installation can carry risk of electric shock or fire.

please think carefully before doing any electrical work yourself if you are not confident in your abilities.

Jun 18, 2011 | Vacuums

1 Answer

We lost power this morning due to the cold temp etc. here in dallas and our hot water didn't come back, why?


Check your breaker(s) When the power goes out and is out for a while before it comes back on, sometimes the sudden demand for power can click breakers off. Yo don's say if you are gas or electric. If gas, and you have electronic ignition, you may need to reset the device. If it is electric controlled but has a pilot, the pilot may have gone out - relight it. If it is electric, you may have to check the elements with your volt/ohm meter. Check the contunity of the elements (with the power off of course) and then turn the power on and check the voltage at the elements. They could have burned out (I doubt it but cannot dismiss with out checking)

Hey, we in the North have been cold all winter - don't complain about your cold snap. More seriously, I trust all is well with you and yours during this terrific storm that is sweeping the country.

Thanks for your interest in FixYa.com and come again please.

Feb 02, 2011 | Vacuums

2 Answers

I have a 2 year old Electrolux ergorapido cleaner that gets used daily for about 2/3 min, the blue light on the stand comes on when the cleaner is put on to charge but fades after about 5 min & the...


No, not worn out batteries.
For my experience, if the batteries were worn, they would charge with the blue led being on and after that, the vacuum wouldn't hold his charge. just that.
This is a different problem. Check the contacts between the charging station and the vacuum, mines got bent a bit and stopped making contact. This has happened twice and just fixed it about 30 min ago. That is why the led first lights and then goes off, there was just a brief contact between them.
Nice vacuum, very powerful and handy but maybe it is just poorly made as it is engineered in Sweden but built in China.

Jan 21, 2011 | Electrolux Vacuums

1 Answer

I have a galaxy obsession deluxe 9.5 kw shower which will run for a little while but then trips the fuse, what could be causing this to happen?


your cable supplying power is not correctly sized for the shower causeing it to overheat and trip the fuse, or your main board fuse isnt matched to the power of the shower

Dec 19, 2010 | Galaxy Vacuums

2 Answers

We have a zenith dehumidifier model ZD300 & the bucket full light keeps flashing. the percentage number wont go higher than 1%. we have turned it off/on & unplugged it. When we do this it will...


I've had the same issue with mine. I am a 12 year refrigeration tech. I checked the float switch which would normally cause that indication light. However manually pushing the switch and then checking it with an electric meter that was not the case. I think that is instead, an error code set by the manufacturer to assist the service tech when or if this failure occurs during the warrenty period. I also checked the next possible failure in the sequence of opperation which would be the compressor overload relay. That is sometimes why, as some people have posted, that after when unplugging the unit, it operates for a short time then again fails. In my case that was the failure. If that would have not been it than I would have tried the compressor start relay. I purchased the overload relay from my local HVAC/plumbing supply for around 7$. The control can easily be replaced by any handy homeowner. Also, as a service tech, 7$ and two wire nuts is better than a 145+$ service call.

Nov 28, 2010 | Vacuums

1 Answer

My Riccar 8850 stopped running. Changed the bag and cleared all hoses. Light comes on but the motor doesn't operate. I can turn the brush freely by hand.


Greetings from GoVacuum,

If the light on your Riccar 8850 is coming on, but the motor is not coming on, this indicates that your motor has gone bad. There is a reset switch on the back of the vacuum cleaner that sometimes trips if the bag is too full, or the filters are not maintained, but when this happens nothing on the vacuum comes on including the headlight. If the headlight is coming on, this indicates that electricity is making it down to the headlight, and the current is going through, but just not activating the motor. This is a tell tale sign of your motor being bad, and needing replacement. You can purchase the motor for the Riccar 8850 (12 AMP, 2 stage motor, Riccar part D113-1700 $122.44) from GoVacuum by giving us a call, as we don't yet have this part on our website.

I hope this helped you. We have been fixing Riccar's for over 30 years, and they are great vacuum cleaners, and the age of the model 8850 is probably the life expectancy of this vacuum cleaner.

Chris Jones
GoVacuum.com

Mar 18, 2010 | Riccar 8850 Vacuum

1 Answer

Brushes do not turn rest of things work ok . How


there are about 8 phillips screws holding the bottom cover ,pull it off and the belt will be just laying there it's burned into from someone picking up a throw rug or ext cord. take the old belt to walmart the have them...in stock. they have a chart so if you cant find your old one you can buy the 2 close one's dont for get to vote for me if this helps you, and i will always be here for you ty sawdust46

Jul 11, 2009 | Hoover SteamVac F5914-900 SpinScrub...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

200 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18407 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...