Question about Car Audio & Video

1 Answer

No sound from sub woofer Mutant MTSBP12 fiat punto 57 plate

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 31 Answers

Hi Mate

Just installed this Bass pack into mine today and I initially had no sound either.

Check all of the following.

- Make sure that you have a good earth to the chassis. (Check for green power light led on amp).
- Make sure that your remote signal wire (blue) is connected to the right out on the back of the head unit. If it doesn't have one, use the power antenna wire.
- Check inline and amp fuses, if either is blown, it's most likely a bad earth - clean up contact area/blot with wire brush/wire wool.
- Check the underside of your head unit to see if there's a switch to activate the pre-outs on the back of your unit.
- Check your owners manual about how to actually turn on the sub!! I have an Alpine unit and you need to turn it on from within the menus. There was also a seperate bass level setting.
- Carefully adjust gain and crossover until you get bass.

Hope this helps....If you get any more probs, give me a shout at obzy@blueyonder.co.uk

Cheers

Posted on Apr 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Cannot locate alarm on 03 plate,1.9 jtd model,can't switch of


post the symptoms. "cant switch off what, exactly"?
the FSM covers the tests, ever heard of the FSM. (buy it at the dealer)
or alldata.com1.9JTD,
i get to decode JTD ,thanks for not posting maker , model
Is this a FIAT"? why must i guess.?
uniJet Turbo Diesel,
Some PSA Peugeot Citroen diesel engines are also rebadged JTD units.
Applications:

pick one, and state country?
some (most?) alarms vary by country (LAWS dictate that)

Jun 14, 2014 | Cars & Trucks

2 Answers

Fiat punto grande 2007 horn came on itself only went off when fuse blew replace fuse horn not working


Check on steering wheel (remove it) behind it has got a copper ring and pins

Oct 26, 2013 | Cars & Trucks

1 Answer

My headlights are staying on and they only switch off when I switch off the engine - car is a Fiat Punto Grande 57 reg


This is normal, this is the daytime running light, should stay on when the engine is running

Mar 26, 2013 | Fiat Punto Cars & Trucks

1 Answer

How can I switch the headlights off my Fiat Punto car?


the reg is is 57 ?? very interesting watson the mind boggles here as to weither this site is being used to send secret codes across the world ?for extremists or similar ,so is uncle reg now 57 which signifies something to do with a route 57 london bus or a new york subway train number 57 about to be targeted ,the mind boggles here and contemplates what is going to happen .

Mar 24, 2013 | Fiat Punto Cars & Trucks

1 Answer

Hi i have a 51 plate 1.2 fiat punto the heater blower only works on full ie No 4 can anyone point me in the right direction?


you have 1 of 2 possible problems. it will be either the fan switch is shot or the fan speed resistor is shot

Feb 17, 2012 | 2001 Fiat Punto

1 Answer

Engine problems with mk2 fiat punto elx


that sounds like a clutch problem. get it checked asap because if that goes you may get stuck in netural and not go anywhere happened to me and it has not nice. if you start smelling a burning smell. that is defo your clutch

Nov 17, 2009 | 2006 Fiat 124

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

284 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4789 Answers

yadayada
yadayada

Level 3 Expert

68970 Answers

The Knight
The Knight

Level 3 Expert

72168 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...