Question about Kenmore Kitchen Ranges

1 Answer

Kenmore Gas Stove, Model No. 790.72404013, oven signals it has preheated to 350 degrees in 7 minutes but it is nowhere near 350 degrees when it does this. Seems to take approximately 20 minutes to reach 350 degrees. Repairman told me they're all like this and I'd have to live with it. I'm not satisfied with this explanation. This is a new stove (was installed one month ago) and I either want this fixed or I want a replacement that works properly. What can be done?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Expert
  • 1,772 Answers

Sorry to read about your problem, I hope this helps you out.

ok it seems you have a offset issue, you need to purchase a oven temp gauge. See what the unit read's, lets say you set the oven for 350, does it read 320 or 380. 20 min for 350 is little on the long side, you may have a gas pressure issue.

I would get a 2nd opinion on this matter. and no, they are not all like that.

I tried to help you. Please help me and Rate/Vote on my response. We take the time to answer your question. take the time to rate us.Thanks and good luck

4 Thumbs - Very Helpful
3 Thumbs - Helpful
2 Thumbs - Somewhat Helpful

Posted on Dec 29, 2010

  • hmcl4 Dec 30, 2010

    I did use a thermometer. That's how I knew it wasn't anywhere near 350 after 7 minutes.
    More like 280 degrees. It did keep on heating until it reached 350 and did hold that temp. fairly well thereafter while the product baked.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenmore 790 oven won't maintain temperature


anyone know where to buy the battery for hand phone model mini i9500 ? manufacturer is
z.doxio

Nov 12, 2013 | Kenmore Kitchen Ranges

1 Answer

Frigidaire gallery stove


Hello Debbie - Sounds like the unit has loss some of its heat inside of the oven cavity. This means it cannot reach the proper preheat temperature in the programmed 30 minute timeframe. A technician would be required to further diagnose this concern. They would most likely assess the convection heating element, thermal cutout, thermal oven sensor and all wired connections for repairs. Lastly the oven cavity and insulation should be checked to ensure there are no gaps or damages that will leak out the heat. At t his time, I would recommend contacting a professional to assist you further.

May 24, 2013 | Frigidaire 30" Self-Cleaning Freestanding...

1 Answer

Amana, ACS3350, gas slid - in range, the oven will not turn


I just had the same problem. I had it repaired and it was the oven ignitor. Labor and Parts $185. I now have an additional problem and I have to call the repair person back. The oven starts up and preheats to temp I set of 350 degrees. Then after awhile it will shut off and after another few minutes the clock will come back on and blink. I will repress oven bake and it will go for a short time and then shut off. I don't know what the problem is yet. I am totaly dis gusted with this stove. The stove is only 8 years old!

Jun 08, 2010 | Amana ACS3350 Gas Kitchen Range

1 Answer

Oven does not get to temp when it says its preheated


More than likely, its your oven thermometer thats taking a half hour to read correctly. The oven is probably getting there sooner. If you had a digital thermometer, the read would come quicker. So save your money,nothing wrong with your stove.

Feb 10, 2010 | GE Ovens

1 Answer

My GE Profile Spectra oven is taking approximately 10-15 minutes to preheat to 350 degrees and does not seem to fully bake food as per instructions. It takes an extra 5 to 20 minutes to bake anything. ...


18 mins from room temp to 350 is factory standard,
you may need to calibrate the range, most now adays come factory set at -25 degrees for safety
depending on your model number in your instruction manuel should be a part about recalibrating it sounds like your about 25 degrees off

Oct 02, 2009 | GE Profile Spectra JGBP90 Gas Kitchen...

1 Answer

Kenmore oven model 665, oven temperature goes up


need to check oven sensor probe located inside of oven will be in left or right hand corner. the tech sheet should still be on the back panel of oven it will have instructions how too...

Sep 30, 2009 | Kenmore Kitchen Ranges

1 Answer

Oven themostat not set correctly


Your thermomitor may be going or the oven sensor could be the problem. Buy a BRAND NEW thermomitor and put it in the middle of the middle rack and set to 350. After the preheat is done, wait another 10 min and read thermomitor with flashlight through door glass. This will be the MOST accurate way. to tell

Mar 26, 2009 | Kenmore Kitchen Ranges

2 Answers

Preheat taking long time


If your oven has the hidden bake element then it is probably working properly. A standard oven with an exposed bake element will usually take about 12-15 minutes to preheat. The hidden element models take a little longer but they usually heat a little more evenly.
Post back if you have any more questions.

Oct 29, 2007 | Kenmore 96212 / 96214 / 96219 Electric...

1 Answer

Fridgidaire stove/ove


I have a Frigidaire electric oven model # PLES389ECE. It is two years old. It has maybe 50hrs of use. I had the oven blower motor go out. Then I had a circuit board malfunction.  The repairman discovered that one of the main terminal connections was loose and caused the terminal block to short. Could this have been the problem all along? Also, we are having a problem with the oven coming up to temp. According to the operating manual, set oven temp. lets say for example  350 degrees. Once the oven is preheated to 350 a beep sounds. With my oven the oven is about 60 degrees to low. You have to wait about 10 more minutes. Is this normal with this model? Has anyone else had problems with this model? I also heard that Frigidaire made a bad batch of ranges. Could this be one of them? 
Thanks, Vincent

Oct 27, 2007 | Frigidaire FGB24S5A Gas Single Oven

Not finding what you are looking for?
Kitchen Ranges Logo

Related Topics:

184 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Kitchen Ranges Experts

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Cindy Wells

Level 3 Expert

5103 Answers

Mike Carew

Level 3 Expert

969 Answers

Are you a Kenmore Kitchen Range Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...