Question about Technics SA-TX50 Receiver

Open Question

My technics sa-tx 50 doesn't work overload on display, what can i do? thanks manu

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Kimi
  • 277 Answers

SOURCE: Overload on Technics SA-AX710 Receiver

first of all, check all the capacitors. Other than that, it needs a repair guy to have a poke about inside it with a screwdriver. Has anything happened to it lately that could have upset it a little bit? such as a powercut or had anything done to the plug? (e.g. change of fuse, and put in one that was a different rating) And is it plugged into a surge protection socket, or a plain old fashioned electrical socket?

Posted on Nov 22, 2005

SOURCE: technics sa-ex300 says overload ?

it could be overheating - try aiming a fan at it for a while, see if the problem stops.

Posted on Aug 05, 2008

  • 899 Answers

SOURCE: Technics SA GX490 - Overload

yes it can be fixed , the input may have shorted and is now protecting the other circuits. it will need to be looked at and tested to make the repair. so calling and probably having to take it to, an electronic repair shop will need to be done.

Posted on Dec 07, 2008

  • 1 Answer

SOURCE: Technics SA DA20

I have a Technics SA DA20 control receiver. I was given it by an electronics workshop and it has this same error of OVERLOAD coming into the display when switched on. I removed the plates from underneath and re-soldered as far as I could all the points along the stereo amplifier ICs and as far as access would allow. The unit then worked normally for several hours. I was very pleased, and went out shopping!. But on my return after it had been off for about an hour, the same problem has come back. But my boss at the electornics workshop thinks it it just a dry joint, or series of dry joints. The unit is complex to dismantle, so patience and care is required in taking it apart and making a note or diagram of how it comes to pieces and how to re-assemble it after the board has been re-soldered. It does not appear to be a component problem or fault with the SVI power amplifier ICs.
petertaussig33@hotmail.com

Posted on Jul 13, 2009

  • 1 Answer

SOURCE: My Technics sa GX350 tuner

Hi mate, had the same problem with my amp.. Take the top off and there is a fan at the back, there are 2 piece's of copper flat wire that touch together and these do not touch anymore so when its turned up or the bass gets stronger it cuts off as the fan should kick in at this point. If you can get these to touch again (bend them) then the problem will be gone!! I have had to do this a few times now though so this is not a long term fix.. I may try soldering!

Posted on Jan 10, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Receiver shows overload because the volume was turned up all the way thank you gina


Hello,there is a chance that you have a damaged speaker and that the amp is ok. Check the unit with no speakers at all connected,if there is no overload displayed then its a bad speaker.

Feb 09, 2011 | Technics SA-AX530 Receiver

1 Answer

On switching my technics sa-dx750 it says switching off overload


The question is what is causing the overload? The power supply or the output devices on the heat sink?
If you have accidently shorted a speaker wire, then the answer will be output devices, otherwise it could be anything in the power section. You may find a burnt or damged device with either of the causes.

Mar 08, 2010 | Technics SA-DX750 Receiver

2 Answers

Describe your I have a technics sa ax910 turning


1 You may have a failing power supply regulating circuit in you amplifier and the fail safe circuit is trying to protect the rest of the circuit.
2. there may be a voltage overload at the primary side of the power supply circuit which in this case is causing it to shut down.

Jan 06, 2010 | Technics Audio Players & Recorders

2 Answers

My Technics AV Control Receiver SA AX530 is in overload


An amplifier should never be turn on without speakers, it will overload internally.
make sure speakers work and try again.

Dec 04, 2009 | Technics SA-AX530 Receiver

1 Answer

My technics sa-dx930 receiver stops working and an error message is displayed that says "overload" when i use the "b" speakers for my patio. This is a new problem. i have had the same outside speakers,...


Hey, I own one of these systems. Whenever I touch two of the wires together (shorting it out) the system shuts down and overload appears on the display. My suggestion is too check your wiring (especially in the spliced areas) or replace the wiring to the outside speakers and try it again. If you dont want to try that, take the wires you have hooked to the A speakers and see if they will work on the B setting (a quick troubleshooting technique). Please let me know if it worked for you. Good Luck!

Sep 09, 2009 | Technics SA-DX930 Receiver

3 Answers

Overload at medium (4-6) volumes. Can you adjust or disable the overload protection on these Technics amps??


try this mate:
http://www.electronicspoint.com/googlesearch.php?cx=002919058480771089906%3A03mranmmdze&cof=FORID%3A10&ie=UTF-8&q=Technics+SA-GX550&sa=Search#862

May 23, 2009 | Technics SA-EX400 Receiver

1 Answer

Technics SA DA20


I have a Technics SA DA20 control receiver. I was given it by an electronics workshop and it has this same error of OVERLOAD coming into the display when switched on. I removed the plates from underneath and re-soldered as far as I could all the points along the stereo amplifier ICs and as far as access would allow. The unit then worked normally for several hours. I was very pleased, and went out shopping!. But on my return after it had been off for about an hour, the same problem has come back. But my boss at the electornics workshop thinks it it just a dry joint, or series of dry joints. The unit is complex to dismantle, so patience and care is required in taking it apart and making a note or diagram of how it comes to pieces and how to re-assemble it after the board has been re-soldered. It does not appear to be a component problem or fault with the SVI power amplifier ICs.
petertaussig33@hotmail.com

Feb 23, 2008 | Technics SA-DA10 Receiver

1 Answer

Technics sa-ex300 says overload ?


it could be overheating - try aiming a fan at it for a while, see if the problem stops.

Nov 30, 2007 | Technics SA-EX300 Receiver

Not finding what you are looking for?

Open Questions:

See all Technics SA-TX50 Receiver Questions

Audio Players & Recorders Logo

Related Topics:

246 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...