Question about Dolphin Maytronics Advantage

1 Answer

SKU # DLHD UNIT IN POOL WILL NOT MOVE --SEEMS DEAD FUSE IS OK

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Dolphin Master
  • 1,378 Answers

Thank you for posting your question here on Fixya.com.


For starters, try the tip I posted here on Fixya, found at: http://www.fixya.com/support/r3651526-dolphin_pool_cleaner_wont_start_up. If that is not enough, try our sites FAQ section on Dolphins at www.arrowpools.net. Select the FAQ button then from the drop-down select Dolphin.

If none of this helps your problem could be in the power supply, cable or motor unit. The motor unit is the most likely problem.

It is not recommended you open the cord end that connects to the motor unit as you are breaking the seal for the submersible electronics. For information about sending your unit in for repair use the dolphin form link on the bottom of our site.


If this answer does not fix your problem, please comment with additional details prior to rating the answer. Positive feedback is appreciated once your problem is solved!


John

Posted on Dec 30, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How come my aquabot turbo will not move or pump water?


Probably the drive belt came off the pulley or the belt broke. Similiar to a vaccuum

May 27, 2014 | Aquabot Turbo Robotic Pool Cleaner

1 Answer

Pump seems to start ok - 240 volts - shaft spins but not enough water pressure to move the polaris cleaner?


It sounds like you could have some debris stuck in the impeller on this pump. This is a common problem and anything that gets past the pool filter can end up stuck in this pump.

Sep 03, 2011 | Polaris Pb4 - 60 Booster Pump

1 Answer

Replaced the battery in the car but now unit seems dead although power to inline fuse is OK. KD G386/385 Has it got an internal fuse ?


It might be a good idea to check all of the fuses in the car. The radio requires two power sources in order to work properly.

Aug 22, 2011 | JVC KD-G340 Car CD/ MP3 Player

1 Answer

Intex Krystal Clear Saltwater System for 2 weeks and now unit is dead. No display at all, no function. Power is on and receptacle for house power is fine.


Possible blown interanl fuse... You are required to call Intex and submit for warranty repair if under 2 years and if you have receipt.. Otherwise, you can look up blogs on how to open unit and replace the internal fuse.. Good luck.. Here's the intex number... 1-800-234-6839

Aug 19, 2011 | Intex Automatic Salt Water System for ...

1 Answer

No Power, No LED's. Circuit breaker OK


There is an internal fuse, however to access it the unit must come out. The outer case will need to be removed. The following link will take you to GE's website where you can get installation instructions. The fuse is available at ther parts site, but you can get a new on for less than a dollar at radio Shack. Take the fuse with you.
http://products.geappliances.com/ApplProducts/Dispatcher?REQUEST=SpecPage&Sku=JVM1665DNWW

Mar 05, 2010 | General Electric Microwave Oven

1 Answer

AO error code


I would have to agree with you concerning the control module.

Jul 31, 2009 | Hayward H Series Pool & Spa Heater 400k...

3 Answers

Hayward pool cleaner wont move


Make sure the feet have springs in place, move freely, and rubber not too worn. If that all looks ok, then probably too much suction pressure. Use gauge that came with unit to verify proper suction.

May 30, 2009 | Hayward Navigator Pool Cleaner

1 Answer

I have a Bose Wave radio which seems to be dead, no sound, Displa


There's a line fuse inside the radio, mounted on a PC board. CAUTION: disconnect the set from power before opening the case or poking around inside. The fuse could be bad, but these sets are notorious for losing the power transformer. If the fuse is ok then you are looking at a $100 repair fee from Bose. You might want to check out the new HD radios -- better sound, MUCH lower price.

Bill B.

Mar 28, 2009 | Bose Wave Radio II

1 Answer

Sanyo EM-710F display dead


Low voltage Tx actually OK. Restored vaporised circuit tracks on controller board, fuse and interior light globe. All working OK.

Jun 18, 2008 | Microwave Ovens

Not finding what you are looking for?
Dolphin Maytronics  Advantage Logo

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dolphin Pool & Spa Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

john h

Level 3 Expert

12650 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Dolphin Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...