Question about Electrolux C101 Bagged Canister Vacuum

1 Answer

The motor in the power head ran at a higher pitch for a for 8 to 10 seconds then stopped. If I push the reset button the powerhead may or may not start or it may start and run for a few seconds. The brush is not caught.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 694 Answers

Did you check the belt? A broken belt results in lower strain on the motor, causing it to run faster resulting in the faster speed and higher pitch. This could result in overheating, which will cause the motor to shut off.
If this isn't the problem you'll need to take it to the nearest Aerus Electrolux store for trouble-shooting and repair.

http://www.aerushome.com/storelocator/

Posted on Dec 29, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Tristar exl powerhead reset button won't reset


You should take it to your local vac shop for diagnosis. It may have a bad breaker, but it could have something else wrong. The way to tell if the breaker is bad without a meter, is to connect the 2 wires together and see if the motor runs. BUT BEWARE, if you do this and the motor is binding, it could burn it up. Again, the best thing would be to take it to a professional.

Feb 20, 2015 | Tristar Vacuums

1 Answer

The powerhead on my Hoover Duros will not keep running. If I push the on/off switch it will come back on sometimes, other times when I push it it turns the whole thing off as its supposed to do.


I just had the same problem with my hoover duros, the vacuum was running fine but the powerhead kept going off. I would make a sweep with it and powerhead would be running and then next sweep powerhead would shut off. I had tried checking connection and belt, etc. I thought it was the powerhead. But then I found the problem. On the duros there are 2 pieces of wands that hook powerhead to hose on canister. They both connected and clicked in fine but I decided to check them separately. I hooked just one piece to hose and powerhead and then turned it on and then I did the other piece. ta-dah! that's what it was...it was only one section of the wand. When I hooked them up separately, one piece the powerhead worked totally fine and vacuumed like normal. When I removed that piece of wand and tried the second piece (actually the bottom section when both are hooked together) the powerhead did not work at all. So I just need to get a new section of wand. Hope this helps!

Nov 17, 2011 | Maytag Hoover Duros S3590 Vacuum...

1 Answer

The powerhead brush died. The vacuum works just fine, but the brush doesn't.


there could be 2 reasons for this problem.

one) the powerhead is dead legit as in there is no power coming to it or the motor is actually dead.

2) something jammed in the brush and popped the reset button. The reset button is a red button located as your looking at the back of the powerhead on the right side. Usually a red square. Push it and it SHOULD start up again.

That being said, if you have done the reset button and it still does not work, that unit I beleive has either a 2 or 5 year warranty (cannot remember dont have the documentation in front of me) and if it is still covered under warranty for you, take it to your closest Vacuum repair shop. Do take the hose and powerhead with the cannister unit.

good luck

Nov 06, 2010 | Electrolux EL7020A Oxygen 3 Ultra Canister...

1 Answer

Was using kenmore whispertone stopped suddenly disconnected brush unit will not switch on ????


if you took the hose out of the wand assembly then it may not turn on as the hose handle has a power button on it and must be connected to turn on the unit.Also check the powerhead for a reset button (small red / or black button on the back of the head){back of head not the bottom}

Oct 05, 2010 | Kenmore 23313 Whispertone Bagged Canister...

1 Answer

Lubrication for powerhead motor


the power head motor dose need service first thing you should do is take the top cover off by removing the screws on the bottom of power head then remove brushtroll clean brushroll and the end bearings make sure they spin freely squirt some lube (wd40n or tri flow) on the end cap bearings . Then clean motor by blowing it out with compressed air lube bearings with either wd40 or tri flow that should free up the motor and brushroll

May 26, 2009 | Vacuums

2 Answers

Power brush will only operate on push stroke


If the motor runs, the circuit breaker is working. If it only works on the push stroke, you probably have burnt contacts where the handle and/or wands and/or power head connect. When you push, the contacts are pressed together; when you pull, they are separated and the motor loses power. The only solution is to replace the connector parts.

May 06, 2009 | Vacuums

1 Answer

Powerhead Keeps Shutting Off


Open up the power head and check the toothed corners where the power head sits - it sounds like thread has caught up at the sides which can only be removed by opening up the powerhead to clean it.

Nov 14, 2008 | Electrolux EL7020A Oxygen 3 Ultra Canister...

1 Answer

Restart button


Usually there is a red reset button to push on top of the power head, but some are on the back edge of the powerhead.

May 28, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

3 Answers

Hoover s3755 bagless windtunnel canister


Very likely it's the cord at the nozzle neck. These cords flex when you vacuum and they often break internally where the cord goes into the neck. Turn the vacuum on and wiggle the cord at the powerhead and see if the powerhead comes on and off. If this happens, then you will have to replace the cord.
On some of the early models, the receptacle in the hose, where it plugs into the top of the wands, will break away from the plastic pins it sits in, and the receptacle will slide back into the handle, which means that it will not plug into the powerhead connection when you connect the hose. You can check this by looking at the end of the hose and observing if the receptacle is sitting flush with the opening it sits in. If it is pushed back, it will not make a complete connection with the powerhead cord that is sitting at the top of the wands.

Jan 18, 2008 | Hoover S3755 WindTunnel Bagless Canister...

2 Answers

Vacums


check belt not broken - could have happened when you caught tassle in head

Apr 18, 2007 | Kenmore 23313 Whispertone Bagged Canister...

Not finding what you are looking for?
Electrolux C101 Bagged Canister Vacuum Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...