Question about Hoover Vacuums

1 Answer

I have serial U5180-910 Belt38528040 Hover Mach 3 12 amp cyclonic cleaning system. I bought it dec 2007, every time I use it stops because it over heating. what should i do about it.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 330 Answers

Take it back right away, you still have the factory warrenty.

Posted on Jul 06, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

(hover whisper cyclone)brush stopped rolling checked belt and looks fine what else can it be?


check other side from belt may be a little jam on the rollers on the oppsite side of the belt

Sep 27, 2012 | Vacuums

1 Answer

Vax mach xp reach seems clogged and light is on


Clean the filters as per the user guide AND remove the silver, where the clear plastic handle is. On te back by the purple catch to release the dirt container is a screw - remove that and then remove the 3 screws on the purple lid with holes in it, remove the lid & clean the "cyclones" - mine were all blocked. Make sure all the bits are clean & dry & re-assemble.

Jul 29, 2012 | Vacuums

1 Answer

My Hoover UH70040W Wind tunnell mach cyclonic has stopped sucking up debris. At the brushes you feel no suction and when you disconnect the tube on the side it has some suction but not much at all. The...


Well if the vac motor is good then its either a clog or a leak ,if you say no clog then it has to be a leak. Make it blow out and see where the air is coming out or try and find it while it is running with a piece of typing paper loosly around the hose and piping. Seals at the connection areas go bad so check them as well.

Mar 31, 2011 | Hoover UH70040W Bagless Upright Cyclonic...

1 Answer

Hello,We have an Hoover Mach 5 Cyclonic vacuum that has no suction. We have cleaned and checked all hoses, belts & filters. Please help us.


With this model, remove the dust tank, and turn it on, check for suction at the lower intake. If you have suction, install the tank and remove hose, and check for suction there. keep following until youn lose it. Then you problem will be between those 2 areas

Mar 27, 2010 | Hoover U5194-900 Mach5 Multi-Chamber...

2 Answers

Hoover Mach 3 (Fusion): Dirt Will not enter dirt cup


The dirt in my vacuum keeps getting stuck into the hose and dosent reach the chamber, its a constant problem even if i clean out the clog!!

Jul 31, 2009 | Hoover Elite Rewind Bagless Upright...

1 Answer

Our Mach 5 turns off after running for about 5 minutes and smells hot!! Help!!! We have 3 kids and I need to Vacumn.


Hello:
Go here
Then find the clean filter section and clean all the filters especially the secondary filters. i think this will solve your problem.

Jul 07, 2009 | Hoover U5194-900 Mach5 Multi-Chamber...

1 Answer

It shut off and will not restart


All the filters have to be removed and cleaned or replaced

Apr 20, 2009 | Hoover U5194-900 Mach5 Multi-Chamber...

2 Answers

Hover mach 4 vaccum


usually caused from being plugged, so first find the plug and clear it. The motor has an automatic reset, should restart after about 30 minutes, if it continues to shut off, there is still a plug.

Dec 12, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

84 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18299 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...