Question about Panasonic Vacuums

2 Answers

Panasonic mc-v6840 Low suction.Changed bag and cleaned hose blockage

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 328 Answers

Check the sole plate where the roller brush is. There may be an obstruction leading from the sole plate to the main dirt channel. Usually on many Panasonic uprights the main dirt channel is a removable bent plastic tube before it meets the bottom of the hose. Check to see if this isn't obstructed. ALso check your filters on the vacuum as sometimes a blocked filter means a lack of suction.

Posted on Jul 04, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

The manual says to remove agitator and clean every five uses and cites this as a troubleshooting point for low suction. However, I can't promise that will work because I can't figure out why mine won't work anymore. The manual is available online on panasonic.com.

Posted on Nov 12, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Riccar 8995 no suction in hose


drop a quater thru hose make sure it goes thru

May 18, 2014 | Riccar Vacuums

1 Answer

Not much suction


Check that the bag and filter are clean.
Try it without the hoses and fittings, If there is better suction the hose has a blockage. Reverse the hose and and hold it against the inlet on the machine and let the machine **** though the hose backwards. This sometimes clears a blockage.

Feb 11, 2011 | Bissell Vacuums

1 Answer

I have a panasonic mc-ul975 vacuum that works great when working properly. the airflow through the canister seems to stops once the aero blast technology is done running which causes the vacuum to not...


Hi there. In Panasonic vacuums2.gif, there is a thermostat protection on the motor. It will automatically shut off the motor if there is no airflow through the motor. This is typically caused by a clogged hose. Typically, if your dust container is that full, there could be backup in the hose. Or the dust container being too full could also or otherwise be the problem. Check your hose for blockage, let the machine cool off, it should start up again

Aug 30, 2009 | Panasonic MC-UL975 Upright Vacuum

1 Answer

The suction isnt working


disconnect the hose where it goes into the base and see if you have suction there.if you don't then your intake hose is clogged.thats the hose that your long stretch hose connects to.take a coat hanger and bend the tip so the end is rounded.work it down into the intake hose at the bottom and try to push the clog out through the bottom.make sure your filters are clean and the bag isn't full. please leave feedback

May 05, 2009 | Panasonic MC-V5005 Bagged Upright Vacuum

1 Answer

Panasonic MC-E468 vacuum cleaner loss of suction


HI If the cleaner is loosing suction make sure to check all inspection tubes and the dirt channel hoses after the spinning brush. Also check the main hose for any clogging. One of the worst faults of this model is clogging hoses. Hope that helps you.

Feb 27, 2009 | Panasonic MC-E583 Bagged Upright Vacuum

1 Answer

Kenmore vacuum model 37105 no suction


are the brushes moving?if so , it is clogged somewhere, that is my guess

Jan 26, 2009 | Kenmore Vacuums

1 Answer

Miele vacuum cleaner not working properly


Is the suction low or ok at the vacuum without the hose attached? If it is ok, then there is a clog in the hose. If it isn't, then check filters, is the speed variable, is the contol set too low. Could be a bad motor, running too slow.

Mar 05, 2008 | Vacuums

1 Answer

Sebo auto x4 1300w


If you pull the hose out, do you have alot of suction? If so, then it may be blocked at the inlet down by the brush roll. If suction is low at the hose, then the hose has a restriction in it. There is a circuit board down on the nozzle that could be giving you a false indication and would have to be replaced.

Jan 06, 2008 | Vacuums

1 Answer

Not enough suction for Panasonic MC-V5716 upright


Probably not the motor protector, its function is shut off the motor if it overheats. Most likely you have a clog or partial clog in the inlet down by the brush roll, or it is in the hose. But if the motor is running, and suction is low, with no clogs, then maybe the motor is running at a slower speed and will have to be replaced.

Nov 04, 2007 | Panasonic MC-V5716 Upright Vacuum

1 Answer

No suction in vacuum on a Panasonic MC-V7355


the device is a bypass which allows some air flow when there is a blockage. you have a blockage somewhere i suspect hence no suction. check all hoses carefully. take off the base and check the air duct away from the brush roll

May 02, 2007 | Panasonic MC-V7355 Upright Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

191 people viewed this question

Ask a Question

Usually answered in minutes!

Top Panasonic Vacuums Experts

Ryan S
Ryan S

Level 2 Expert

328 Answers

Jim Parker
Jim Parker

Level 3 Expert

1040 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Panasonic Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...