Question about Car Amplifiers

2 Answers

ALPINE MRV-T757, BRIDGED AND BLOWN

MY CUSTOMER BRIDGED THIS WRONG [PLUS TO PLUS ,NEG TO NEG. AND IT BLEW ALL SIX TRANSISTORS ON THE BOARD. I TRIED TO ORDER THE PARTS, IOR International Rectifiers IRFZ44N. FROM ELECTROSONICS, THEY SENT ME A REPLACEMENT FROM NTE , NTE MOSFET-POWER N CHANNEL PART NO. NTE2395. INSTALLED AND TESTED WITH POWER AND NOW TWO OF THE NEW PARTS BLEW AGAIN. ....... CAN WE STILL SAVE THIS OR WHAT?

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Car Amplifiers Master
  • 3,614 Answers

Did you have test all other capacitor & resistor..on the board, could be some parts maybe faulty and can cause of this other parts blown..

Posted on Jul 03, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

The problem is that the driver circuit is also damaged. Try powering up the unit with the output transistors disconnected. Measure each pad and report the results here. You should see something like 0.6,B+,0.0 on each set of three. Some will be negative rather than + (-0.6,B-, 0.0).

Keep us posted.
Dan

Posted on Jul 03, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I bridge this amp to run a single sub?


  • To bridge 1 sub with a Alpine MRV-100M amp you run the negative and positive wires coming from the speaker to the outside terminals on the AMP respectively.

Regards, Tony

May 22, 2011 | Alpine MRV-100M Car Audio Amplifier

1 Answer

AMP IN PROTECT MODE


have you tried removing the power from your amp, there are several reason to put an amp in protection mode, its usually due to incorrect wiring. ohms law???

Sep 11, 2010 | Alpine MRV-T757 Car Audio Amplifier

1 Answer

The light power is red and it smell like melt


on an amplifier that usually means that its burnt out, or that you've melted one of the wires. check the ground wires and whatever you have the amp sitting on. if everything looks alrite then its most likely the inside of the amp is fried.

Jun 20, 2010 | Alpine MRV-T757 Car Audio Amplifier

1 Answer

I need to know what the wattage the alpine mrv-f407 puts out when its bridged or only running 2 channels?


RMS Continuous Power (at 12.0V)
Per channel into 4 ohms...............40W, 0.08% THD
Per channel into 2 ohms ..............50W, 0.3% THD
Bridged into 4 ohms.....................100W, 0.3% THD

RMS Continuous Power (at 14.4V)
Per channel into 4 ohms...............60W, 0.08% THD
Per channel into 2 ohms...............80W, 0.3% THD
Bridged into 4 ohms.....................160W, 0.3% THD
Max. Power (at 14.4V)
Per channel into 4 Ohms..............120W
Bridged into 4 Ohms....................320W
This should help.

Apr 30, 2010 | Alpine MRV-F407 Car Audio Amplifier

1 Answer

I obtain recently a car amplifier model: mrv-f400 of alpine, i want information about the correct way to instal thanks


http://www.alpine-usa.com/US-en/support/support_search.php?modelname=MRV-F407

THE ABOVE LINK WILL DOWNLOAD A MANUAL FOR THE SIMILAR MRV-F407 AMPLIFIER. IF YOU WANT TO PURCHASE THE EXACT MANUAL, YOU CAN OBTAIN IT FROM PACIFIC COAST PARTS AT 800-421-5080 PART NUMBER=68P50958W56. IT IS AROUND $5.00 PLUS SHIPPING. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE.....V

Nov 24, 2009 | Alpine MRV-F540 Car Audio Amplifier

1 Answer

Red protection light on when power,d up from battrie is this normal


check the connector at the amp and make sure the wires aint touching also check ur speaker wire are rigged up right... do not run 2 subs off 1 channel as it will pop fuses and the procet light will come on

Oct 21, 2009 | Alpine MRV-T757 Car Audio Amplifier

1 Answer

Blinking protection light on mrv-t757 amp


Could be the power supply or output stage electrolytic capacitors.
Possibly breaking down/drying out inside.

Mar 17, 2008 | Alpine MRV-T757 Car Audio Amplifier

2 Answers

Wiring my subs to my alpine mrv-1000


did you read your instruction manual. does it says "it could be bridged to other amp"?. you can't make a bridge to amplifier that is not bridgeable. bridging an amp is a way which it is made through transistor type ampilfier by bridging more transistor inside and more voltage is required for bridging.
I don't know if we could do to an IC type amplifier. ask an experts about bridging IC types how to bridge maybe they know how.
and if you had an successful bridging, you may have a problem through your speakers, they may hit hard but you will experience some errors through your speakers and easy to worn.

Jan 22, 2008 | Pioneer GM-X962 Car Audio Amplifier

1 Answer

Alpine mrv-t757


Hi Big Nick,

 

Sounds like you have got almost all the good out of those Subs. You can find the screws you need at almost any hardware store or Auto parts store. The light is becase you are dloading the amp with low OHMS.  You may need use one channel and Run the wiring like written blow to get the power problem to disappear.

 

S1+ = Kicker comp cvr sub coil 1 positive

A+ = Amplifier Positive output.

 

 

A+ to S1+

S1- to S2+

S2- to A- 

Oct 18, 2007 | Alpine MRV-T757 Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

293 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...