Question about Audio Players & Recorders

2 Answers

Technics amplifier sound cuts after a few seconds operation

Posted by on

  • 01494 May 08, 2009

    everytime i turn it on it cuts out after a few seconds and the red light remains as it is on stand by

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 417 Answers

SOUNDS LIKE YOUR OVER LOADING
OR YOU HAVE 1 WIRE SPEAKER WIRE AROUND THE WRONG WAY

Posted on Jul 03, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 726 Answers

Hi there if the sound cuts out after a few seconds and then if you turn it back on again if it does the same you might have a few problems ,,
make sure you are not overloading with to many speakers
make sure all positives are to positive and negatives are to negatives
make sure the unit is not over heating or getting to hot make sure it has room to circulate the hot air
and also check the wiring for any breaks or rips that could be touching each other to make it shutdown
when it cuts out its going into safe mode to prevent further damage one of those will defintly be your problem good luck with it hope this helps

Posted on Jul 01, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can i hook a amplifier to my technics receiver model no sa-ax720


If the Amplifier has more Output Power and Better Quality Sound then it is worthwhile to do so -Yes you can connect Amp to Technics Receiver you have mentioned

Jun 24, 2015 | Technics Audio Players & Recorders

1 Answer

What causes the sound to cut for a few seconds?


Hi i just would to know if you did try to connect your TV by HDMI to test if your optical output of your reciever/amplifier have some problem. In second time yes maybe you can have an overheating problem, just take a look at your grid and maybe a clean-up will be necessary. I don't think your amplifier have a fan.
Don't hesitate to contact me here in this post. have a nice day.

Nov 10, 2014 | Technics SA-DX750 Receiver

1 Answer

Power on but no sound


check for a clicking sound of relay after a few seconds from switching on, if missing , the amplifier section needs technical attention. refer service to a qualified engineer.

Nov 14, 2010 | Yamaha R-V703 Receiver

1 Answer

Onkyo TX-DS838 integra receiver got sound cutting off for few seconds during play back and problem keep incur after few minutes. Any suggestions to trouble shoot this problem very much appreciated. Cheers,


Hello sir, there are several factors that might cause this:
  1. Low voltage. check for filter leaking capactor. defective regulator, or a burnt resistor.
  2. High voltage peak, check for the voltage output VCC.
  3. the main amplifier is defective. if it is an IC amp. replace it. if transistorized check for the pushpull driver/transistor.
Hope this helps. let me know your progress. thanks

Jul 28, 2009 | Audio Players & Recorders

2 Answers

Technics SA-DX930 Sound cutting in and out


try rehooking up speaker wires. make sure no bare wire is showing and positive and negative are aligned correctly

May 19, 2009 | Technics SA-DX930 Receiver

1 Answer

Technics su z2 amp shuts off sound


hello. we cant help if we dont know what music source you are using.

Apr 13, 2009 | Technics SA-AX530 Receiver

2 Answers

I have no sound in teh left channel , could be an integrated ?


Hey, The model of the amplifier is SU-G91 Technics.....If you could help......Thank you.

Apr 08, 2009 | Technics SA-EX320 Receiver

2 Answers

Su-g91


Have you checked the fuse in the unit?

Aug 31, 2008 | Technics SA-AX540 Receiver

1 Answer

THE AMPLIFIER CUTS OFF WHEN I INCREASE THE SOUND.HD560


I've just fixed a Denon amp with the same problem. Replace the mains plug - especially if it a moulded type. Likely that the wires inside the plug have frayed to the extent that there aren't enough strands left to carry the load when the volume is cranked up.

May 25, 2008 | Technics Audio Players & Recorders

3 Answers

Technics SA-DX950


when turn on receiver , after few seconds got message
F70. when wants to do any operation with receiver got message SWITCH POWER OFF

Jun 25, 2007 | Technics SA-DX950 Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

188 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

98829 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69805 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...