Question about JVC KS-AX4750 Car Audio Amplifier

1 Answer

JVC dual bridgeble AMP

My Amp suddenly stopped working on the left chanel.
I took it to a repair work Shop to fix it.
as per repair 2 mosfets were replaced.
the amp is now giving out put on both the chanel. but as soon as i increase the volume the left channel bass fades away and voice gets distorted only at left chanel. what could be the problem.
please help ?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 624 Answers

Have the speaker checked out and if it checks good you need to take the amp back to the repair center and have them test it better. Most repair centers have a 30 day warranty on the work they perform. Make sure they know what the problem is in detail, so they know how to check it properly. But my first thought is the speaker could be faulty. You can check the speaker yourself by switching them at the amplifier. If the same speaker sounds bad you know it is the speaker that is bad. If the sound is bad from the other speaker, then the amp is bad unless it is coming from the head unit. You can also switch the RCA input jacks after that and see if the problem changes speakers, if so, the RCA output of the head unit is bad, but that is less likely.

Posted on Jul 03, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2007 Honda Civic 2 door bought the car found the legacy LA 960 in the trunk worked great for 1 year took on a 500 mile ride and woofer gave out. Took to a repair shop they said fuse of 20 amps...


1. Stop going to this shop.
A fuse that keeps blowing is a sign of a problem. You never replace a fuse with one of a higher amperage because the idea is the fuse is suppose to blow before the the wires melt and catch on fire. The reason it stopped working and the fuse didn't blow is probably be cause the wire did melt someplace and you are lucky the car didn't burn. If it did burn and the insurance company found the 40 amp fuse, they would probably have refused to pay.
The idea that a repair shop would do this tells me that they don't know what they are doing. Read this
FUSES

Oct 18, 2013 | Legacy Audio LA960 Car Audio Amplifier

1 Answer

I hooked up a dual mosfet 4 channel amp and i am not getting power to it. the way it is setup is from battery to 100 amp fuse, from fuse to inside cab of truck then to 500 K farad, Split from + to power on...


Bad ground sounds like you may have paint or undercoating stopping the ground from making good contact or unhook the remote wire and run a small wire from the main power to the remote hook up and see if it works ...... May have a faulty remote

Apr 25, 2011 | Dual 2-Channel Bridgeable MOSFET Amplifier...

2 Answers

Shashij_2001@yahoo.com


TURN THE BALANCE CONTROL IN THE MIDLE

Jul 06, 2010 | Yamaha P4500 Power Amplifier 2-Channel

1 Answer

Subwoofer powers on for about 4 seconds and then shutsdown


I don't know if you were able to get the problem fixed, but I had the same sort of problem where it worked and then all of a sudden it stopped working right in the middle of a movie.
I took it to a repair shop and he found that it was the power supply... a $4.00 part.

Jun 14, 2009 | JVC TH-C30 System

1 Answer

4 chanel amp I dont know how to conected,to radioand one subwoofer


Hello canelo63,

Your question appears under the product listing for the Dual XPA4100 but the in the text you say the amp is actually a Jensen, so it's not possible to provide specific connection information.

But most bridgeable amps can be connected to a single subwoofer and the other two channels used to drive a set of regular speakers. I'd connect the front speakers to channels 1 and 2 and wire the subwoofer to the bridge connections of channels 3 and 4. On the XPA4100, the bridge terminals are the first (negative) terminal on channel 4 and the last (positive) terminal on channel 3.

Hope this helps.

Jun 01, 2009 | Dual 2-Channel Bridgeable MOSFET Amplifier...

1 Answer

JVC dual channel bridgeble Amp


Most repair shops offer a warranty. If you've recently had it repaired, return it to the shop to have them check it out. If you continue playing it as it is, more damage may occur and the additional damage isn't likely to be covered by the warranty.

Jul 01, 2008 | JVC KS-AX4750 Car Audio Amplifier

1 Answer

Dual xpa 4100 2/3/4 chanel amp


make sure power and ground are where they are suppose to be and speaker wires are not mixed up. but it sounds to me like the amp is junk

Jun 09, 2008 | Dual 2-Channel Bridgeable MOSFET Amplifier...

2 Answers

Blown car amp repair (Lanzar Opti 150 stereo bridgeable car amp)


its better to change them all. than to change 1 or 2 mosfets, bcuz simetimes it affects the other mosfets. and please check your speaker or maybe there is an resistor, capacitors, or a relay malfunctioning in that area.

Jan 18, 2008 | Car Audio & Video

2 Answers

Audiobahn A6004T Amp Blown PLEASE HELP!!


They are most likely a MOSFET type of transistor. If they are in the power supply part of the amp then you will probably need to replace all the MOSFET's in the power supply along with perhaps some gate control resistors for them. They each have their own resistors. It wouldn't hurt to see if the 494 IC in the power supply is working properly too. This IC is what sends the pulse width modulated square wave to the MOSFET's. Next you will want to test all the MOSFET's that are used as the audio output drivers and their predrivers and bias resistors. Don't forget to check the DC bias and offset on the outputs too, to make sure everything is OK there. In short, you will most likely need to go to a repair shop that can do all this and who would know what the heck I'm talking about. Good luck.

Mar 05, 2007 | AudioBahn A4004T Car Audio Amplifier

4 Answers

Amp Will Not Stop Overheating


You say you have 2 p312d2 subs. Ok so the d2 stands for dual 2homs (2 X 2homs voice coils per sub) , conecting in parallel the 2 voice coils of only one sub will create 1hom load to the amp, and if your amp is 2homs stable per chanel that means you are lowering too much your homs causing the overhwating to it.

Sep 25, 2006 | Ultra Linear UL-2200D Car Audio Amplifier

Not finding what you are looking for?
JVC KS-AX4750 Car Audio Amplifier Logo

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top JVC Car Audio & Video Experts

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

kakima

Level 3 Expert

102366 Answers

xxxxxx xxx

Level 3 Expert

4823 Answers

Are you a JVC Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...