Question about Nitro BMW-481 Car Audio Amplifier

1 Answer

Nitro 1000 w amp

Protect red light stays on checked all wires even tried to simplfiy set up can you help?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 45 Answers

Unplug the speakers and the RCA leads from the amp, if the red protection light is still lit then its 1 of your linear amps blown or mosfet depending what your amp uses..if the red light does go off with the leads all disconnected, then connect 1 lead at a time and check the light,when you connect the bad lead or speaker then the light will come on and you know that 1 needs replacing..hope this helps

Posted on Jul 27, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The Ground wire is hooked up right but the red light wont go off and stay green so the amp will work. It is very frusterating all the cables are the right size its is a 1000 watt amp. I have two 500 watt...


Sounds to me like the amp is going into protection mode. Try placing one sub on the amp with very little gain. One of the biggest reason why this happens is because the subwoofers are wired wrong. What is the brand and model number for your amp?

Apr 14, 2011 | Car Audio & Video

1 Answer

Why is the red light that says protect on? my amp turns on but it dosent work, i have a sup hooked up & it dosent work. the red light that says protect is on.


first thing check all ground and power wires and make sure ur rca wire make sure it isnt cut in anyway. after that unplug ur sub and unplug the negative wire from ur amp, while its out check the fuses on the amp if all is well put all fuses back if not get new. then plug the negative wire back in if protect goes off check for heat and if no heat inspect the wires from speaker out put all the way to the sub, look for any wire touching another this is were most problems are even the smallest wire can trip a protect. if u still cant find the problem. an amplifier specialist is in order.if its trashed go on ebay and buy a powerbass there goin cheap right now. hope i could help

Oct 12, 2010 | Lanzar VIBE266 Car Audio Amplifier

2 Answers

I have a nitro 1200 watt amp that was working great until it a red light that read " protection mode" turned on


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty
Definitely is worth .A thumbs up would be greatly appreciated if this answer is helpful to you. nitro-1200-watt-amp-working-lv2kkrmxrai4iihdvw4m3np2-1-0.jpg

Aug 25, 2010 | Nitro BMW-482 Car Audio Amplifier

2 Answers

Hello, i have a nitro bmw 486 amp. i use it to power my 2 subwoofers in my trunk. its a very good amp and sure does its job, but randomly the light will turn red, which means protect, and my subs will shut...


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty D .A thumbs up would be greatly appreciated if this answer is helpful to you. nitro-lv2kkrmxrai4iihdvw4m3np2-1-0_0.jpg

Jul 31, 2010 | Nitro BMW-486 Car Audio Amplifier

2 Answers

Ok so my Nitro BMW - 481 2000w amp was working and then i came back the next day and the red protect light was on its been working for weeks but now it has the red light.


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. ok-nitro-bmw-481-2000w-amp-working-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg http://www.nitrobmw.com/

Mar 17, 2010 | Nitro BMW-481 Car Audio Amplifier

1 Answer

Unit only stays on for 4 seconds then turns itself off.


This is a short or unstable ohm load. Remove all speaker wire connections to see if the amp will stay on.
If the problem goes away when disconnecting the speaker wires try this:
1) Check volume level on zone one and zone 2 if connected. If it is too high the amp will go into protect mode and shut off exactly as you described.
2) Make sure no wires are touching any other wire or the metal surface of the amp. This will cause a short and send the amp into protect mode.

Nov 21, 2009 | Denon AVR-1705 Receiver

1 Answer

Can't get my amp to work right


Recheck each and every wire connected to the amp. If everything is wired correctly, then you either have a shorted speaker, or a shorted pair of speaker wires, or one of the speaker wires is touching another grounded location, or the amp is blown.

That's about as far as you can take it, unfortunately.

Double and triple check all you wiring. EVERY wire! Don't assume anything about any single wire.

Nov 16, 2009 | Power Acoustik PS2-820 Car Audio Amplifier

2 Answers

I have a nitro 1200 watt amp earlier today it was workin with no problems we parked then came back in the car 3 hours later and it wasnt workin wont come on or anything just red light which is protecting...


Check your speaker wires, make sure everythings connected right with no short circuits, and check all of the fuses in the amp, and make sure none of them are blown. If all this checks out just check the battery wire, grnd, and remote wires. It has to be a wiring issue unless you busted your amp, but if was working when you tuned it off it should be alright... hop this helps...

Sep 10, 2009 | Nitro BMW-484 Car Amp

1 Answer

The red light is on i dont know why my amp is kiker kx.500.2


Disconnect your speaker wires at the amp and test. If it turns normal (green or whatever) check your speakers and wires with a meter for a short. If it stays red, the protection circuit is cooked and needs to be serviced. Hope this helps.

Aug 11, 2009 | Kicker KX Series 04KX1200.1 1200w RMS...

1 Answer

Same problem i have a 486 bridge green light before now red.


IF THE RED PROTECTION LIGHT STAYS ON MAINLY MEANS THAT ITS BLOWN, I HAD THE SAME PROBLEM BUT MY PROTECT LICHT DIDNT COME ON, IF U HAVE A WARRNETY ON U CAN USE.

Jun 18, 2009 | Nitro BMW-486 Car Audio Amplifier

Not finding what you are looking for?
Nitro BMW-481 Car Audio Amplifier Logo

304 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nitro Car Audio & Video Experts

Michael Kovalik III
Michael Kovalik III

Level 2 Expert

117 Answers

yadayada
yadayada

Level 3 Expert

71694 Answers

matthew walsh

Level 1 Expert

69 Answers

Are you a Nitro Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...