Question about Olympus EVOLT E-300 Digital Camera

4 Answers

Olympus E-300 Evolt - LCD Screen doesn't come & SSWF light stays on

I was using my camera fine three days before. I bought a new lens, Zuiko Digital 70-300mm. I attached as normal, went to turn on my camera and nothing happen. No screen information whatsoever. I removed the lens and reattached my 15 - 45mm Zuiko Digital Lens I was shooting with the day before and nothing again. I checked the battery and have plunty of charge. The unit didn't get wet, dropped or mis-handle in anyway. Does anyone have any suggestions. I think I'm going to take it in to the repair shop.

Posted by on

  • jucarca Jul 13, 2008

    Hi, I have the same problem. My Olympus E-300 Evolt has a Zuiko Digital 40-150 lens. I turn on the camera and nothing happens, and SSWF light stays on. I turn off the camera but the light is still on.

    Thanks for your help.


  • molsen Jul 13, 2008

    i just bought the the same lens have the same problem

×

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

My camera is working again, but the problem is not completely solved. What I did was to put on the old lens, take out the battery then turn on the camera and finally put on the battery again. And now it works. But the problem with the new lens (Zuiko digital 40-150) continues.

Posted on Jul 13, 2008

  • jucarca Jul 15, 2008

    Hello, it's me again. You have to be sure to update the firmware of the camera to the latest version before using the lens. I update my camera and now is working good.

  • jucarca Sep 14, 2008

    Hi. The firmware is the built-in software which the camera uses to work properly. As a software, you can update it by connecting the camera to a PC and running the Olympus Master software that should have been included with the camera.
    Then Set (PC MODE) in the E-300's (Set up Menu) to (Storage). If the operating system is Windows XP, remove the memory card before connecting the E-300 to the PC.
    In the Olympus Master software Help Menu, you can look for "update firmware" to follow the instructions. Good luck!


×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Please i have the same problem can some body help me! Thanks

Posted on Jul 10, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Jucarca is exactly right about updating the software, but be forewarned that it will only work if you have the newest Olympus Master Software Update, Olympus Master 2. Olympus Master 1.1 will not be able to connect with the online server. Luckily, Olympus Master 2 is a quick and free download from the Olympus site.

Once you are sure you have Olympus Master 2 loaded, follow Jucarca's directions (above). Just completed the steps, and my new 300 lens now works fine.

Posted on Dec 29, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Ok, I need to update the firmware...
Now, what's a firmware and how shall I update it? Sorry, I don't understand...

Posted on Sep 12, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to use the Olympus 18-180mm f/3.5-6.3 ED Zuiko Digital Zoom Lens in low light.


The 510 seems to have trouble auto-focusing in low light. Manual focus works if there is enough light for your eyes.

Dec 16, 2009 | Olympus EVOLT E-510 Body Only Digital...

1 Answer

LCD montior not on to see picture before taking picture


On the EVOLT E-300 it is not a camera that has a live view LCD screen that will allow you to see the image before it is taken. You must take the image with viewfinder only and only use the LCD screen for review purposes. This is how the camera was designed.

Mar 15, 2009 | Olympus EVOLT E-300 (Double Lens Kit)...

1 Answer

SSWF Light


update the firmware of the camera to the latest update using the software that came with the camera

Oct 13, 2008 | Olympus EVOLT E-300 Digital Camera

1 Answer

SSWF ON MY E300 WONT GO OFF


Try updating the firmware on your camera to the latest version using the Olympus master software. There have been several revisions since the camera came out.

Apr 21, 2008 | Olympus EVOLT E-300 Digital Camera

1 Answer

Attaching non-Olympus lenses


The E-500 body has a "bayonet" twist & click attachment for the lens. There is no way that a simple screw threaded lens can attach to the camera directly. The lens that you have are designed to screw into the front of the original Olympus lens. I have seen some of these adverts on auction sites and they are worded something like "The wide angle / Tele lenses are simply mounted in the front of the Olympus EVOLT E-500 / E-330 / E-300 standard ZUIKO Digital EZ 14-45mm lens, or any other lens with 58mm filter thread." Which maybe isn't clear enough. So the bottom line is that you need an Olympus lens to use the other lenses you have bought. Please update the question & let us know if the information given was useful to you - Good Luck!

Aug 16, 2007 | Olympus EVOLT E-500 Digital Camera

1 Answer

EVOLT Body


No, the EVOLT body, Zuiko Digital 14-45mm F3.5-5.6 and 40-150mm F3.5-4.5 lenses are not splash proof.

Sep 04, 2005 | Olympus EVOLT E-300 Digital Camera

1 Answer

Lenses


ZUIKO DIGITAL Four Thirds System lenses can be used with the EVOLT E-300.

Sep 04, 2005 | Olympus EVOLT E-300 Digital Camera

Not finding what you are looking for?
Olympus EVOLT E-300 Digital Camera Logo

1,099 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Digital Cameras Experts

kakima

Level 3 Expert

96333 Answers

Willem.
Willem.

Level 2 Expert

345 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Olympus Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...