Question about Jl Audio E1200 Car Audio Amplifier

2 Answers

Have a jl 500.1 amp

When playing the amp sometime the amp dont play it show the power light green blinking and dont hear nothing out of my jl w6

Posted by on

  • heyomar Sep 30, 2008

    I have a 300.2 v2 amp that did the same thing, and have a JL W6v2
    does any one know the solution to this??
    my battery voltage is normal at 12.5 volts when its not turned on. not to sure about when it is turned on.. but anyways could it be the alternator???

  • Anonymous Mar 16, 2014

    blinking green light on jl xd600 amp

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 323 Answers

I thought I would add, this can damage your amp, you definitely want to lower your gains on the amp or change the wiring diagram you are using on your subs.
http://www.jbl.com/car/product_support/SubwooferWiring/sub_wiring_diagram.aspx
www.onlinecarstereo.com is currently running a sale on the kinetic capacitors if interested. I just bought one of their batteries and it is doing wonders for my audio system.

http://www.onlinecarstereo.com/CarAudio/ProductDetail.aspx?ProductID=20378

Posted on Feb 11, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 160 Answers

For that amp u need a compasitor to mantain the amps the amp draws the amp is being choked when the car is off and when its running its killing the cars charging system

Posted on Dec 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ok i have a jl500/1v2 amp with 2 w6v2 subs and i haveing a problem dont no if the amp is two much for the subs becouse i turn the amp to get more tump and the subs pop and the yellow light filkes so i turn...


its real simple. your under powered.

your W6s RMS at 500 watts EACH and your sending em 250RMS (half what they need)
The 'pop' your hearing is the failure to supply enough power to draw the cone back in time and collides with the next wave of sound.

prove it?
drive a single W6 with your 500/1 bridged.
i'll bet your pop goes away.

long term, get another 500/1 or jump up to a 1000/1v2.

I also HIGHLY recommend JL's in-line audio cleaner. If i recall it was like 60 bucks but waaaay worth it. makes sure that theres no distortion in the source input to your amp(s), which...keeps your subs from trying to reproduce transients and delivers only clear signal to your subs void of all clipping signals. Its an active electronic compoent.


PS: if you are pushing 12W6's, i had the same setup once...I had W3s connected to my 500/1 and upgraded to the W6s...had the same issue your describing, and then got the 1000/1. happy ending.

May 03, 2011 | Jl Audio 500/1V2 Car Amp

1 Answer

My amp jl audio 500/1 i connect it and the green light turn on then i turn in the sterio and it sounds but when i turn off the sterio and when i wanna turn it on again the amp dont turn on i dont know why


Check the remote lead and see if it is getting power at the amp when it won't come on that way you know if the issue is with the head unit or the amplifier.

Mar 08, 2011 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

THERMAL LIGHT IS BLINKING AN THERE IS NO SOUND. WHAT DO I NEED TO DO


Your amp has overheated. You need to pick a new place to mount it, somewhere with better ventilation, or you can buy a cooling device for it. The only other option is to play your music quieter because the amp cannot handle the power output you are requesting without overheating. The light will not go off until the amp's heatsink drops to a temperature level safe enough for normal operation.

Mar 06, 2011 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My jl 500.1 amp dosent play anything.


you have your sub wired incorrectly. your amp shouldn't get hot unless you're settings are too high or your'e sending too small of an ohm load to the amp. this would cause it to heat up and will fry your amp.

May 30, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs


maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Fried amp


Hello zadiel89,

Out-of-warranty JL Audio products are normally repaired through JL's authorized dealer network.

To locate your nearest JL dealer, enter your zip code in the box on this page, select "radius" from the drop down, and click "find".

http://mobile.jlaudio.com/dealerfind.php

You can email JL directly at: technical@jlaudio.com

Hope this helps.

Aug 21, 2009 | Jl Audio Car Amplifiers

1 Answer

Got jl300/2 amp confused which subwoofer sounds good


Hello drsubhakar26,

JL W6's will perform well with from 150-600 watts RMS. W7's with from 150-500 watts. Less expensive Alpine Type R's work OK with from 200-500 watts RMS. Either of the brands will sound good. None of them will perform to their full potential with 300 watts RMS. Powering any sub with a 2-channel amp is a compromise. A monoblock is more efficient.

Hope this helps.

Jul 12, 2009 | Jl Audio Slash 300/2 Car Audio Amplifier

1 Answer

I HAVE A JL AUDIO MONOBLOCK AMP 250


It indicating that the power output is too loud and possibility of speakers may get damaged if played at this volume for long periods. When the loudest sound is played the led light mightshow its loosing its brightness and dims in time with the sound level.......................sodeep

Jan 17, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Rca Connection


You need to check the shield ground on the head unit. The following link will guide you through the test procedure.

Shield Ground Testing

Jun 07, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl 500/1


Nine times out of ten if the amp smells burnt it usuallly is. Your best bet is to hook another amp to your system and see if you get sound.

Jan 30, 2008 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio E1200 Car Audio Amplifier Logo

398 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Sudeep Chatterjee
Sudeep Chatterjee

Level 3 Expert

3267 Answers

Are you a Jl Audio Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...