Question about AudioBahn A2200HCT Car Audio Amplifier

1 Answer

Red Status Light

Ok...i have an a2200hct amplifier, it powers on, i have everything connected right..it's grounded well, but yet the red light comes on in between my meters! i opened it up and looked for any burns,cracks,or noticable differences on the compacitors and board,but didn't anything..So please just throw me some options i can go through?thanx

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

The most common cause for the protection LED to be lit is shorted output transistors. I'm not familiar with that amp but if you can send me some decent quality photos of the insides, I can tell you what to check.

You should only continue if you intend to replace the defective transistors yourself.

babin_perry@yahoo.com

Posted on Jun 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have my amp hooked up right to two 12 inch subs but the red protect light comes on wht does this mean?


Check all your cable work.
Power is connected tight? Ground is attached tight - on both ends (my guess is it is the ground) Remote cable?
Is the ground a proper ground?

Mar 01, 2011 | Dual XPA2100 2/1 Channel 300 Watt...

2 Answers

Ok so my Nitro BMW - 481 2000w amp was working and then i came back the next day and the red protect light was on its been working for weeks but now it has the red light.


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. ok-nitro-bmw-481-2000w-amp-working-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg http://www.nitrobmw.com/

Mar 17, 2010 | Nitro BMW-481 Car Audio Amplifier

1 Answer

Power light turns red


Make sure the red, yellow, and remote cable (usually blue and white stripes) that are coming from the radio are connected to the correct positions in the amp. Make sure amp is also grounded well enough that the ground cable does not come loose. make Sure none of the cables touch each other or the frame of the car (except for ground). Also make sure the cables for the speakers are connected to the amp and subs/speakers properly and not touch any part of the amp or other cables. Check the cables then write again if it happens again.

Sep 28, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

When just wblue wire is connected red light comes on


This sounds normal. The light comes on when there is 12v supplied to the blue wire (remote input). Need more details. brian.small@bobstgroup.com

Sep 13, 2009 | Pioneer GM-5200T Car Audio Amplifier

2 Answers

Hi there just picked up a jbl bp 1200 for good price although just wired it up and turned the key to find the red light come on few seconds then solid green and no sound...checked ground,remote wire rca...


Most amps do a "power up" where all the lights can come on, then settle into "green light" or some sort of "ready status" light comes on. The red or yellow lights can indicate "protection mode" (a bad amp) and green is the universal signal for okay. - So try this - Double check your connections and the amp. Pay close attention to the settings on the amp before you declare it not working. I have had many amps (especially newer ones) cause problems from a simple switch that was in the wrong position. Be sure to use good power and audio cables matched to your amps capabilities with good strong grounds on a clean non-painted metal surface. If all is in order from there start checking your signal from the deck to the amp. You can also check manufactures website for the manual, (if you didn't get one) looking at it may give a clue about proper switch configurations and hook-ups. Let me know if you need additional info concerning these idea's.
-Dynami

Apr 15, 2009 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Protection light just blink on and off


check that your ground wire is connected properly to both your amp and body of vehcile you may need a thicker earth wire

Mar 23, 2009 | Power Acoustik LT-980/2 Car Audio...

2 Answers

Red amp light


some parts are damaged ,maybe audio amplifiers IC´s or power fet´s

Mar 16, 2009 | Insignia 600W Bridgeable Amplifier with...

2 Answers

Amp light is neither green or red


have u connectted the remote wire from head unit to turn amp on? have u got + and - the rite way round.hope this of use.

Mar 05, 2009 | Power Acoustik PS2-1250 Car Audio...

1 Answer

Mine is actually a q4000 4 channel amp


First of all, you MUST HOOK UP YOUR GROUND WIRE FIRST. You may have damaged it if you hooked your power and trigger wire first and then the ground wire. Unhook EVERYTHING except the hot wire, ground wire and trigger wire. If you still can't get the unit to come on then it is time for a trip to the repair shop. Good luck.

Feb 01, 2007 | Cadence Q200 2 CHANNEL POWER AMPLIFIER...

Not finding what you are looking for?
AudioBahn A2200HCT Car Audio Amplifier Logo

Related Topics:

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you an AudioBahn Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...